aboutsummaryrefslogtreecommitdiff
path: root/graphics/ilmbase
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2020-05-08 11:57:55 +0000
committerMatthias Andree <mandree@FreeBSD.org>2020-05-08 11:57:55 +0000
commitded32047a723b1a1fde99db2077174e186424cb9 (patch)
tree80c1887fbd11c77022d8b87d4a2d2ab6c4249c63 /graphics/ilmbase
parent19b03a9a1019b86077c231c9619e2372572700c4 (diff)
downloadports-ded32047a723b1a1fde99db2077174e186424cb9.tar.gz
ports-ded32047a723b1a1fde99db2077174e186424cb9.zip
graphics/ilmbase: graphics/openexr: update to v2.5.0
ChangeLog: - https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v2.5.0 * Bump PORTREVISION of all consumers except py-openimageio (BROKEN). * cad/PrusaSlicer: LIB_DEPENDS: remove version from libHalf.so BUILD_DEPENDS+=qt5-buildtools as package (needed on bare metal builds) USE_GL+=gl USES+=pkgconfig (needed to find libHalf)
Notes
Notes: svn path=/head/; revision=534388
Diffstat (limited to 'graphics/ilmbase')
-rw-r--r--graphics/ilmbase/Makefile55
-rw-r--r--graphics/ilmbase/distinfo6
-rw-r--r--graphics/ilmbase/files/patch-config_CMakeLists.txt24
-rw-r--r--graphics/ilmbase/pkg-plist5
4 files changed, 26 insertions, 64 deletions
diff --git a/graphics/ilmbase/Makefile b/graphics/ilmbase/Makefile
index 3f8e02bd1acf..2a68ea9471ee 100644
--- a/graphics/ilmbase/Makefile
+++ b/graphics/ilmbase/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= ilmbase
-PORTVERSION= 2.4.1
-PORTREVISION= 1
+PORTVERSION= 2.5.0
CATEGORIES= graphics devel
MAINTAINER= mandree@FreeBSD.org
@@ -11,54 +10,42 @@ COMMENT= ILM Base libraries a.k.a. Half, IlmThread, Imath, and Iex
LICENSE= BSD3CLAUSE
-# there are some systems that have a static /bin/bash, so
-# in order to make BUILD_DEPENDS effective, use the same absolute
-# path we will pass down through CONFIGURE_SHELL below.
-BUILD_DEPENDS= ${BASH_CMD}:shells/bash
-
-USES= cmake compiler:c++14-lang pkgconfig libtool
-USE_LDCONFIG= yes
+USES= cmake compiler:c++14-lang libtool pkgconfig
USE_GITHUB= yes
GH_TUPLE= AcademySoftwareFoundation:openexr:v${PORTVERSION}
-WRKSRC_SUBDIR= IlmBase
+USE_LDCONFIG= yes
-PORTDOCS= README.md
-OPTIONS_DEFINE= DOCS LARGE_STACK
-LARGE_STACK_DESC= Enable sys-dependent large stack optimizations
-LARGE_STACK_CONFIGURE_ENABLE= large-stack
-LARGE_STACK_CMAKE_BOOL= ILMBASE_ENABLE_LARGE_STACK
+CMAKE_ARGS+= --target \
+ -DCMAKE_INSTALL_PREFIX=${PREFIX} \
+ install
-CMAKE_ARGS+= -DCMAKE_INSTALL_PREFIX=${PREFIX} --target install
+WRKSRC_SUBDIR= IlmBase
-BASH_CMD= ${LOCALBASE}/bin/bash
+PLIST_SUB= MAJORVER=${_MAJORVER} \
+ VER=${_VER}
+PORTDOCS= README.md
+OPTIONS_DEFINE= DOCS LARGE_STACK
OPTIONS_SUB= yes
-MAJORVER= 2_4
-VER= 24
-
-PLIST_SUB= MAJORVER=${MAJORVER}
-PLIST_SUB+= VER=${VER}
-
-HALF_BIN= eLut toFloat
+LARGE_STACK_DESC= Enable sys-dependent large stack optimizations
+LARGE_STACK_CMAKE_BOOL= ILMBASE_ENABLE_LARGE_STACK
+LARGE_STACK_CONFIGURE_ENABLE= large-stack
-test regression-test regression check::
- cd ${BUILD_WRKSRC} && ctest
+_MAJORVER= 2_5
+_VER= 24
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libHalf-${MAJORVER}.so
- ${RM} ${STAGEDIR}${PREFIX}/lib/*.la
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libHalf-${_MAJORVER}.so
.for l in libHalf libIex libIexMath libImath libIlmThread
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${l}-${MAJORVER}.so
- ${LN} -s ${l}-${MAJORVER}.so.${VER} ${STAGEDIR}${PREFIX}/lib/${l}.so || :
-.endfor
-
-.for e in ${HALF_BIN}
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/Half/${e} ${STAGEDIR}${PREFIX}/bin/${e}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${l}-${_MAJORVER}.so
.endfor
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+do-test:
+ cd ${BUILD_WRKSRC} && ctest
+
.include <bsd.port.mk>
diff --git a/graphics/ilmbase/distinfo b/graphics/ilmbase/distinfo
index 4ee213965165..0fa714cba853 100644
--- a/graphics/ilmbase/distinfo
+++ b/graphics/ilmbase/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1581526768
-SHA256 (AcademySoftwareFoundation-openexr-2.4.1-v2.4.1_GH0.tar.gz) = 3ebbe9a8e67edb4a25890b98c598e9fe23b10f96d1416d6a3ff0732e99d001c1
-SIZE (AcademySoftwareFoundation-openexr-2.4.1-v2.4.1_GH0.tar.gz) = 26809861
+TIMESTAMP = 1588893233
+SHA256 (AcademySoftwareFoundation-openexr-2.5.0-v2.5.0_GH0.tar.gz) = ea1d786806045682461df1882dd36667d868bb7b41bb5307f8b87ff314328bcb
+SIZE (AcademySoftwareFoundation-openexr-2.5.0-v2.5.0_GH0.tar.gz) = 27522236
diff --git a/graphics/ilmbase/files/patch-config_CMakeLists.txt b/graphics/ilmbase/files/patch-config_CMakeLists.txt
deleted file mode 100644
index 89525edad2d8..000000000000
--- a/graphics/ilmbase/files/patch-config_CMakeLists.txt
+++ /dev/null
@@ -1,24 +0,0 @@
-From fe2fccde18bc35db11895718d0b77d3f23d427b5 Mon Sep 17 00:00:00 2001
-From: Kimball Thurston <kdt3rd@gmail.com>
-Date: Tue, 5 Nov 2019 21:42:45 +1300
-Subject: [PATCH] Fix #595 and others, issue with pkgconfig generation under
- cmake
-
-autoconf seems to automatically insert the ${prefix} variable reference
-when emitting the pkg-config file. Make cmake rules conform to that
-pattern.
---- config/CMakeLists.txt.orig 2019-09-18 01:02:06 UTC
-+++ config/CMakeLists.txt
-@@ -71,9 +71,9 @@ if(ILMBASE_INSTALL_PKG_CONFIG)
- # use a helper function to avoid variable pollution, but pretty simple
- function(ilmbase_pkg_config_help pcinfile)
- set(prefix ${CMAKE_INSTALL_PREFIX})
-- set(exec_prefix ${CMAKE_INSTALL_BINDIR})
-- set(libdir ${CMAKE_INSTALL_LIBDIR})
-- set(includedir ${CMAKE_INSTALL_INCLUDEDIR})
-+ set(exec_prefix "\${prefix}")
-+ set(libdir "\${exec_prefix}/${CMAKE_INSTALL_LIBDIR}")
-+ set(includedir "\${prefix}/${CMAKE_INSTALL_INCLUDEDIR}")
- set(LIB_SUFFIX_DASH ${ILMBASE_LIB_SUFFIX})
- if(TARGET Threads::Threads)
- # hrm, can't use properties as they end up as generator expressions
diff --git a/graphics/ilmbase/pkg-plist b/graphics/ilmbase/pkg-plist
index 8eac4668eadd..0250cbb4a735 100644
--- a/graphics/ilmbase/pkg-plist
+++ b/graphics/ilmbase/pkg-plist
@@ -1,5 +1,3 @@
-bin/eLut
-bin/toFloat
include/OpenEXR/Iex.h
include/OpenEXR/IexBaseExc.h
include/OpenEXR/IexErrnoExc.h
@@ -57,9 +55,10 @@ include/OpenEXR/half.h
include/OpenEXR/halfExport.h
include/OpenEXR/halfFunction.h
include/OpenEXR/halfLimits.h
-lib/cmake/IlmBase/IlmBaseConfig-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/IlmBase/IlmBaseConfig.cmake
lib/cmake/IlmBase/IlmBaseConfigVersion.cmake
+lib/cmake/IlmBase/IlmBaseTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/IlmBase/IlmBaseTargets.cmake
lib/libHalf-%%MAJORVER%%.so
lib/libHalf-%%MAJORVER%%.so.%%VER%%
lib/libHalf-%%MAJORVER%%.so.%%VER%%.0.0