aboutsummaryrefslogtreecommitdiff
path: root/graphics/imagesort
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-10 19:50:00 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-10 19:50:00 +0000
commit9d706491b8dbe3e7592240b37cb421cb1dc52dd5 (patch)
tree48154b5fe5a6bc2a169e31b95b1e4bdbc8766b53 /graphics/imagesort
parent0911d806ccbddc2c7f5942699fe54113e3e2adef (diff)
downloadports-9d706491b8dbe3e7592240b37cb421cb1dc52dd5.tar.gz
ports-9d706491b8dbe3e7592240b37cb421cb1dc52dd5.zip
Notes
Diffstat (limited to 'graphics/imagesort')
-rw-r--r--graphics/imagesort/Makefile28
-rw-r--r--graphics/imagesort/distinfo1
-rw-r--r--graphics/imagesort/files/patch-Makefile20
-rw-r--r--graphics/imagesort/pkg-comment1
-rw-r--r--graphics/imagesort/pkg-descr6
-rw-r--r--graphics/imagesort/pkg-plist3
6 files changed, 59 insertions, 0 deletions
diff --git a/graphics/imagesort/Makefile b/graphics/imagesort/Makefile
new file mode 100644
index 000000000000..3f549a5d6b33
--- /dev/null
+++ b/graphics/imagesort/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: imagesort
+# Date created: Apr 10, 2001
+# Whom: Mark Pulford <mark@kyne.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= imagesort
+PORTVERSION= 2.0
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= apps/graphics/viewers/X
+
+MAINTAINER= mark@kyne.com.au
+
+LIB_DEPENDS= Imlib.5:${PORTSDIR}/graphics/imlib
+
+USE_X_PREFIX= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/imagesort ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/imagesort
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/imagesort
+ ${INSTALL_DATA} ${WRKSRC}/imagesortrc.sample ${PREFIX}/share/doc/imagesort
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/imagesort/distinfo b/graphics/imagesort/distinfo
new file mode 100644
index 000000000000..62890083c643
--- /dev/null
+++ b/graphics/imagesort/distinfo
@@ -0,0 +1 @@
+MD5 (imagesort-2.0.tar.gz) = fcb4aff8239eeb3988064df19c3fc081
diff --git a/graphics/imagesort/files/patch-Makefile b/graphics/imagesort/files/patch-Makefile
new file mode 100644
index 000000000000..559dd89e5852
--- /dev/null
+++ b/graphics/imagesort/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig Tue Apr 10 18:16:03 2001
++++ Makefile Tue Apr 10 18:18:54 2001
+@@ -7,15 +7,14 @@
+
+ # you may need to change this if you lack gcc (in which case you may
+ # not be able to compile at all
+-CC = gcc
+
+ # you'll probably have to dick with the libs, depending on how your imlib
+ # is compiled. We default to including all of the extras supported by
+ # imlib 1.9
+-LIBS = -lX11 -lXext -lImlib -ljpeg -lm -lpng -ltiff -lz -lgif
++LIBS = -lX11 -lXext -lImlib -ljpeg -lm -lpng -ltiff -lz -lungif
+ #LIBS = -lImlib -lX11 -lXext -ljpeg -lgif -lm
+
+-CFLAGS = -g -L$(XDIR)/lib -I$(XDIR)/include
++CFLAGS += -L$(LOCALBASE)/lib -L$(X11BASE)/lib -I$(X11BASE)/include
+
+ all: imagesort.o
+
diff --git a/graphics/imagesort/pkg-comment b/graphics/imagesort/pkg-comment
new file mode 100644
index 000000000000..ba8dec4954aa
--- /dev/null
+++ b/graphics/imagesort/pkg-comment
@@ -0,0 +1 @@
+A flexible X utility for managing many image files
diff --git a/graphics/imagesort/pkg-descr b/graphics/imagesort/pkg-descr
new file mode 100644
index 000000000000..ff0e1c13321b
--- /dev/null
+++ b/graphics/imagesort/pkg-descr
@@ -0,0 +1,6 @@
+Imagesort is a flexible utility for managing a large number of images.
+Via a configuration file (~/.imagesortrc) various commands are bound
+to keys allowing you to quickly process your images while you flick
+throught them. Documentation can be found in share/doc/imagesort.
+
+WWW: http://sammy.net/~sammy/hacks/
diff --git a/graphics/imagesort/pkg-plist b/graphics/imagesort/pkg-plist
new file mode 100644
index 000000000000..a2458a0b4d38
--- /dev/null
+++ b/graphics/imagesort/pkg-plist
@@ -0,0 +1,3 @@
+bin/imagesort
+%%PORTDOCS%%share/doc/imagesort/README
+%%PORTDOCS%%share/doc/imagesort/imagesortrc.sample