aboutsummaryrefslogtreecommitdiff
path: root/graphics/imagesort
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-10-29 21:12:52 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-10-29 21:12:52 +0000
commit58c2a61181405804ed4c747aaf2fa4bc2d7ebd40 (patch)
treeca9284e5494508244572d214c88d513cb232a468 /graphics/imagesort
parentbffa8320d839ba417f82b3961134877a1d2c000a (diff)
downloadports-58c2a61181405804ed4c747aaf2fa4bc2d7ebd40.tar.gz
ports-58c2a61181405804ed4c747aaf2fa4bc2d7ebd40.zip
Notes
Diffstat (limited to 'graphics/imagesort')
-rw-r--r--graphics/imagesort/Makefile44
-rw-r--r--graphics/imagesort/files/patch-Makefile20
-rw-r--r--graphics/imagesort/pkg-plist4
3 files changed, 28 insertions, 40 deletions
diff --git a/graphics/imagesort/Makefile b/graphics/imagesort/Makefile
index bb600d199c46..e68532c1a1f8 100644
--- a/graphics/imagesort/Makefile
+++ b/graphics/imagesort/Makefile
@@ -1,36 +1,48 @@
-# New ports collection makefile for: imagesort
-# Date created: Apr 10, 2001
-# Whom: Mark Pulford <mark@kyne.com.au>
-#
+# Created by: Mark Pulford <mark@kyne.com.au>
# $FreeBSD$
-# $MCom: ports/graphics/imagesort/Makefile,v 1.1 2006/10/04 13:18:57 ahze Exp $
PORTNAME= imagesort
PORTVERSION= 2.0
PORTREVISION= 11
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_SUNSITE}
-MASTER_SITE_SUBDIR= apps/graphics/viewers/X
+MASTER_SITES= SUNSITE/apps/graphics/viewers/X
MAINTAINER= ports@FreeBSD.org
COMMENT= A flexible X utility for managing many image files
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- gif.5:${PORTSDIR}/graphics/giflib
+LICENSE= GPLv2
-BROKEN= does not compile
+LIB_DEPENDS= gif:${PORTSDIR}/graphics/giflib \
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ png15:${PORTSDIR}/graphics/png
+
+OPTIONS_DEFINE= DOCS
USE_XORG= x11 xt
USE_GNOME= imlib
-CFLAGS:= ${CFLAGS} -I${LOCALBASE}/include
+MAKE_JOBS_SAFE= yes
+
+PORTDOCS= README imagesortrc.sample
+PLIST_FILES= bin/imagesort
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/^CC/s| =| ?=| ; \
+ /^LIBS/s| =.*| = `imlib-config --libs`| ; \
+ /^CFLAGS/s| =.*| += `imlib-config --cflags`|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e \
+ 's|unsigned int argc|int argc| ; \
+ s|^#endif.*|#endif|' ${WRKSRC}/imagesort.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/imagesort ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/imagesort
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/imagesort
- ${INSTALL_DATA} ${WRKSRC}/imagesortrc.sample ${PREFIX}/share/doc/imagesort
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
.endif
.include <bsd.port.mk>
diff --git a/graphics/imagesort/files/patch-Makefile b/graphics/imagesort/files/patch-Makefile
deleted file mode 100644
index f54af2485219..000000000000
--- a/graphics/imagesort/files/patch-Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.orig Tue Apr 10 18:16:03 2001
-+++ Makefile Tue Apr 10 18:18:54 2001
-@@ -7,15 +7,14 @@
-
- # you may need to change this if you lack gcc (in which case you may
- # not be able to compile at all
--CC = gcc
-
- # you'll probably have to dick with the libs, depending on how your imlib
- # is compiled. We default to including all of the extras supported by
- # imlib 1.9
--LIBS = -lX11 -lXext -lImlib -ljpeg -lm -lpng -ltiff -lz -lgif
-+LIBS = -lX11 -lXext -lImlib -ljpeg -lm -lpng -ltiff -lz -lgif
- #LIBS = -lImlib -lX11 -lXext -ljpeg -lgif -lm
-
--CFLAGS = -g -L$(XDIR)/lib -I$(XDIR)/include
-+CFLAGS += -L$(LOCALBASE)/lib -I$(LOCALBASE)/include
-
- all: imagesort.o
-
diff --git a/graphics/imagesort/pkg-plist b/graphics/imagesort/pkg-plist
deleted file mode 100644
index 5959c5f85bba..000000000000
--- a/graphics/imagesort/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-bin/imagesort
-%%PORTDOCS%%share/doc/imagesort/README
-%%PORTDOCS%%share/doc/imagesort/imagesortrc.sample
-%%PORTDOCS%%@dirrm share/doc/imagesort