aboutsummaryrefslogtreecommitdiff
path: root/graphics/imageworsener
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-03-15 18:48:53 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-03-15 18:48:53 +0000
commit2031fcad6d53eb4aa418045487d75ee9b05c670d (patch)
treea1e6d781ab43c5919fe801bc8e3014b838d94e35 /graphics/imageworsener
parent72b0ec8ad2debc00c9e7505286aa1d4935fc41cf (diff)
downloadports-2031fcad6d53eb4aa418045487d75ee9b05c670d.tar.gz
ports-2031fcad6d53eb4aa418045487d75ee9b05c670d.zip
- Add imageworsener 1.2.0
ImageWorsener is a cross-platform command-line utility and library for image scaling and other image processing. It has full support for PNG, JPEG, BMP formats, experimental support for WebP, read-only support for GIF, and limited support for some other image formats. It's not as fast or memory-efficient as some utilities, but it's very accurate. WWW: http://entropymine.com/imageworsener/
Notes
Notes: svn path=/head/; revision=348372
Diffstat (limited to 'graphics/imageworsener')
-rw-r--r--graphics/imageworsener/Makefile37
-rw-r--r--graphics/imageworsener/distinfo2
-rw-r--r--graphics/imageworsener/pkg-descr7
-rw-r--r--graphics/imageworsener/pkg-plist6
4 files changed, 52 insertions, 0 deletions
diff --git a/graphics/imageworsener/Makefile b/graphics/imageworsener/Makefile
new file mode 100644
index 000000000000..56c4d198a08b
--- /dev/null
+++ b/graphics/imageworsener/Makefile
@@ -0,0 +1,37 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= imageworsener
+PORTVERSION= 1.2.0
+CATEGORIES= graphics
+MASTER_SITES= http://entropymine.com/imageworsener/ \
+ LOCAL/sunpoet
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= CLI utility and library for image scaling and processing
+
+LICENSE= MIT
+
+OPTIONS_DEFINE= JPEG PNG WEBP
+OPTIONS_DEFAULT=JPEG PNG WEBP
+
+CONFIGURE_ARGS= --with-zlib-include-dir=${INCLUDEDIR} \
+ --with-zlib-lib-dir=${LIBDIR}
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+JPEG_CONFIGURE_OFF= --without-jpeg
+JPEG_CONFIGURE_ON= --with-jpeg-include-dir=${LOCALBASE}/include --with-jpeg-lib-dir=${LOCALBASE}/lib
+JPEG_LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
+PNG_CONFIGURE_OFF= --without-png
+PNG_CONFIGURE_ON= --with-png-include-dir=${LOCALBASE}/include --with-png-lib-dir=${LOCALBASE}/lib
+PNG_LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
+WEBP_CONFIGURE_OFF= --without-webp
+WEBP_CONFIGURE_ON= --with-webp-include-dir=${LOCALBASE}/include --with-webp-lib-dir=${LOCALBASE}/lib
+WEBP_LIB_DEPENDS= libwebp.so:${PORTSDIR}/graphics/webp
+
+post-build:
+ @${STRIP_CMD} ${WRKSRC}/.libs/libimageworsener.so.2
+
+.include <bsd.port.mk>
diff --git a/graphics/imageworsener/distinfo b/graphics/imageworsener/distinfo
new file mode 100644
index 000000000000..bbb7f978ccfd
--- /dev/null
+++ b/graphics/imageworsener/distinfo
@@ -0,0 +1,2 @@
+SHA256 (imageworsener-1.2.0.tar.gz) = 97fdb1aafac7bc2339b2ce813071f0900de0b093b96ab1a99a43f9647afdfe35
+SIZE (imageworsener-1.2.0.tar.gz) = 635509
diff --git a/graphics/imageworsener/pkg-descr b/graphics/imageworsener/pkg-descr
new file mode 100644
index 000000000000..033de0c0000d
--- /dev/null
+++ b/graphics/imageworsener/pkg-descr
@@ -0,0 +1,7 @@
+ImageWorsener is a cross-platform command-line utility and library for image
+scaling and other image processing. It has full support for PNG, JPEG, BMP
+formats, experimental support for WebP, read-only support for GIF, and limited
+support for some other image formats. It's not as fast or memory-efficient as
+some utilities, but it's very accurate.
+
+WWW: http://entropymine.com/imageworsener/
diff --git a/graphics/imageworsener/pkg-plist b/graphics/imageworsener/pkg-plist
new file mode 100644
index 000000000000..4512c4f5501f
--- /dev/null
+++ b/graphics/imageworsener/pkg-plist
@@ -0,0 +1,6 @@
+bin/imagew
+include/imagew.h
+lib/libimageworsener.a
+lib/libimageworsener.la
+lib/libimageworsener.so
+lib/libimageworsener.so.2