aboutsummaryrefslogtreecommitdiff
path: root/graphics/imc
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2013-03-24 19:58:04 +0000
committerBeech Rintoul <beech@FreeBSD.org>2013-03-24 19:58:04 +0000
commit0d8b4648c9fb455893c0fe5da5b23df110d0281e (patch)
tree63d76cd62066a7c634a923826ec8f2fcc6952764 /graphics/imc
parent8d9cab40d58f69643e11401e16cb2432a08f3de1 (diff)
downloadports-0d8b4648c9fb455893c0fe5da5b23df110d0281e.tar.gz
ports-0d8b4648c9fb455893c0fe5da5b23df110d0281e.zip
Notes
Diffstat (limited to 'graphics/imc')
-rw-r--r--graphics/imc/Makefile39
-rw-r--r--graphics/imc/pkg-plist60
2 files changed, 26 insertions, 73 deletions
diff --git a/graphics/imc/Makefile b/graphics/imc/Makefile
index 90dd3cf360a6..f0373140a888 100644
--- a/graphics/imc/Makefile
+++ b/graphics/imc/Makefile
@@ -1,20 +1,17 @@
-# ex:ts=8
-# New ports collection makefile for: imc
-# Date created: Apr 30, 2002
-# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
-#
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= imc
PORTVERSION= 4.3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics
-MASTER_SITES= http://users.skynet.be/Peter.Verthez/projects/imc/
+MASTER_SITES= http://www.peterverthez.net/projects/imc/
MAINTAINER= ports@FreeBSD.org
COMMENT= Image Compiler
+LICENSE= GPLv2
+
BUILD_DEPENDS= p5-GD>=0:${PORTSDIR}/graphics/p5-GD \
p5-CGI.pm>=0:${PORTSDIR}/www/p5-CGI.pm
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -23,16 +20,32 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_PERL5= yes
-MAN1= imc.1
+PLIST_FILES= bin/${PORTNAME}
+MAN1= ${PORTNAME}.1
+
+PORTDOCS= *
+
+DOCSRCDIR1= ${WRKSRC}
+DOC_FILES1= AUTHORS ChangeLog NEWS README THANKS Todo
+
+DOCSRCDIR2= ${WRKSRC}/doc
+DOCSDIR2= ${DOCSDIR}/doc
+DOC_FILES2= *.html *.ref *.txt
+
+PORTEXAMPLES= *
+
+.include <bsd.port.options.mk>
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- ${CP} -R ${WRKSRC}/doc/* ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR2}
+ ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${DOCSDIR2}
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
- ${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
.endif
.include <bsd.port.mk>
diff --git a/graphics/imc/pkg-plist b/graphics/imc/pkg-plist
deleted file mode 100644
index 6b5565837a4a..000000000000
--- a/graphics/imc/pkg-plist
+++ /dev/null
@@ -1,60 +0,0 @@
-bin/imc
-%%PORTDOCS%%%%DOCSDIR%%/Makefile
-%%PORTDOCS%%%%DOCSDIR%%/Makefile.am
-%%PORTDOCS%%%%DOCSDIR%%/Makefile.in
-%%PORTDOCS%%%%DOCSDIR%%/imc.html
-%%PORTDOCS%%%%DOCSDIR%%/imc.ref
-%%PORTDOCS%%%%DOCSDIR%%/imc.txt
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile.am
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile.in
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/arc.imc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic.imc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basic2.imc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basicjpg.imc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basicgif.imc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/closedarc.imc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/closedarc2.imc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fill.imc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/grid200x200.imc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/imagealign1.imc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/imagealign2.imc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/imagerotate.imc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/imcmp.pl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/next.jpg
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/next.gif
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/next.png
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/origin.imc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/piechart.imc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref/Makefile.in
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref/Makefile.am
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref/arc.png.ref
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref/basic.png.ref
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref/basic2.png.ref
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref/basicjpg.png.ref
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref/basicgif.png.ref
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref/closedarc.png.ref
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref/closedarc2.png.ref
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref/fill.png.ref
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref/grid200x200.png.ref
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref/imagealign1.png.ref
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref/imagealign2.png.ref
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref/imagerotate.png.ref
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref/origin.png.ref
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref/piechart.png.ref
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref/text.png.ref
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref/textalign1.png.ref
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref/textalign2.png.ref
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref/textrotate.png.ref
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref/Makefile
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ref/transparent.png.ref
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rgb.txt
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test_script
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/text.imc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/textalign1.imc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/textalign2.imc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/textrotate.imc
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/transparent.imc
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/ref
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%