aboutsummaryrefslogtreecommitdiff
path: root/graphics/imgtops/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-03-17 06:38:41 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-03-17 06:38:41 +0000
commit708860990dc89497d6c3d2540b455651eff7f6b1 (patch)
tree116a46a6cf0a7ebd69b1452e3b2b5b078ddc5d98 /graphics/imgtops/Makefile
parent545a0e5e3792a350c4e118dd1284c838b87d86ce (diff)
downloadports-708860990dc89497d6c3d2540b455651eff7f6b1.tar.gz
ports-708860990dc89497d6c3d2540b455651eff7f6b1.zip
Notes
Diffstat (limited to 'graphics/imgtops/Makefile')
-rw-r--r--graphics/imgtops/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/graphics/imgtops/Makefile b/graphics/imgtops/Makefile
new file mode 100644
index 000000000000..0cb8c73c435f
--- /dev/null
+++ b/graphics/imgtops/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: imgtops
+# Date created: 17 Mar 2008
+# Whom: Timothy Bourke <timbob@bigpond.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= imgtops
+PORTVERSION= 1.0
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=${PORTNAME}
+
+MAINTAINER= timbob@bigpond.com
+COMMENT= Create efficient Encapsulated Postscript files from images
+
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/PIL.pth:${PORTSDIR}/graphics/py-imaging
+
+USE_GHOSTSCRIPT_RUN= yes
+USE_PYTHON= 2.2+
+USE_PYDISTUTILS= yes
+INSTALLS_EGGINFO= yes
+
+MAN1= imgtops.1 epstoimg.1
+
+post-install:
+ ${CHMOD} 644 ${MANPREFIX}/man/man1/imgtops.1
+ ${CHMOD} 644 ${MANPREFIX}/man/man1/epstoimg.1
+
+.include <bsd.port.mk>