aboutsummaryrefslogtreecommitdiff
path: root/graphics/imgv/Makefile
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2007-02-05 21:23:55 +0000
committerNicola Vitale <nivit@FreeBSD.org>2007-02-05 21:23:55 +0000
commitd8c68a06887565369b8dc065e28cd9121424b152 (patch)
tree243603cab961707b3c274a67d74b1e0d45d9c78c /graphics/imgv/Makefile
parent77e3e1eb2d53e51b9d8daee212bb3400249a5f83 (diff)
Features include a GUI that doesn't get in the way of viewing your images, a
file browser, slideshows, zooming, rotating, on-the-fly Exif viewing, histograms, fullscreen support, wallpaper setting, the ability to view 4 images on the screen at once, adjustable thumbnail sizes, playlists, view and download images from Web sites, movie playing, file searching/filtering, multiple directory loading, transitional effects, image hiding and more. Author: Ryan Kulla <rkulla@gmail.com> WWW: http://imgv.sourceforge.net/ PR: ports/108755 Submitted by: Simon Olofsson <simon at olofsson.de> Approved by: alexbl (mentor, implicit)
Notes
Notes: svn path=/head/; revision=184311
Diffstat (limited to 'graphics/imgv/Makefile')
-rw-r--r--graphics/imgv/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/graphics/imgv/Makefile b/graphics/imgv/Makefile
new file mode 100644
index 000000000000..c21d4c3756a8
--- /dev/null
+++ b/graphics/imgv/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: imgv
+# Date created: 2007-02-03
+# Whom: Simon Olofsson <simon@olofsson.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= imgv
+PORTVERSION= 3.1.5
+CATEGORIES= graphics python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= simon@olofsson.de
+COMMENT= A unique and feature rich Image Viewer
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygame/__init__.py:${PORTSDIR}/devel/py-game \
+ ${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imaging
+
+USE_PYTHON= 2.2+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,%%DATADIR%%,${DATADIR},' ${WRKSRC}/gl.py
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/imgv.py ${PREFIX}/bin/imgv
+ ${RM} -f ${WRKSRC}/imgv.py ${WRKSRC}/setup.py
+ ${MKDIR} ${DATADIR}/data
+ ${INSTALL_DATA} ${WRKSRC}/data/* ${DATADIR}/data
+ ${MKDIR} ${PYTHON_SITELIBDIR}/imgv/
+ ${TOUCH} ${PYTHON_SITELIBDIR}/imgv/__init__.py
+ ${INSTALL_DATA} ${WRKSRC}/*.py ${PYTHON_SITELIBDIR}/imgv/
+ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${PYTHON_SITELIBDIR}/imgv/
+
+.include <bsd.port.post.mk>