aboutsummaryrefslogtreecommitdiff
path: root/graphics/imlib2/Makefile
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2014-02-07 15:37:31 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2014-02-07 15:37:31 +0000
commitd44edd4247a0e978778f744dedf76a3037482c07 (patch)
tree798872b24f168aa11ea91d5c243516acba880fd3 /graphics/imlib2/Makefile
parent5f1cab02344c08e9b618ab8a9c981d2f7721fb8e (diff)
Notes
Diffstat (limited to 'graphics/imlib2/Makefile')
-rw-r--r--graphics/imlib2/Makefile29
1 files changed, 18 insertions, 11 deletions
diff --git a/graphics/imlib2/Makefile b/graphics/imlib2/Makefile
index f9ac96ab591a..993fd5eb2270 100644
--- a/graphics/imlib2/Makefile
+++ b/graphics/imlib2/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= imlib2
-PORTVERSION= 1.4.5
-PORTREVISION= 2
+PORTVERSION= 1.4.6
PORTEPOCH= 2
CATEGORIES= graphics enlightenment
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -12,20 +11,28 @@ MASTER_SITE_SUBDIR= enlightenment/imlib2-src/${PORTVERSION}
MAINTAINER= bf@FreeBSD.org
COMMENT= The next generation graphics library for Enlightenment
-LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+LICENSE= imlib2
+LICENSE_NAME= imlib2 license
+LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE_PERMS= auto-accept
+
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USES= pathfix pkgconfig
USE_EFL= libtool_hack
+USE_LDCONFIG= yes
+USES= pathfix pkgconfig
+
+CONFIGURE_ARGS+= --enable-visibility-hiding
+CONFIGURE_ENV+= ac_cv_lib_dl_dlopen=no
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_LDCONFIG= yes
+MAKE_ENV+= INSTALL_STRIP_FLAG="${STRIP}"
OPTIONS_DEFINE= JPEG PNG TIFF GIF ID3 X11
OPTIONS_DEFAULT= JPEG PNG TIFF GIF ID3 X11
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${ARCH} == "i386" && !empty(MACHINE_CPU:Mmmx)
@@ -49,7 +56,7 @@ PLIST_SUB= X11=""
.endif
.if ${PORT_OPTIONS:MJPEG}
-LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg
PLIST_SUB+= JPEG=""
.else
CONFIGURE_ARGS+= --without-jpeg
@@ -57,7 +64,7 @@ PLIST_SUB+= JPEG="@comment "
.endif
.if ${PORT_OPTIONS:MPNG}
-LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS+= libpng15.so:${PORTSDIR}/graphics/png
PLIST_SUB+= PNG=""
.else
CONFIGURE_ARGS+= --without-png
@@ -65,7 +72,7 @@ PLIST_SUB+= PNG="@comment "
.endif
.if ${PORT_OPTIONS:MTIFF}
-LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
+LIB_DEPENDS+= libtiff.so:${PORTSDIR}/graphics/tiff
PLIST_SUB+= TIFF=""
.else
CONFIGURE_ARGS+= --without-tiff
@@ -73,7 +80,7 @@ PLIST_SUB+= TIFF="@comment "
.endif
.if ${PORT_OPTIONS:MGIF}
-LIB_DEPENDS+= gif.5:${PORTSDIR}/graphics/giflib
+LIB_DEPENDS+= libgif.so:${PORTSDIR}/graphics/giflib
PLIST_SUB+= GIF=""
.else
CONFIGURE_ARGS+= --without-gif
@@ -81,7 +88,7 @@ PLIST_SUB+= GIF="@comment "
.endif
.if ${PORT_OPTIONS:MID3}
-LIB_DEPENDS+= id3tag.0:${PORTSDIR}/audio/libid3tag
+LIB_DEPENDS+= libid3tag.so:${PORTSDIR}/audio/libid3tag
PLIST_SUB+= ID3=""
.else
CONFIGURE_ARGS+= --without-id3