aboutsummaryrefslogtreecommitdiff
path: root/graphics/imlib2/Makefile
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2000-11-07 14:32:57 +0000
committerKevin Lo <kevlo@FreeBSD.org>2000-11-07 14:32:57 +0000
commitc61d65a8499a4f9b2e408b24d2ff6ea2f43c4ea3 (patch)
treeba4af28997ab05723c8912a8facf2ed04e3141a5 /graphics/imlib2/Makefile
parentb5ff91158303aee7e0f310a185a223393f57dbea (diff)
downloadports-c61d65a8499a4f9b2e408b24d2ff6ea2f43c4ea3.tar.gz
ports-c61d65a8499a4f9b2e408b24d2ff6ea2f43c4ea3.zip
Notes
Diffstat (limited to 'graphics/imlib2/Makefile')
-rw-r--r--graphics/imlib2/Makefile23
1 files changed, 16 insertions, 7 deletions
diff --git a/graphics/imlib2/Makefile b/graphics/imlib2/Makefile
index 9d55bd13d30c..861aa746d7d6 100644
--- a/graphics/imlib2/Makefile
+++ b/graphics/imlib2/Makefile
@@ -1,17 +1,18 @@
# New ports collection makefile for: imlib2
# Date created: 16 Oct 2000
-# Whom: >Jeremy Norris <ishmael27@home.com>
+# Whom: Jeremy Norris <ishmael27@home.com>
#
# $FreeBSD$
#
PORTNAME= imlib2
PORTVERSION= 1.0.0
+PORTREVISION= 1
CATEGORIES= graphics
-MASTER_SITES= ftp://ftp.enlightenment.org/pub/enlightenment/e17/libs/ \
- http://www.us.rasterman.com/files/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= enlightenment
-MAINTAINER= ports@FreeBSD.ORG
+MAINTAINER= ishmael27@home.com
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
@@ -32,8 +33,16 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ARGS= --enable-mmx
.endif
+post-configure:
+ @${PERL} -pi -e 's|\@localbase\@|${LOCALBASE}|g' ${WRKSRC}/imlib2-config
+
post-install:
- strip ${PREFIX}/lib/libImlib2.so.1
- strip ${PREFIX}/lib/loaders/filter/*
- strip ${PREFIX}/lib/loaders/image/*
+ @strip ${PREFIX}/lib/libImlib2.so.1
+.for i in bump_map colormod testfilter
+ @strip ${PREFIX}/lib/loaders/filter/${i}.so
+.endfor
+.for i in argb bmp db gif jpeg png pnm tga tiff xpm
+ @strip ${PREFIX}/lib/loaders/image/${i}.so
+.endfor
+
.include <bsd.port.post.mk>