aboutsummaryrefslogtreecommitdiff
path: root/graphics/imlib2
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-08-08 16:10:17 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-08-08 16:10:17 +0000
commitca20165cb5f39d324509ee8a7959d93d14d0dd45 (patch)
tree7038e0ebf3eb2c435d7c058a568f333f08e1d3c6 /graphics/imlib2
parent1ebb626e8c87b6f1d7b087a279bcba6d784b4e5a (diff)
downloadports-ca20165cb5f39d324509ee8a7959d93d14d0dd45.tar.gz
ports-ca20165cb5f39d324509ee8a7959d93d14d0dd45.zip
Notes
Diffstat (limited to 'graphics/imlib2')
-rw-r--r--graphics/imlib2/Makefile10
-rw-r--r--graphics/imlib2/distinfo4
-rw-r--r--graphics/imlib2/files/patch-Makefile.in11
-rw-r--r--graphics/imlib2/files/patch-aa11
-rw-r--r--graphics/imlib2/files/patch-configure95
-rw-r--r--graphics/imlib2/files/patch-loaders::Makefile.in16
-rw-r--r--graphics/imlib2/files/patch-ltmain.sh33
-rw-r--r--graphics/imlib2/files/patch-src::Makefile.in105
-rw-r--r--graphics/imlib2/files/patch-src_rgbadraw.c19
-rw-r--r--graphics/imlib2/pkg-plist40
10 files changed, 31 insertions, 313 deletions
diff --git a/graphics/imlib2/Makefile b/graphics/imlib2/Makefile
index a3376c145ea5..7ed3bc6b744b 100644
--- a/graphics/imlib2/Makefile
+++ b/graphics/imlib2/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= imlib2
-PORTVERSION= 1.1.0
+PORTVERSION= 1.1.1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= enlightenment
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= vanilla@FreeBSD.org
COMMENT= The next generation graphic library for enlightenment package
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
@@ -21,6 +21,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
freetype.9:${PORTSDIR}/print/freetype2
USE_LIBLTDL= yes
+USE_LIBTOOL_VER= 15
USE_X_PREFIX= yes
USE_GNOME= gnomehack pkgconfig
USE_REINPLACE= yes
@@ -35,7 +36,6 @@ INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-mmx
.endif
-post-configure:
- @${REINPLACE_CMD} -e 's|\@localbase\@|${LOCALBASE}|g' ${WRKSRC}/imlib2-config
-
.include <bsd.port.post.mk>
+
+CONFIGURE_TARGET:= --build=${CONFIGURE_TARGET}
diff --git a/graphics/imlib2/distinfo b/graphics/imlib2/distinfo
index 2c4110306adc..b4d438bf5e21 100644
--- a/graphics/imlib2/distinfo
+++ b/graphics/imlib2/distinfo
@@ -1,2 +1,2 @@
-MD5 (imlib2-1.1.0.tar.gz) = 1589ebb054da76734fe08ae570460034
-SIZE (imlib2-1.1.0.tar.gz) = 814851
+MD5 (imlib2-1.1.1.tar.gz) = 06b629285c163cd61a59db89377a0520
+SIZE (imlib2-1.1.1.tar.gz) = 871202
diff --git a/graphics/imlib2/files/patch-Makefile.in b/graphics/imlib2/files/patch-Makefile.in
deleted file mode 100644
index dbcada323685..000000000000
--- a/graphics/imlib2/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Fri Sep 21 12:31:03 2001
-+++ Makefile.in Sun Oct 7 17:26:29 2001
-@@ -93,7 +93,7 @@
- MAINTAINERCLEANFILES = INSTALL Makefile.in aclocal.m4 config.guess config.h.in config.sub configure install-sh ltconfig ltmain.sh missing mkinstalldirs stamp-h.in
-
-
--SUBDIRS = libltdl src filters doc loaders
-+SUBDIRS = src filters doc loaders
-
- bin_SCRIPTS = imlib2-config
-
diff --git a/graphics/imlib2/files/patch-aa b/graphics/imlib2/files/patch-aa
deleted file mode 100644
index 0a1f4f63e5e1..000000000000
--- a/graphics/imlib2/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- imlib2-config.in.orig Sun Jul 20 15:10:43 2003
-+++ imlib2-config.in Mon Dec 8 04:30:33 2003
-@@ -45,7 +45,7 @@
- echo $includes @x_cflags@
- ;;
- --libs)
-- libdirs=-L@libdir@
-+ libdirs=-L@libdir@ -L@localbase@/lib
- echo $libdirs -lImlib2 @freetype_libs@ -lm @dlopen_libs@ @x_ldflags@ @x_libs@
- ;;
- *)
diff --git a/graphics/imlib2/files/patch-configure b/graphics/imlib2/files/patch-configure
deleted file mode 100644
index c42001234b6b..000000000000
--- a/graphics/imlib2/files/patch-configure
+++ /dev/null
@@ -1,95 +0,0 @@
---- configure.orig Mon Sep 8 11:12:12 2003
-+++ configure Mon Dec 8 05:29:41 2003
-@@ -1244,16 +1244,6 @@
- fi
-
-
-- case $enable_ltdl_convenience in
-- no) { echo "configure: error: this package needs a convenience libltdl" 1>&2; exit 1; } ;;
-- "") enable_ltdl_convenience=yes
-- ac_configure_args="$ac_configure_args --enable-ltdl-convenience" ;;
-- esac
-- LIBLTDL='${top_builddir}/''libltdl'/libltdlc.la
-- INCLTDL='-I${top_srcdir}/''libltdl'
--
--subdirs="libltdl"
--
-
- # Extract the first word of "gcc", so it can be a program name with args.
- set dummy gcc; ac_word=$2
-@@ -7682,75 +7672,5 @@
- esac
- done
-
-- for ac_config_dir in libltdl; do
--
-- # Do not complain, so a configure script can configure whichever
-- # parts of a large source tree are present.
-- if test ! -d $srcdir/$ac_config_dir; then
-- continue
-- fi
--
-- echo configuring in $ac_config_dir
--
-- case "$srcdir" in
-- .) ;;
-- *)
-- if test -d ./$ac_config_dir || mkdir ./$ac_config_dir; then :;
-- else
-- { echo "configure: error: can not create `pwd`/$ac_config_dir" 1>&2; exit 1; }
-- fi
-- ;;
-- esac
--
-- ac_popdir=`pwd`
-- cd $ac_config_dir
--
-- # A "../" for each directory in /$ac_config_dir.
-- ac_dots=`echo $ac_config_dir|sed -e 's%^\./%%' -e 's%[^/]$%&/%' -e 's%[^/]*/%../%g'`
--
-- case "$srcdir" in
-- .) # No --srcdir option. We are building in place.
-- ac_sub_srcdir=$srcdir ;;
-- /*) # Absolute path.
-- ac_sub_srcdir=$srcdir/$ac_config_dir ;;
-- *) # Relative path.
-- ac_sub_srcdir=$ac_dots$srcdir/$ac_config_dir ;;
-- esac
--
-- # Check for guested configure; otherwise get Cygnus style configure.
-- if test -f $ac_sub_srcdir/configure; then
-- ac_sub_configure=$ac_sub_srcdir/configure
-- elif test -f $ac_sub_srcdir/configure.in; then
-- ac_sub_configure=$ac_configure
-- else
-- echo "configure: warning: no configuration information is in $ac_config_dir" 1>&2
-- ac_sub_configure=
-- fi
--
-- # The recursion is here.
-- if test -n "$ac_sub_configure"; then
--
-- # Make the cache file name correct relative to the subdirectory.
-- case "$cache_file" in
-- /*) ac_sub_cache_file=$cache_file ;;
-- *) # Relative path.
-- ac_sub_cache_file="$ac_dots$cache_file" ;;
-- esac
-- case "$ac_given_INSTALL" in
-- [/$]*) INSTALL="$ac_given_INSTALL" ;;
-- *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
-- esac
--
-- echo "running ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir"
-- # The eval makes quoting arguments work.
-- if eval ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir
-- then :
-- else
-- { echo "configure: error: $ac_sub_configure failed for $ac_config_dir" 1>&2; exit 1; }
-- fi
-- fi
--
-- cd $ac_popdir
-- done
- fi
-
diff --git a/graphics/imlib2/files/patch-loaders::Makefile.in b/graphics/imlib2/files/patch-loaders::Makefile.in
deleted file mode 100644
index 261021fbf73a..000000000000
--- a/graphics/imlib2/files/patch-loaders::Makefile.in
+++ /dev/null
@@ -1,16 +0,0 @@
---- loaders/Makefile.in.orig Mon Sep 8 11:12:29 2003
-+++ loaders/Makefile.in Mon Dec 8 05:09:37 2003
-@@ -99,10 +99,10 @@
- # A list of all the files in the current directory which can be regenerated
- MAINTAINERCLEANFILES = Makefile.in
-
--LDFLAGS = -L$(top_builddir)/src -L$(top_builddir)/src/.libs -L/usr/X11R6/lib
-+LDFLAGS = @LDFLAGS@
- INCLUDES = -I. -I$(top_srcdir) -I$(top_srcdir)/src \
-- -I$(top_srcdir)/loaders -I$(top_srcdir)/libltdl \
-- -I/usr/X11R6/include $(X_CFLAGS) \
-+ -I$(top_srcdir)/loaders \
-+ $(X_CFLAGS) \
- -I$(prefix)/include -I$(includedir)
-
-
diff --git a/graphics/imlib2/files/patch-ltmain.sh b/graphics/imlib2/files/patch-ltmain.sh
deleted file mode 100644
index 281979539cdb..000000000000
--- a/graphics/imlib2/files/patch-ltmain.sh
+++ /dev/null
@@ -1,33 +0,0 @@
---- ltmain.sh.orig Mon Sep 8 11:12:11 2003
-+++ ltmain.sh Mon Dec 8 05:15:45 2003
-@@ -944,6 +944,7 @@
- ;;
-
- -avoid-version)
-+ build_old_libs=no
- avoid_version=yes
- continue
- ;;
-@@ -2408,6 +2409,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this....
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
-@@ -4175,10 +4179,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/graphics/imlib2/files/patch-src::Makefile.in b/graphics/imlib2/files/patch-src::Makefile.in
deleted file mode 100644
index d39d0ff27235..000000000000
--- a/graphics/imlib2/files/patch-src::Makefile.in
+++ /dev/null
@@ -1,105 +0,0 @@
---- src/Makefile.in.orig Mon Sep 8 11:12:28 2003
-+++ src/Makefile.in Mon Dec 8 04:42:05 2003
-@@ -99,10 +99,10 @@
- # A list of all the files in the current directory which can be regenerated
- MAINTAINERCLEANFILES = Makefile.in loaderpath.h
-
--LDFLAGS = -L/usr/X11R6/lib
-+LDFLAGS = @LDFLAGS@
- INCLUDES = -I. -I$(top_srcdir) -I$(top_srcdir)/src \
-- -I$(top_srcdir)/loaders -I$(top_srcdir)/libltdl \
-- $(freetype_cflags) -I/usr/X11R6/include $(X_CFLAGS) \
-+ -I$(top_srcdir)/loaders \
-+ $(freetype_cflags) $(X_CFLAGS) \
- -I$(prefix)/include -I$(includedir)
-
- MMX_SRCS = asm_blend.S asm_rgba.S asm_scale.S asm_rotate.S \
-@@ -128,10 +128,10 @@
-
- libImlib2_la_LDFLAGS = -version-info 2:0:1
- @HAVE_MMX_TRUE@libImlib2_la_LIBADD = @HAVE_MMX_TRUE@$(X_OBJS) @DLLDFLAGS@ $(MMX_OBJS) \
--@HAVE_MMX_TRUE@ $(top_builddir)/libltdl/libltdlc.la \
-+@HAVE_MMX_TRUE@ -lltdl \
- @HAVE_MMX_TRUE@ $(x_libs) $(freetype_libs) $(LDFLAGS)
- @HAVE_MMX_FALSE@libImlib2_la_LIBADD = @HAVE_MMX_FALSE@$(X_OBJS) @DLLDFLAGS@ \
--@HAVE_MMX_FALSE@ $(top_builddir)/libltdl/libltdlc.la \
-+@HAVE_MMX_FALSE@ -lltdl \
- @HAVE_MMX_FALSE@ $(x_libs) $(freetype_libs) $(LDFLAGS)
- @HAVE_MMX_TRUE@libImlib2_la_DEPENDENCIES = @HAVE_MMX_TRUE@$(top_builddir)/config.h $(X_OBJS) $(MMX_OBJS)
- @HAVE_MMX_FALSE@libImlib2_la_DEPENDENCIES = @HAVE_MMX_FALSE@$(top_builddir)/config.h $(X_OBJS)
-@@ -314,57 +314,57 @@
- fi; \
- done
- api.lo api.o : api.c ../config.h common.h colormod.h image.h \
-- ../libltdl/ltdl.h scale.h blend.h context.h color.h grab.h \
-+ scale.h blend.h context.h color.h grab.h \
- rend.h rgba.h ximage.h draw.h file.h updates.h rgbadraw.h \
- Imlib2.h font.h grad.h rotate.h filter.h dynamic_filters.h \
- script.h color_helpers.h
- blend.lo blend.o : blend.c common.h ../config.h colormod.h image.h \
-- ../libltdl/ltdl.h blend.h scale.h
-+ blend.h scale.h
- color.lo color.o : color.c common.h ../config.h color.h
- color_helpers.lo color_helpers.o : color_helpers.c color_helpers.h
- colormod.lo colormod.o : colormod.c common.h ../config.h colormod.h \
-- image.h ../libltdl/ltdl.h file.h loaderpath.h blend.h
-+ image.h file.h loaderpath.h blend.h
- context.lo context.o : context.c common.h ../config.h image.h \
-- ../libltdl/ltdl.h context.h color.h rgba.h
-+ context.h color.h rgba.h
- draw.lo draw.o : draw.c common.h ../config.h colormod.h image.h \
-- ../libltdl/ltdl.h blend.h rend.h draw.h
-+ blend.h rend.h draw.h
- dynamic_filters.lo dynamic_filters.o : dynamic_filters.c common.h \
-- ../config.h image.h ../libltdl/ltdl.h file.h dynamic_filters.h \
-+ ../config.h image.h file.h dynamic_filters.h \
- script.h Imlib2.h loaderpath.h
- file.lo file.o : file.c common.h ../config.h file.h
- filter.lo filter.o : filter.c common.h ../config.h colormod.h image.h \
-- ../libltdl/ltdl.h blend.h filter.h
-+ blend.h filter.h
- font_draw.lo font_draw.o : font_draw.c ../config.h common.h colormod.h \
-- image.h ../libltdl/ltdl.h blend.h font.h file.h updates.h \
-+ image.h blend.h font.h file.h updates.h \
- rgbadraw.h rotate.h
- font_load.lo font_load.o : font_load.c ../config.h common.h colormod.h \
-- image.h ../libltdl/ltdl.h blend.h font.h file.h updates.h \
-+ image.h blend.h font.h file.h updates.h \
- rgbadraw.h rotate.h
- font_main.lo font_main.o : font_main.c ../config.h common.h colormod.h \
-- image.h ../libltdl/ltdl.h blend.h font.h file.h updates.h \
-+ image.h blend.h font.h file.h updates.h \
- rgbadraw.h rotate.h
- font_query.lo font_query.o : font_query.c ../config.h common.h \
-- colormod.h image.h ../libltdl/ltdl.h blend.h font.h file.h \
-+ colormod.h image.h blend.h font.h file.h \
- updates.h rgbadraw.h rotate.h
- format.lo format.o : format.c format.h
- grab.lo grab.o : grab.c common.h ../config.h grab.h
- grad.lo grad.o : grad.c common.h ../config.h colormod.h image.h \
-- ../libltdl/ltdl.h file.h loaderpath.h blend.h grad.h \
-+ file.h loaderpath.h blend.h grad.h \
- color_helpers.h
- image.lo image.o : image.c common.h ../config.h image.h \
-- ../libltdl/ltdl.h file.h loaderpath.h
-+ file.h loaderpath.h
- rend.lo rend.o : rend.c common.h ../config.h colormod.h image.h \
-- ../libltdl/ltdl.h scale.h ximage.h context.h rgba.h color.h \
-+ scale.h ximage.h context.h rgba.h color.h \
- grab.h blend.h rend.h rotate.h
- rgba.lo rgba.o : rgba.c common.h ../config.h context.h rgba.h
- rgbadraw.lo rgbadraw.o : rgbadraw.c common.h ../config.h colormod.h \
-- image.h ../libltdl/ltdl.h scale.h blend.h updates.h rgbadraw.h
-+ image.h scale.h blend.h updates.h rgbadraw.h
- rotate.lo rotate.o : rotate.c common.h ../config.h rotate.h image.h \
-- ../libltdl/ltdl.h colormod.h blend.h
-+ colormod.h blend.h
- scale.lo scale.o : scale.c common.h ../config.h colormod.h image.h \
-- ../libltdl/ltdl.h blend.h scale.h
-+ blend.h scale.h
- script.lo script.o : script.c common.h ../config.h Imlib2.h image.h \
-- ../libltdl/ltdl.h file.h dynamic_filters.h script.h \
-+ file.h dynamic_filters.h script.h \
- loaderpath.h
- updates.lo updates.o : updates.c common.h ../config.h updates.h
- ximage.lo ximage.o : ximage.c common.h ../config.h ximage.h
diff --git a/graphics/imlib2/files/patch-src_rgbadraw.c b/graphics/imlib2/files/patch-src_rgbadraw.c
deleted file mode 100644
index e9b730c7cb3a..000000000000
--- a/graphics/imlib2/files/patch-src_rgbadraw.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/rgbadraw.c.orig Sat Jul 31 11:10:28 2004
-+++ src/rgbadraw.c Sat Jul 31 11:16:05 2004
-@@ -2357,14 +2357,14 @@
- /* last span on line and still not < ss->x */
- if (ps)
- ps->next = s;
-- nospans:
-+ nospans: ;
- }
- }
- if (i == y2)
- goto nolines;
- i += step;
- }
-- nolines:
-+ nolines: ;
- }
- for (i = 0; i < h; i++)
- {
diff --git a/graphics/imlib2/pkg-plist b/graphics/imlib2/pkg-plist
index 6de5e8396329..89c926628413 100644
--- a/graphics/imlib2/pkg-plist
+++ b/graphics/imlib2/pkg-plist
@@ -1,22 +1,30 @@
+bin/bumpmaptest
+bin/color_spaces
+bin/imconvert
+bin/imlib2
+bin/imlib2_test
+bin/imlib2_view
bin/imlib2-config
+bin/polytest
include/Imlib2.h
lib/libImlib2.a
lib/libImlib2.so
lib/libImlib2.so.2
-lib/loaders/filter/bump_map.so
-lib/loaders/filter/colormod.so
-lib/loaders/filter/testfilter.so
-lib/loaders/image/argb.so
-lib/loaders/image/bmp.so
-lib/loaders/image/gif.so
-lib/loaders/image/gzbz2.so
-lib/loaders/image/jpeg.so
-lib/loaders/image/png.so
-lib/loaders/image/pnm.so
-lib/loaders/image/tga.so
-lib/loaders/image/tiff.so
-lib/loaders/image/xpm.so
+lib/imlib2_loaders/filter/bump_map.so
+lib/imlib2_loaders/filter/colormod.so
+lib/imlib2_loaders/filter/testfilter.so
+lib/imlib2_loaders/image/argb.so
+lib/imlib2_loaders/image/bmp.so
+lib/imlib2_loaders/image/bz2.so
+lib/imlib2_loaders/image/gif.so
+lib/imlib2_loaders/image/jpeg.so
+lib/imlib2_loaders/image/png.so
+lib/imlib2_loaders/image/pnm.so
+lib/imlib2_loaders/image/tga.so
+lib/imlib2_loaders/image/tiff.so
+lib/imlib2_loaders/image/xpm.so
+lib/imlib2_loaders/image/zlib.so
libdata/pkgconfig/imlib2.pc
-@dirrm lib/loaders/image
-@dirrm lib/loaders/filter
-@dirrm lib/loaders
+@dirrm lib/imlib2_loaders/image
+@dirrm lib/imlib2_loaders/filter
+@dirrm lib/imlib2_loaders