aboutsummaryrefslogtreecommitdiff
path: root/graphics/impressive/Makefile
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2019-05-22 06:40:01 +0000
committerKai Knoblich <kai@FreeBSD.org>2019-05-22 06:40:01 +0000
commit36055a452ba2dc82d3f08895b500894c948f4230 (patch)
tree84f757d834d42e841bfa835efcd9668847110a94 /graphics/impressive/Makefile
parentff89fbb285e60b755701950f6b7d08fc5c2ef8ba (diff)
downloadports-36055a452ba2dc82d3f08895b500894c948f4230.tar.gz
ports-36055a452ba2dc82d3f08895b500894c948f4230.zip
Notes
Diffstat (limited to 'graphics/impressive/Makefile')
-rw-r--r--graphics/impressive/Makefile49
1 files changed, 38 insertions, 11 deletions
diff --git a/graphics/impressive/Makefile b/graphics/impressive/Makefile
index a9e42f79a1ce..dafb8274641e 100644
--- a/graphics/impressive/Makefile
+++ b/graphics/impressive/Makefile
@@ -2,28 +2,25 @@
# $FreeBSD$
PORTNAME= impressive
-PORTVERSION= 0.11.1
-PORTREVISION= 5
-CATEGORIES= graphics
+PORTVERSION= 0.12.0
+CATEGORIES= graphics python
MASTER_SITES= SF/${PORTNAME}/Impressive/${PORTVERSION}/
DISTNAME= Impressive-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= kai@FreeBSD.org
COMMENT= Stylish way of giving presentations
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/license.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}PyOpenGL>=0:graphics/py-PyOpenGL@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR} \
- xpdf:graphics/xpdf \
- pdftk:print/pdftk \
- xdg-open:devel/xdg-utils \
- mplayer:multimedia/mplayer
+ ${PYTHON_PKGNAMEPREFIX}game>0:devel/py-game@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
-USES= ghostscript:run python shebangfix
-SHEBANG_FILES= impressive.py
+USES= python:2.7 sdl shebangfix
USE_SDL= sdl
+
+SHEBANG_FILES= impressive.py
NO_BUILD= yes
NO_ARCH= yes
PLIST_FILES= bin/${PORTNAME} \
@@ -32,6 +29,36 @@ PLIST_FILES= bin/${PORTNAME} \
PORTDOCS= ${PORTNAME}.html demo.pdf
OPTIONS_DEFINE= DOCS
+OPTIONS_GROUP= MULTIMEDIA PDFFEATURE
+OPTIONS_MULTI= PDFENGINE
+OPTIONS_DEFAULT=FFMPEG MPLAYER MUPDF PDFTK XDG
+
+OPTIONS_GROUP_MULTIMEDIA= FFMPEG MPLAYER
+OPTIONS_GROUP_PDFFEATURE= PDFTK XDG
+OPTIONS_MULTI_PDFENGINE= GHOSTSCRIPT MUPDF POPPLER XPDF
+
+FFMPEG_DESC= Optimize generation of video preview images
+MPLAYER_DESC= Enable audio/video playback
+PDFTK_DESC= Enable automatic extraction of PDF page titles
+XDG_DESC= Enable web/e-mail hyperlinks in PDF files
+GHOSTSCRIPT_DESC= Use Ghostscript for PDF rendering
+MUPDF_DESC= Use MuPDF for PDF rendering
+POPPLER_DESC= Use Poppler for PDF rendering
+XPDF_DESC= Use Xpdf for PDF rendering
+
+FFMPEG_IMPLIES= MPLAYER
+GHOSTSCRIPT_IMPLIES= PDFTK
+POPPLER_IMPLIES= PDFTK
+XPDF_IMPLIES= PDFTK
+
+FFMPEG_RUN_DEPENDS= ffmpeg:multimedia/ffmpeg
+MPLAYER_RUN_DEPENDS= mplayer:multimedia/mplayer
+PDFTK_RUN_DEPENDS= pdftk:print/pdftk
+XDG_RUN_DEPENDS= xdg-open:devel/xdg-utils
+GHOSTSCRIPT_USES= ghostscript:run
+MUPDF_RUN_DEPENDS= mupdf:graphics/mupdf
+POPPLER_RUN_DEPENDS= pdftoppm:graphics/poppler-utils
+XPDF_RUN_DEPENDS= ${LOCALBASE}/libexec/xpdf/pdftoppm:graphics/xpdf
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.py ${STAGEDIR}${PREFIX}/bin/${PORTNAME}