aboutsummaryrefslogtreecommitdiff
path: root/graphics/impressive/Makefile
diff options
context:
space:
mode:
authorVeniamin Gvozdikov <vg@FreeBSD.org>2014-06-30 15:38:43 +0000
committerVeniamin Gvozdikov <vg@FreeBSD.org>2014-06-30 15:38:43 +0000
commit82d49f7eb25dc398246111176a9fb66637154a50 (patch)
tree8c5f2eaa25251a0c6052d285c724c079dc579f01 /graphics/impressive/Makefile
parent1be0afa923b2eb2733cce26e1dfaec0c5d37e347 (diff)
downloadports-82d49f7eb25dc398246111176a9fb66637154a50.tar.gz
ports-82d49f7eb25dc398246111176a9fb66637154a50.zip
Notes
Diffstat (limited to 'graphics/impressive/Makefile')
-rw-r--r--graphics/impressive/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/graphics/impressive/Makefile b/graphics/impressive/Makefile
index 21c1e6e9f844..3fcb8582d7cb 100644
--- a/graphics/impressive/Makefile
+++ b/graphics/impressive/Makefile
@@ -24,24 +24,21 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}opengl>=0:${PORTSDIR}/graphics/py-opengl \
USE_PYTHON= yes
USE_GHOSTSCRIPT_RUN= yes
NO_BUILD= yes
-PLIST_FILES= bin/${PORTNAME}
-
-MAN1= ${PORTNAME}.1
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz
PORTDOCS= ${PORTNAME}.html demo.pdf
-NO_STAGE= yes
-
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.py ${PREFIX}/bin/${PORTNAME}
- @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.py ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>