aboutsummaryrefslogtreecommitdiff
path: root/graphics/inkscape/Makefile
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2003-11-17 04:03:39 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2003-11-17 04:03:39 +0000
commit74f1dc757b07e6022da0d55174d45edccbd0bf47 (patch)
treea129953b2af2b948cfe1aa8195c207e6e310fe7b /graphics/inkscape/Makefile
parent0f3e3621dd9547273fe1bd2c30789a641cb4b438 (diff)
downloadports-74f1dc757b07e6022da0d55174d45edccbd0bf47.tar.gz
ports-74f1dc757b07e6022da0d55174d45edccbd0bf47.zip
Notes
Diffstat (limited to 'graphics/inkscape/Makefile')
-rw-r--r--graphics/inkscape/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
new file mode 100644
index 000000000000..4ca2afc2a50e
--- /dev/null
+++ b/graphics/inkscape/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: inkscape
+# Date created: 17 Nov 2003
+# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= inkscape
+PORTVERSION= 0.35
+CATEGORIES= graphics gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A program seeks to become a full featured open source SVG editor
+
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_GNOME= gnomeprefix gnomehack libglade2 libartlgpl2 libgnomeprintui
+USE_REINPLACE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --with-popt
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+MAN1= inkscape.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|g' \
+ ${WRKSRC}/src/helper/action.c \
+ ${WRKSRC}/src/libarikkei/arikkei-token.c
+
+.include <bsd.port.mk>