aboutsummaryrefslogtreecommitdiff
path: root/graphics/inkscape/Makefile
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2005-11-22 20:19:59 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2005-11-22 20:19:59 +0000
commit81b657732335d538b16b70524e165b7f6618c6bd (patch)
treeae2027dde45d7dc8df4bb17854c00eb9be8e7baa /graphics/inkscape/Makefile
parent8dbc4c12e1a0df8e7f61fd48b1268f24b9fa5c7f (diff)
Notes
Diffstat (limited to 'graphics/inkscape/Makefile')
-rw-r--r--graphics/inkscape/Makefile27
1 files changed, 20 insertions, 7 deletions
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index 58654a878af5..112e927ce446 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= inkscape
-PORTVERSION= 0.42.2
-PORTREVISION= 1
+PORTVERSION= 0.43
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,16 +20,17 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
gtkspell.0:${PORTSDIR}/textproc/gtkspell2
RUN_DEPENDS= ${SITE_PERL}/XML/XQL.pm:${PORTSDIR}/textproc/p5-XML-XQL
+USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack intlhack libgnomeprintui libxslt
+WANT_GNOME= yes
+USE_GNOME= gnomeprefix gnomehack intlhack libxslt
USE_REINPLACE= yes
USE_AUTOTOOLS= libtool:15
USE_GCC= 3.4
-CONFIGURE_ARGS= --with-popt \
- --with-gnome-print
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 -I${X11BASE}/include -I${LOCALBASE} ${PTHREAD_CFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -L${LOCALBASE} ${PTHREAD_LIBS}"
+CONFIGURE_ARGS= --with-popt
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
MAN1= inkscape.1 inkview.1
@@ -40,6 +40,19 @@ MAN1= inkscape.1 inkview.1
IGNORE= Requires symbols not present on 4.X
.endif
+.if ${HAVE_GNOME:Mlibgnomeprint} != ""
+USE_GNOME+= libgnomeprint
+CONFIGURE_ARGS+= --with-gnome-print
+.else
+CONFIGURE_ARGS+= --without-gnome-print
+.endif
+.if ${HAVE_GNOME:Mgnomevfs2} != ""
+USE_GNOME+= gnomevfs2
+CONFIGURE_ARGS+= --with-gnome-vfs
+.else
+CONFIGURE_ARGS+= --without-gnome-vfs
+.endif
+
patch-autotools::
@(cd ${PATCH_WRKSRC}; \
for file in ${LIBTOOLFILES}; do \