aboutsummaryrefslogtreecommitdiff
path: root/graphics/inkscape/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 11:03:07 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 11:03:07 +0000
commitba6e68fea6287e3f1c619bfb757d202d58020807 (patch)
treeef1c8570a6cfec72a82415d83a4584a4b995cba9 /graphics/inkscape/Makefile
parent5f9ad71e350e62528ba082e74dcbcb267fab8a27 (diff)
Notes
Diffstat (limited to 'graphics/inkscape/Makefile')
-rw-r--r--graphics/inkscape/Makefile54
1 files changed, 23 insertions, 31 deletions
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index b871b9991198..4ebaaa902ac0 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= inkscape
-PORTVERSION= 0.38.1
-PORTREVISION= 3
+PORTVERSION= 0.41
+PORTREVISION= 2
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,42 +16,34 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= A program seeks to become a full featured open source SVG editor
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
- sigc-1.2.5:${PORTSDIR}/devel/libsigc++12
+ gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
+ gc.1:${PORTSDIR}/devel/boehm-gc \
+ gtkspell.0:${PORTSDIR}/textproc/gtkspell2
RUN_DEPENDS= ${SITE_PERL}/XML/XQL.pm:${PORTSDIR}/textproc/p5-XML-XQL
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack lthack intlhack libglade2 libartlgpl2 \
- desktopfileutils libgnomeprintui
+USE_GNOME= gnomeprefix gnomehack intlhack libgnomeprintui libxslt
USE_REINPLACE= yes
-USE_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
+USE_GCC= 3.4
CONFIGURE_ARGS= --with-popt \
--with-gnome-print
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 -I${X11BASE}/include -I${LOCALBASE}" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -L${LOCALBASE}"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 -I${X11BASE}/include -I${LOCALBASE} ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -L${LOCALBASE} ${PTHREAD_LIBS}"
MAN1= inkscape.1 inkview.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-old_gcc_bugs
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|g' \
- ${WRKSRC}/src/helper/action.cpp \
- ${WRKSRC}/src/libarikkei/arikkei-token.cpp
- @${REINPLACE_CMD} -e 's|round|rint|g' \
- ${WRKSRC}/src/livarot/Shape.h \
- ${WRKSRC}/src/object-edit.cpp \
- ${WRKSRC}/src/spiral-context.cpp \
- ${WRKSRC}/src/star-context.cpp
-.if ${OSVERSION} < 500000
- @${REINPLACE_CMD} -e 's|<stdint.h>|<sys/types.h>|g' \
- ${WRKSRC}/src/livarot/*.h
- @${REINPLACE_CMD} -e 's|isfinite|!isinf|g' \
- ${WRKSRC}/src/helper/*.cpp
-.endif
-
-.include <bsd.port.post.mk>
+patch-autotools:
+ @(cd ${PATCH_WRKSRC}; \
+ for file in ${LIBTOOLFILES}; do \
+ ${CP} $$file $$file.tmp; \
+ ${SED} -e "/^ltmain=/s^\$$ac_aux_dir/ltmain.sh^${LTMAIN}^g" \
+ $$file.tmp > $$file; \
+ ${RM} $$file.tmp; \
+ done);
+
+post-install:
+ @-update-desktop-database
+
+.include <bsd.port.mk>