aboutsummaryrefslogtreecommitdiff
path: root/graphics/inkscape
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2003-12-11 15:36:02 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2003-12-11 15:36:02 +0000
commitac0f2649eea3151f414920b534117d52a13e3eb8 (patch)
tree6c01fd7c9cd89294f6a7f3e05e04b003688ef61a /graphics/inkscape
parent9e74d5d4db833d9468dc28e28944e9d1dc36274c (diff)
downloadports-ac0f2649eea3151f414920b534117d52a13e3eb8.tar.gz
ports-ac0f2649eea3151f414920b534117d52a13e3eb8.zip
Notes
Diffstat (limited to 'graphics/inkscape')
-rw-r--r--graphics/inkscape/Makefile4
-rw-r--r--graphics/inkscape/files/patch-src::module.c20
-rw-r--r--graphics/inkscape/files/patch-src::modules::gnome.c10
-rw-r--r--graphics/inkscape/pkg-plist1
4 files changed, 34 insertions, 1 deletions
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index 97d740385e06..3cd375959b18 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -7,6 +7,7 @@
PORTNAME= inkscape
PORTVERSION= 0.36
+PORTREVISION= 1
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,7 +22,8 @@ USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack libglade2 libartlgpl2 libgnomeprintui
USE_REINPLACE= yes
USE_LIBTOOL= yes
-CONFIGURE_ARGS= --with-popt
+CONFIGURE_ARGS= --with-popt \
+ --with-gnome-print
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
diff --git a/graphics/inkscape/files/patch-src::module.c b/graphics/inkscape/files/patch-src::module.c
new file mode 100644
index 000000000000..2671a5f3f8af
--- /dev/null
+++ b/graphics/inkscape/files/patch-src::module.c
@@ -0,0 +1,20 @@
+--- src/module.c.orig Fri Dec 12 00:10:31 2003
++++ src/module.c Fri Dec 12 00:14:45 2003
+@@ -38,7 +38,7 @@
+ static void sp_module_private_build (SPModule *module, SPRepr *repr);
+ static void sp_module_load_default (SPModule * module);
+ static void sp_module_unload_default (SPModule * module);
+-static SPModule * sp_module_new (GType type, SPRepr *repr);
++SPModule * sp_module_new (GType type, SPRepr *repr);
+
+ /**
+ \var module_parent_class
+@@ -283,7 +283,7 @@
+ A reference to the SPRepr structure is added in this function so it
+ should not need to be added by each individual subclass.
+ */
+-static SPModule *
++SPModule *
+ sp_module_new (GType type, SPRepr *repr)
+ {
+ SPModule *module;
diff --git a/graphics/inkscape/files/patch-src::modules::gnome.c b/graphics/inkscape/files/patch-src::modules::gnome.c
new file mode 100644
index 000000000000..25bbad22f630
--- /dev/null
+++ b/graphics/inkscape/files/patch-src::modules::gnome.c
@@ -0,0 +1,10 @@
+--- src/modules/gnome.c.orig Thu Dec 11 23:52:25 2003
++++ src/modules/gnome.c Thu Dec 11 23:52:44 2003
+@@ -31,6 +31,7 @@
+ #include <libgnomeprintui/gnome-print-dialog.h>
+
+ #include "helper/sp-intl.h"
++#include "helper/canvas-bpath.h"
+ #include "enums.h"
+ #include "document.h"
+ #include "style.h"
diff --git a/graphics/inkscape/pkg-plist b/graphics/inkscape/pkg-plist
index 8b24480b005e..d4bee7377323 100644
--- a/graphics/inkscape/pkg-plist
+++ b/graphics/inkscape/pkg-plist
@@ -217,6 +217,7 @@ share/locale/sv/LC_MESSAGES/inkscape.mo
share/locale/tr/LC_MESSAGES/inkscape.mo
share/locale/uk/LC_MESSAGES/inkscape.mo
share/locale/zh_CN/LC_MESSAGES/inkscape.mo
+@dirrm share/gnome/inkscape/modules
@dirrm share/gnome/inkscape/extensions
@dirrm share/gnome/inkscape
@dirrm lib/inkscape/extensions