aboutsummaryrefslogtreecommitdiff
path: root/graphics/inventor/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
commit074ea5282a00d556c73d86231bec5444990597dc (patch)
treeeec3d608e84e79f0187985e5a1e29cd4f04f13eb /graphics/inventor/Makefile
parent522c152d1c7b0c92982e310110fa6d59f915ffeb (diff)
downloadports-074ea5282a00d556c73d86231bec5444990597dc.tar.gz
ports-074ea5282a00d556c73d86231bec5444990597dc.zip
Notes
Diffstat (limited to 'graphics/inventor/Makefile')
-rw-r--r--graphics/inventor/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/graphics/inventor/Makefile b/graphics/inventor/Makefile
index 3940065d43e3..0c029d486b5b 100644
--- a/graphics/inventor/Makefile
+++ b/graphics/inventor/Makefile
@@ -3,7 +3,7 @@
PORTNAME= inventor
PORTVERSION= 2.1.5.p10
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= graphics
MASTER_SITES= ftp://oss.sgi.com/projects/inventor/download/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p/-/}
@@ -19,7 +19,7 @@ LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
CONFLICTS= Coin-[0-9]* SoXt-[0-9]*
-USE_XORG= x11 xi
+USE_XORG= x11 xext xi xp xt
USE_GL= glu glw
USES= iconv gmake motif
USE_LDCONFIG= yes
@@ -27,7 +27,12 @@ ONLY_FOR_ARCHS= i386 amd64
MAKE_JOBS_UNSAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKE_ARGS= CC="${CC}" CXX="${CXX}" LD="${CXX}" \
+ VCOPTS="${CFLAGS}" VCXXOPTS="${CXXFLAGS}" \
+ VLDOPTS="${LDFLAGS}" VLDDSOOPTS="${LDFLAGS}" \
+ IVPREFIX="${PREFIX}" X11DIR="${LOCALBASE}"
MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/lib:${WRKSRC}/libSoXt \
+ FREETYPE=1 \
INSTALL_STRIP=${STRIP} \
IVROOT=${STAGEDIR}
MAKEFILE= GNUmakefile
@@ -41,13 +46,12 @@ DEBUG_MAKE_ENV= LIBTYPE=debug
.include <bsd.port.options.mk>
.if !(${OPSYS} == FreeBSD && ${OSVERSION} < 900033)
-MAKE_ENV+= VLDOPTS=-Wl,--add-needed
+LDFLAGS+= -Wl,--add-needed
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|%%CC%%|${CC}|g ;\
- s|%%CXX%%|${CXX}|g ; \
- s|%%CXXFLAGS%%|${CXXFLAGS}|g' ${WRKSRC}/make/ivcommondefs
+ @${REINPLACE_CMD} 's|/usr\(/include/freetype2\)|${LOCALBASE}\1|' \
+ ${WRKSRC}/libFL/ang/GNUmakefile
@${REINPLACE_CMD} -e 's|%%ICONV_LIB%%|${ICONV_LIB}|' \
${WRKSRC}/lib/GNUmakefile