aboutsummaryrefslogtreecommitdiff
path: root/graphics/inventor
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2003-08-19 00:31:42 +0000
committerMaho Nakata <maho@FreeBSD.org>2003-08-19 00:31:42 +0000
commit27e0b92655a727a40ab23b371fece1504053ce8b (patch)
tree49a5fcc6aa45bd6722c68278746dd996dd167eba /graphics/inventor
parenta0c44024a2ee1564bf1e5d011f0961c6f64a78c7 (diff)
downloadports-27e0b92655a727a40ab23b371fece1504053ce8b.tar.gz
ports-27e0b92655a727a40ab23b371fece1504053ce8b.zip
Notes
Diffstat (limited to 'graphics/inventor')
-rw-r--r--graphics/inventor/Makefile3
-rw-r--r--graphics/inventor/files/patch-machine.h23
2 files changed, 25 insertions, 1 deletions
diff --git a/graphics/inventor/Makefile b/graphics/inventor/Makefile
index ac988135f0b3..b99be067de69 100644
--- a/graphics/inventor/Makefile
+++ b/graphics/inventor/Makefile
@@ -26,7 +26,8 @@ USE_MOTIF= yes
USE_MESA= yes
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
-PREFIX= ${X11BASE} # not a good manner
+ONLY_FOR_ARCHES= i386
+PREFIX= ${X11BASE} # not a good manner
WRKSRC= ${WRKDIR}/${PORTNAME}
MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/lib:${WRKSRC}/libSoXt
diff --git a/graphics/inventor/files/patch-machine.h b/graphics/inventor/files/patch-machine.h
new file mode 100644
index 000000000000..4e85ee3b2efb
--- /dev/null
+++ b/graphics/inventor/files/patch-machine.h
@@ -0,0 +1,23 @@
+*** lib/database/include/machine.h.orig Mon Aug 18 18:36:50 2003
+--- lib/database/include/machine.h Mon Aug 18 18:48:17 2003
+***************
+*** 152,157 ****
+--- 152,169 ----
+
+
+ /*
++ * Alpha under FreeBSD
++ */
++
++ #if __alpha__ && __FreeBSD__
++
++ #define MACHINE_WORD_FORMAT DGL_LITTLE_ENDIAN
++ #define MACHINE_FLOAT_FORMAT DGL_NON_IEEE
++
++ #endif /* __alpha__ && __FreeBSD__ */
++
++
++ /*
+ * Apple Darwin (Mac OS X) machine dependent setup
+ */
+