aboutsummaryrefslogtreecommitdiff
path: root/graphics/inventor
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2014-06-25 14:51:11 +0000
committerJason E. Hale <jhale@FreeBSD.org>2014-06-25 14:51:11 +0000
commit68b94b6a4c4f64cc866281ed85ea5e85502b3078 (patch)
tree4a94088e081917d94bdce1684241c311fb581cfe /graphics/inventor
parent6e1f5a56634c13b07b9810755b4df695d46c464f (diff)
downloadports-68b94b6a4c4f64cc866281ed85ea5e85502b3078.tar.gz
ports-68b94b6a4c4f64cc866281ed85ea5e85502b3078.zip
Notes
Diffstat (limited to 'graphics/inventor')
-rw-r--r--graphics/inventor/Makefile135
-rw-r--r--graphics/inventor/files/patch-make__ivcommonrules34
-rw-r--r--graphics/inventor/pkg-descr7
-rw-r--r--graphics/inventor/pkg-plist362
4 files changed, 412 insertions, 126 deletions
diff --git a/graphics/inventor/Makefile b/graphics/inventor/Makefile
index 6d85845a3bb5..82cbd367f366 100644
--- a/graphics/inventor/Makefile
+++ b/graphics/inventor/Makefile
@@ -3,155 +3,46 @@
PORTNAME= inventor
PORTVERSION= 2.1.5.p10
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= graphics
MASTER_SITES= ftp://oss.sgi.com/projects/inventor/download/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p/-/}
EXTRACT_SUFX= .src.tar.gz
MAINTAINER= c47g@gmx.at
-COMMENT= This is SGI's Open Inventor (TM)
+COMMENT= SGI's Open Inventor (TM)
+
+LICENSE= LGPL21
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
- GLU.1:${PORTSDIR}/graphics/libGLU
+ libjpeg.so:${PORTSDIR}/graphics/jpeg
-CONFLICTS= Coin-* SoXt-*
+CONFLICTS= Coin-[0-9]* SoXt-[0-9]*
USE_XORG= x11 xi
-USE_GL= glw
+USE_GL= glu glw
USES= iconv gmake motif
USE_LDCONFIG= yes
ONLY_FOR_ARCHS= i386 amd64
MAKE_JOBS_UNSAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/lib:${WRKSRC}/libSoXt
+MAKE_ENV= LD_LIBRARY_PATH=${WRKSRC}/lib:${WRKSRC}/libSoXt \
+ INSTALL_STRIP=${STRIP} \
+ IVROOT=${STAGEDIR}
MAKEFILE= GNUmakefile
-.if defined(WITH_DEBUG)
-MAKE_ENV+= LIBTYPE=debug
-PKGNAMESUFFIX= -debug
-.endif
-
-MAN1= SceneViewer.1 inventor.1 iv2toiv1.1 ivcat.1 ivdowngrade.1 ivfix.1 ivinfo.1 ivview.1
+SUB_FILES= pkg-message
-MAN3= SoAction.3iv SoCallbackAction.3iv SoGLRenderAction.3iv \
- SoGetBoundingBoxAction.3iv SoGetMatrixAction.3iv \
- SoHandleEventAction.3iv SoPickAction.3iv SoRayPickAction.3iv \
- SoSearchAction.3iv SoWriteAction.3iv SbBool.3iv SbBox2f.3iv \
- SbBox2s.3iv SbBox3f.3iv SbColor.3iv SbCylinder.3iv SbLine.3iv \
- SbMatrix.3iv SbName.3iv SbPList.3iv SbPlane.3iv SbRotation.3iv \
- SbSphere.3iv SbString.3iv SbTime.3iv SbVec2f.3iv SbVec2s.3iv \
- SbVec3f.3iv SbVec4f.3iv SbViewVolume.3iv SbViewportRegion.3iv \
- SbXfBox3f.3iv SoXt.3iv SoXtClipboard.3iv SoXtComponent.3iv \
- SoXtDirectionalLightEditor.3iv SoXtGLWidget.3iv \
- SoXtLightSliderSet.3iv SoXtMaterialEditor.3iv SoXtMaterialList.3iv \
- SoXtMaterialSliderSet.3iv SoXtPrintDialog.3iv SoXtRenderArea.3iv \
- SoXtResource.3iv SoXtSliderSet.3iv SoXtSliderSetBase.3iv \
- SoXtTransformSliderSet.3iv SoConeDetail.3iv SoCubeDetail.3iv \
- SoCylinderDetail.3iv SoDetail.3iv SoDetailList.3iv SoFaceDetail.3iv \
- SoLineDetail.3iv SoNodeKitDetail.3iv SoPointDetail.3iv \
- SoTextDetail.3iv SoXtDevice.3iv SoXtInputFocus.3iv SoXtKeyboard.3iv \
- SoXtMouse.3iv SoXtSpaceball.3iv SoCenterballDragger.3iv \
- SoDirectionalLightDragger.3iv SoDragPointDragger.3iv SoDragger.3iv \
- SoHandleBoxDragger.3iv SoJackDragger.3iv SoPointLightDragger.3iv \
- SoRotateCylindricalDragger.3iv SoRotateDiscDragger.3iv \
- SoRotateSphericalDragger.3iv SoGate.3iv SoScale1Dragger.3iv \
- SoScale2Dragger.3iv SoScale2UniformDragger.3iv \
- SoScaleUniformDragger.3iv SoSpotLightDragger.3iv SoTabBoxDragger.3iv \
- SoTabPlaneDragger.3iv SoTrackballDragger.3iv \
- SoTransformBoxDragger.3iv SoTransformerDragger.3iv \
- SoTranslate1Dragger.3iv SoTranslate2Dragger.3iv SoBoolOperation.3iv \
- SoCalculator.3iv SoComposeMatrix.3iv SoComposeRotation.3iv \
- SoComposeRotationFromTo.3iv SoComposeVec2f.3iv SoComposeVec3f.3iv \
- SoComposeVec4f.3iv SoComputeBoundingBox.3iv SoConcatenate.3iv \
- SoCounter.3iv SoDecomposeMatrix.3iv SoDecomposeRotation.3iv \
- SoDecomposeVec2f.3iv SoDecomposeVec3f.3iv SoDecomposeVec4f.3iv \
- SoElapsedTime.3iv SoEngine.3iv SoEngineList.3iv SoEngineOutput.3iv \
- SoEngineOutputList.3iv SoInterpolate.3iv SoInterpolateFloat.3iv \
- SoInterpolateRotation.3iv SoInterpolateVec2f.3iv \
- SoInterpolateVec3f.3iv SoInterpolateVec4f.3iv SoOnOff.3iv \
- SoOneShot.3iv SoSelectOne.3iv SoTimeCounter.3iv SoTransformVec3f.3iv \
- SoTriggerAny.3iv SoDebugError.3iv SoError.3iv SoMemoryError.3iv \
- SoReadError.3iv SoButtonEvent.3iv SoEvent.3iv SoKeyboardEvent.3iv \
- SoLocation2Event.3iv SoMotion3Event.3iv SoMouseButtonEvent.3iv \
- SoSpaceballButtonEvent.3iv SoField.3iv SoFieldContainer.3iv \
- SoFieldList.3iv SoMFBitMask.3iv SoMFBool.3iv SoMFColor.3iv \
- SoMFEngine.3iv SoMFEnum.3iv SoMFFloat.3iv SoMFInt32.3iv SoMFLong.3iv \
- SoMFMatrix.3iv SoMFName.3iv SoMFNode.3iv SoMFPath.3iv SoMFPlane.3iv \
- SoMFRotation.3iv SoMFShort.3iv SoMFString.3iv SoMFTime.3iv \
- SoMFUInt32.3iv SoMFULong.3iv SoMFUShort.3iv SoMFVec2f.3iv \
- SoMFVec3f.3iv SoMFVec4f.3iv SoMField.3iv SoSFBitMask.3iv SoSFBool.3iv \
- SoSFColor.3iv SoSFEngine.3iv SoSFEnum.3iv SoSFFloat.3iv SoSFImage.3iv \
- SoSFInt32.3iv SoSFLong.3iv SoSFMatrix.3iv SoSFName.3iv SoSFNode.3iv \
- SoSFPath.3iv SoSFPlane.3iv SoSFRotation.3iv SoSFShort.3iv \
- SoSFString.3iv SoSFTime.3iv SoSFTrigger.3iv SoSFUInt32.3iv \
- SoSFULong.3iv SoSFUShort.3iv SoSFVec2f.3iv SoSFVec3f.3iv SoSFVec4f.3iv \
- SoSField.3iv SoBase.3iv SoBaseList.3iv SoByteStream.3iv \
- SoCallbackList.3iv SoDB.3iv SoInput.3iv SoNodeKitPath.3iv \
- SoNodeList.3iv SoOffscreenRenderer.3iv SoOutput.3iv SoPath.3iv \
- SoPathList.3iv SoPickedPoint.3iv SoPickedPointList.3iv \
- SoPrimitiveVertex.3iv SoTranReceiver.3iv SoTranSender.3iv SoType.3iv \
- SoTypeList.3iv SoBoxHighlightRenderAction.3iv SoEventCallback.3iv \
- SoInteraction.3iv SoLineHighlightRenderAction.3iv SoSceneManager.3iv \
- SoSelection.3iv SoCenterballManip.3iv SoDirectionalLightManip.3iv \
- SoHandleBoxManip.3iv SoJackManip.3iv SoPointLightManip.3iv \
- SoSpotLightManip.3iv SoTabBoxManip.3iv SoTrackballManip.3iv \
- SoTransformBoxManip.3iv SoTransformManip.3iv SoTransformerManip.3iv \
- SoAppearanceKit.3iv SoBaseKit.3iv SoCameraKit.3iv SoInteractionKit.3iv \
- SoLightKit.3iv SoNodeKit.3iv SoNodeKitListPart.3iv \
- SoNodekitCatalog.3iv SoSceneKit.3iv SoSeparatorKit.3iv SoShapeKit.3iv \
- SoWrapperKit.3iv SoAnnotation.3iv SoAntiSquish.3iv SoArray.3iv \
- SoAsciiText.3iv SoBaseColor.3iv SoBlinker.3iv SoCallback.3iv \
- SoCamera.3iv SoClipPlane.3iv SoColorIndex.3iv SoComplexity.3iv \
- SoCone.3iv SoCoordinate3.3iv SoCoordinate4.3iv SoCube.3iv \
- SoCylinder.3iv SoDirectionalLight.3iv SoDrawStyle.3iv \
- SoEnvironment.3iv SoFaceSet.3iv SoFile.3iv SoFont.3iv SoFontStyle.3iv \
- SoGroup.3iv SoIndexedFaceSet.3iv SoIndexedLineSet.3iv \
- SoIndexedNurbsCurve.3iv SoIndexedNurbsSurface.3iv SoIndexedShape.3iv \
- SoIndexedTriangleStripSet.3iv SoInfo.3iv SoLOD.3iv SoLabel.3iv \
- SoLevelOfDetail.3iv SoLight.3iv SoLightModel.3iv SoLineSet.3iv \
- SoLinearProfile.3iv SoLocateHighlight.3iv SoMaterial.3iv \
- SoMaterialBinding.3iv SoMatrixTransform.3iv SoMultipleCopy.3iv \
- SoNode.3iv SoNonIndexedShape.3iv SoNormal.3iv SoNormalBinding.3iv \
- SoNurbsCurve.3iv SoNurbsProfile.3iv SoNurbsSurface.3iv \
- SoOrthographicCamera.3iv SoPackedColor.3iv SoPathSwitch.3iv \
- SoPendulum.3iv SoPerspectiveCamera.3iv SoPickStyle.3iv \
- SoPointLight.3iv SoPointSet.3iv SoProfile.3iv SoProfileCoordinate2.3iv \
- SoProfileCoordinate3.3iv SoQuadMesh.3iv SoResetTransform.3iv \
- SoRotation.3iv SoRotationXYZ.3iv SoRotor.3iv SoScale.3iv \
- SoSeparator.3iv SoShape.3iv SoShapeHints.3iv SoShuttle.3iv \
- SoSphere.3iv SoSpotLight.3iv SoSurroundScale.3iv SoSwitch.3iv \
- SoText2.3iv SoText3.3iv SoTexture2.3iv SoTexture2Transform.3iv \
- SoTextureCoordinate2.3iv SoTextureCoordinateBinding.3iv \
- SoTextureCoordinateDefault.3iv SoTextureCoordinateEnvironment.3iv \
- SoTextureCoordinateFunction.3iv SoTextureCoordinatePlane.3iv \
- SoTransform.3iv SoTransformSeparator.3iv SoTransformation.3iv \
- SoTranslation.3iv SoTriangleStripSet.3iv SoUnits.3iv \
- SoVertexProperty.3iv SoVertexShape.3iv SoWWWAnchor.3iv SoWWWInline.3iv \
- SbCylinderPlaneProjector.3iv SbCylinderProjector.3iv \
- SbCylinderSectionProjector.3iv SbCylinderSheetProjector.3iv \
- SbLineProjector.3iv SbPlaneProjector.3iv SbProjector.3iv \
- SbSpherePlaneProjector.3iv SbSphereProjector.3iv \
- SbSphereSectionProjector.3iv SbSphereSheetProjector.3iv \
- SoAlarmSensor.3iv SoDataSensor.3iv SoDelayQueueSensor.3iv \
- SoFieldSensor.3iv SoIdleSensor.3iv SoNodeSensor.3iv \
- SoOneShotSensor.3iv SoPathSensor.3iv SoSensor.3iv \
- SoTimerQueueSensor.3iv SoTimerSensor.3iv SoXtConstrainedViewer.3iv \
- SoXtExaminerViewer.3iv SoXtFlyViewer.3iv SoXtFullViewer.3iv \
- SoXtPlaneViewer.3iv SoXtViewer.3iv SoXtWalkViewer.3iv
+OPTIONS_DEFINE= DEBUG
-SUB_FILES= pkg-message
+DEBUG_MAKE_ENV= LIBTYPE=debug
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|%%CC%%|${CC}|g ;\
s|%%CXX%%|${CXX}|g ; \
s|%%CXXFLAGS%%|${CXXFLAGS}|g' ${WRKSRC}/make/ivcommondefs
@${REINPLACE_CMD} -e 's|%%ICONV_LIB%%|${ICONV_LIB}|' \
${WRKSRC}/lib/GNUmakefile
-post-install:
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/graphics/inventor/files/patch-make__ivcommonrules b/graphics/inventor/files/patch-make__ivcommonrules
new file mode 100644
index 000000000000..1a7dd89343c9
--- /dev/null
+++ b/graphics/inventor/files/patch-make__ivcommonrules
@@ -0,0 +1,34 @@
+--- ./make/ivcommonrules.orig 2014-06-25 10:16:42.000000000 -0400
++++ ./make/ivcommonrules 2014-06-25 10:26:35.000000000 -0400
+@@ -31,11 +31,11 @@
+
+ install_ivlibdso: $(LIBDSO)
+ mkdir -p $(IVLIBDIR)
+- $(INSTALL) -m 755 $< $(IVLIBDIR)
++ $(INSTALL) $(INSTALL_STRIP) -m 755 $< $(IVLIBDIR)
+
+ if [ "$(LIBTYPE)" = "debug" ]; then \
+ mkdir -p $(IVDLIBDIR); \
+- $(INSTALL) -m 755 $< $(IVDLIBDIR); \
++ $(INSTALL) $(INSTALL_STRIP) -m 755 $< $(IVDLIBDIR); \
+ fi
+
+ install_ivheaders:
+@@ -96,7 +96,7 @@
+
+ install_ivbin: $(PROGRAM)
+ mkdir -p $(IVBINDIR)
+- $(INSTALL) -m 755 $(PROGRAM) $(IVBINDIR)
++ $(INSTALL) $(INSTALL_STRIP) -m 755 $(PROGRAM) $(IVBINDIR)
+
+ install_ivscript:
+ mkdir -p $(IVBINDIR)
+@@ -109,7 +109,7 @@
+
+ install_ivdemo: $(DEMO)
+ mkdir -p $(IVDEMOBINDIR) $(IVDEMODATADIR)
+- $(INSTALL) -m 755 $(DEMO) $(IVDEMOBINDIR)
++ $(INSTALL) $(INSTALL_STRIP) -m 755 $(DEMO) $(IVDEMOBINDIR)
+ if [ -e $(DEMO).RUNME ]; then \
+ $(INSTALL) -m 755 $(DEMO).RUNME $(IVDEMOBINDIR); \
+ if [ "$(IVPREFIX)" != "/usr" ]; then \
diff --git a/graphics/inventor/pkg-descr b/graphics/inventor/pkg-descr
index f5b3f144c4b8..1c1132fbf130 100644
--- a/graphics/inventor/pkg-descr
+++ b/graphics/inventor/pkg-descr
@@ -1,4 +1,3 @@
-From http://oss.sgi.com/projects/inventor/
Open Inventor(TM) is an object-oriented 3D toolkit offering a comprehensive
solution to interactive graphics programming problems. It presents a
programming model based on a 3D scene database that dramatically simplifies
@@ -6,6 +5,7 @@ graphics programming. It includes a rich set of objects such as cubes,
polygons, text, materials, cameras, lights, trackballs, handle boxes,
3D viewers, and editors that speed up your programming time and extend
your 3D programming capabilities.
+
Open Inventor:
- is built on top of OpenGL (R)
- defines a standard file format for 3D data interchange
@@ -17,6 +17,5 @@ Open Inventor:
- supports PostScript printing
- encourages programmers to create new customized objects
- is fun to use
-WWW: http://oss.sgi.com/projects/inventor/
-christian.
-c47g@gmx.at
+
+WWW: http://oss.sgi.com/projects/inventor/
diff --git a/graphics/inventor/pkg-plist b/graphics/inventor/pkg-plist
index 51eb60e5a5ea..528db6a1acc7 100644
--- a/graphics/inventor/pkg-plist
+++ b/graphics/inventor/pkg-plist
@@ -517,6 +517,368 @@ include/Inventor/Xt/viewers/SoXtViewer.h
include/Inventor/Xt/viewers/SoXtWalkViewer.h
lib/libInventor.so
lib/libInventorXt.so
+man/man1/SceneViewer.1.gz
+man/man1/inventor.1.gz
+man/man1/iv2toiv1.1.gz
+man/man1/ivcat.1.gz
+man/man1/ivdowngrade.1.gz
+man/man1/ivfix.1.gz
+man/man1/ivinfo.1.gz
+man/man1/ivview.1.gz
+man/man3/SbBool.3iv.gz
+man/man3/SbBox2f.3iv.gz
+man/man3/SbBox2s.3iv.gz
+man/man3/SbBox3f.3iv.gz
+man/man3/SbColor.3iv.gz
+man/man3/SbCylinder.3iv.gz
+man/man3/SbCylinderPlaneProjector.3iv.gz
+man/man3/SbCylinderProjector.3iv.gz
+man/man3/SbCylinderSectionProjector.3iv.gz
+man/man3/SbCylinderSheetProjector.3iv.gz
+man/man3/SbLine.3iv.gz
+man/man3/SbLineProjector.3iv.gz
+man/man3/SbMatrix.3iv.gz
+man/man3/SbName.3iv.gz
+man/man3/SbPList.3iv.gz
+man/man3/SbPlane.3iv.gz
+man/man3/SbPlaneProjector.3iv.gz
+man/man3/SbProjector.3iv.gz
+man/man3/SbRotation.3iv.gz
+man/man3/SbSphere.3iv.gz
+man/man3/SbSpherePlaneProjector.3iv.gz
+man/man3/SbSphereProjector.3iv.gz
+man/man3/SbSphereSectionProjector.3iv.gz
+man/man3/SbSphereSheetProjector.3iv.gz
+man/man3/SbString.3iv.gz
+man/man3/SbTime.3iv.gz
+man/man3/SbVec2f.3iv.gz
+man/man3/SbVec2s.3iv.gz
+man/man3/SbVec3f.3iv.gz
+man/man3/SbVec4f.3iv.gz
+man/man3/SbViewVolume.3iv.gz
+man/man3/SbViewportRegion.3iv.gz
+man/man3/SbXfBox3f.3iv.gz
+man/man3/SoAction.3iv.gz
+man/man3/SoAlarmSensor.3iv.gz
+man/man3/SoAnnotation.3iv.gz
+man/man3/SoAntiSquish.3iv.gz
+man/man3/SoAppearanceKit.3iv.gz
+man/man3/SoArray.3iv.gz
+man/man3/SoAsciiText.3iv.gz
+man/man3/SoBase.3iv.gz
+man/man3/SoBaseColor.3iv.gz
+man/man3/SoBaseKit.3iv.gz
+man/man3/SoBaseList.3iv.gz
+man/man3/SoBlinker.3iv.gz
+man/man3/SoBoolOperation.3iv.gz
+man/man3/SoBoxHighlightRenderAction.3iv.gz
+man/man3/SoButtonEvent.3iv.gz
+man/man3/SoByteStream.3iv.gz
+man/man3/SoCalculator.3iv.gz
+man/man3/SoCallback.3iv.gz
+man/man3/SoCallbackAction.3iv.gz
+man/man3/SoCallbackList.3iv.gz
+man/man3/SoCamera.3iv.gz
+man/man3/SoCameraKit.3iv.gz
+man/man3/SoCenterballDragger.3iv.gz
+man/man3/SoCenterballManip.3iv.gz
+man/man3/SoClipPlane.3iv.gz
+man/man3/SoColorIndex.3iv.gz
+man/man3/SoComplexity.3iv.gz
+man/man3/SoComposeMatrix.3iv.gz
+man/man3/SoComposeRotation.3iv.gz
+man/man3/SoComposeRotationFromTo.3iv.gz
+man/man3/SoComposeVec2f.3iv.gz
+man/man3/SoComposeVec3f.3iv.gz
+man/man3/SoComposeVec4f.3iv.gz
+man/man3/SoComputeBoundingBox.3iv.gz
+man/man3/SoConcatenate.3iv.gz
+man/man3/SoCone.3iv.gz
+man/man3/SoConeDetail.3iv.gz
+man/man3/SoCoordinate3.3iv.gz
+man/man3/SoCoordinate4.3iv.gz
+man/man3/SoCounter.3iv.gz
+man/man3/SoCube.3iv.gz
+man/man3/SoCubeDetail.3iv.gz
+man/man3/SoCylinder.3iv.gz
+man/man3/SoCylinderDetail.3iv.gz
+man/man3/SoDB.3iv.gz
+man/man3/SoDataSensor.3iv.gz
+man/man3/SoDebugError.3iv.gz
+man/man3/SoDecomposeMatrix.3iv.gz
+man/man3/SoDecomposeRotation.3iv.gz
+man/man3/SoDecomposeVec2f.3iv.gz
+man/man3/SoDecomposeVec3f.3iv.gz
+man/man3/SoDecomposeVec4f.3iv.gz
+man/man3/SoDelayQueueSensor.3iv.gz
+man/man3/SoDetail.3iv.gz
+man/man3/SoDetailList.3iv.gz
+man/man3/SoDirectionalLight.3iv.gz
+man/man3/SoDirectionalLightDragger.3iv.gz
+man/man3/SoDirectionalLightManip.3iv.gz
+man/man3/SoDragPointDragger.3iv.gz
+man/man3/SoDragger.3iv.gz
+man/man3/SoDrawStyle.3iv.gz
+man/man3/SoElapsedTime.3iv.gz
+man/man3/SoEngine.3iv.gz
+man/man3/SoEngineList.3iv.gz
+man/man3/SoEngineOutput.3iv.gz
+man/man3/SoEngineOutputList.3iv.gz
+man/man3/SoEnvironment.3iv.gz
+man/man3/SoError.3iv.gz
+man/man3/SoEvent.3iv.gz
+man/man3/SoEventCallback.3iv.gz
+man/man3/SoFaceDetail.3iv.gz
+man/man3/SoFaceSet.3iv.gz
+man/man3/SoField.3iv.gz
+man/man3/SoFieldContainer.3iv.gz
+man/man3/SoFieldList.3iv.gz
+man/man3/SoFieldSensor.3iv.gz
+man/man3/SoFile.3iv.gz
+man/man3/SoFont.3iv.gz
+man/man3/SoFontStyle.3iv.gz
+man/man3/SoGLRenderAction.3iv.gz
+man/man3/SoGate.3iv.gz
+man/man3/SoGetBoundingBoxAction.3iv.gz
+man/man3/SoGetMatrixAction.3iv.gz
+man/man3/SoGroup.3iv.gz
+man/man3/SoHandleBoxDragger.3iv.gz
+man/man3/SoHandleBoxManip.3iv.gz
+man/man3/SoHandleEventAction.3iv.gz
+man/man3/SoIdleSensor.3iv.gz
+man/man3/SoIndexedFaceSet.3iv.gz
+man/man3/SoIndexedLineSet.3iv.gz
+man/man3/SoIndexedNurbsCurve.3iv.gz
+man/man3/SoIndexedNurbsSurface.3iv.gz
+man/man3/SoIndexedShape.3iv.gz
+man/man3/SoIndexedTriangleStripSet.3iv.gz
+man/man3/SoInfo.3iv.gz
+man/man3/SoInput.3iv.gz
+man/man3/SoInteraction.3iv.gz
+man/man3/SoInteractionKit.3iv.gz
+man/man3/SoInterpolate.3iv.gz
+man/man3/SoInterpolateFloat.3iv.gz
+man/man3/SoInterpolateRotation.3iv.gz
+man/man3/SoInterpolateVec2f.3iv.gz
+man/man3/SoInterpolateVec3f.3iv.gz
+man/man3/SoInterpolateVec4f.3iv.gz
+man/man3/SoJackDragger.3iv.gz
+man/man3/SoJackManip.3iv.gz
+man/man3/SoKeyboardEvent.3iv.gz
+man/man3/SoLOD.3iv.gz
+man/man3/SoLabel.3iv.gz
+man/man3/SoLevelOfDetail.3iv.gz
+man/man3/SoLight.3iv.gz
+man/man3/SoLightKit.3iv.gz
+man/man3/SoLightModel.3iv.gz
+man/man3/SoLineDetail.3iv.gz
+man/man3/SoLineHighlightRenderAction.3iv.gz
+man/man3/SoLineSet.3iv.gz
+man/man3/SoLinearProfile.3iv.gz
+man/man3/SoLocateHighlight.3iv.gz
+man/man3/SoLocation2Event.3iv.gz
+man/man3/SoMFBitMask.3iv.gz
+man/man3/SoMFBool.3iv.gz
+man/man3/SoMFColor.3iv.gz
+man/man3/SoMFEngine.3iv.gz
+man/man3/SoMFEnum.3iv.gz
+man/man3/SoMFFloat.3iv.gz
+man/man3/SoMFInt32.3iv.gz
+man/man3/SoMFLong.3iv.gz
+man/man3/SoMFMatrix.3iv.gz
+man/man3/SoMFName.3iv.gz
+man/man3/SoMFNode.3iv.gz
+man/man3/SoMFPath.3iv.gz
+man/man3/SoMFPlane.3iv.gz
+man/man3/SoMFRotation.3iv.gz
+man/man3/SoMFShort.3iv.gz
+man/man3/SoMFString.3iv.gz
+man/man3/SoMFTime.3iv.gz
+man/man3/SoMFUInt32.3iv.gz
+man/man3/SoMFULong.3iv.gz
+man/man3/SoMFUShort.3iv.gz
+man/man3/SoMFVec2f.3iv.gz
+man/man3/SoMFVec3f.3iv.gz
+man/man3/SoMFVec4f.3iv.gz
+man/man3/SoMField.3iv.gz
+man/man3/SoMaterial.3iv.gz
+man/man3/SoMaterialBinding.3iv.gz
+man/man3/SoMatrixTransform.3iv.gz
+man/man3/SoMemoryError.3iv.gz
+man/man3/SoMotion3Event.3iv.gz
+man/man3/SoMouseButtonEvent.3iv.gz
+man/man3/SoMultipleCopy.3iv.gz
+man/man3/SoNode.3iv.gz
+man/man3/SoNodeKit.3iv.gz
+man/man3/SoNodeKitDetail.3iv.gz
+man/man3/SoNodeKitListPart.3iv.gz
+man/man3/SoNodeKitPath.3iv.gz
+man/man3/SoNodeList.3iv.gz
+man/man3/SoNodeSensor.3iv.gz
+man/man3/SoNodekitCatalog.3iv.gz
+man/man3/SoNonIndexedShape.3iv.gz
+man/man3/SoNormal.3iv.gz
+man/man3/SoNormalBinding.3iv.gz
+man/man3/SoNurbsCurve.3iv.gz
+man/man3/SoNurbsProfile.3iv.gz
+man/man3/SoNurbsSurface.3iv.gz
+man/man3/SoOffscreenRenderer.3iv.gz
+man/man3/SoOnOff.3iv.gz
+man/man3/SoOneShot.3iv.gz
+man/man3/SoOneShotSensor.3iv.gz
+man/man3/SoOrthographicCamera.3iv.gz
+man/man3/SoOutput.3iv.gz
+man/man3/SoPackedColor.3iv.gz
+man/man3/SoPath.3iv.gz
+man/man3/SoPathList.3iv.gz
+man/man3/SoPathSensor.3iv.gz
+man/man3/SoPathSwitch.3iv.gz
+man/man3/SoPendulum.3iv.gz
+man/man3/SoPerspectiveCamera.3iv.gz
+man/man3/SoPickAction.3iv.gz
+man/man3/SoPickStyle.3iv.gz
+man/man3/SoPickedPoint.3iv.gz
+man/man3/SoPickedPointList.3iv.gz
+man/man3/SoPointDetail.3iv.gz
+man/man3/SoPointLight.3iv.gz
+man/man3/SoPointLightDragger.3iv.gz
+man/man3/SoPointLightManip.3iv.gz
+man/man3/SoPointSet.3iv.gz
+man/man3/SoPrimitiveVertex.3iv.gz
+man/man3/SoProfile.3iv.gz
+man/man3/SoProfileCoordinate2.3iv.gz
+man/man3/SoProfileCoordinate3.3iv.gz
+man/man3/SoQuadMesh.3iv.gz
+man/man3/SoRayPickAction.3iv.gz
+man/man3/SoReadError.3iv.gz
+man/man3/SoResetTransform.3iv.gz
+man/man3/SoRotateCylindricalDragger.3iv.gz
+man/man3/SoRotateDiscDragger.3iv.gz
+man/man3/SoRotateSphericalDragger.3iv.gz
+man/man3/SoRotation.3iv.gz
+man/man3/SoRotationXYZ.3iv.gz
+man/man3/SoRotor.3iv.gz
+man/man3/SoSFBitMask.3iv.gz
+man/man3/SoSFBool.3iv.gz
+man/man3/SoSFColor.3iv.gz
+man/man3/SoSFEngine.3iv.gz
+man/man3/SoSFEnum.3iv.gz
+man/man3/SoSFFloat.3iv.gz
+man/man3/SoSFImage.3iv.gz
+man/man3/SoSFInt32.3iv.gz
+man/man3/SoSFLong.3iv.gz
+man/man3/SoSFMatrix.3iv.gz
+man/man3/SoSFName.3iv.gz
+man/man3/SoSFNode.3iv.gz
+man/man3/SoSFPath.3iv.gz
+man/man3/SoSFPlane.3iv.gz
+man/man3/SoSFRotation.3iv.gz
+man/man3/SoSFShort.3iv.gz
+man/man3/SoSFString.3iv.gz
+man/man3/SoSFTime.3iv.gz
+man/man3/SoSFTrigger.3iv.gz
+man/man3/SoSFUInt32.3iv.gz
+man/man3/SoSFULong.3iv.gz
+man/man3/SoSFUShort.3iv.gz
+man/man3/SoSFVec2f.3iv.gz
+man/man3/SoSFVec3f.3iv.gz
+man/man3/SoSFVec4f.3iv.gz
+man/man3/SoSField.3iv.gz
+man/man3/SoScale.3iv.gz
+man/man3/SoScale1Dragger.3iv.gz
+man/man3/SoScale2Dragger.3iv.gz
+man/man3/SoScale2UniformDragger.3iv.gz
+man/man3/SoScaleUniformDragger.3iv.gz
+man/man3/SoSceneKit.3iv.gz
+man/man3/SoSceneManager.3iv.gz
+man/man3/SoSearchAction.3iv.gz
+man/man3/SoSelectOne.3iv.gz
+man/man3/SoSelection.3iv.gz
+man/man3/SoSensor.3iv.gz
+man/man3/SoSeparator.3iv.gz
+man/man3/SoSeparatorKit.3iv.gz
+man/man3/SoShape.3iv.gz
+man/man3/SoShapeHints.3iv.gz
+man/man3/SoShapeKit.3iv.gz
+man/man3/SoShuttle.3iv.gz
+man/man3/SoSpaceballButtonEvent.3iv.gz
+man/man3/SoSphere.3iv.gz
+man/man3/SoSpotLight.3iv.gz
+man/man3/SoSpotLightDragger.3iv.gz
+man/man3/SoSpotLightManip.3iv.gz
+man/man3/SoSurroundScale.3iv.gz
+man/man3/SoSwitch.3iv.gz
+man/man3/SoTabBoxDragger.3iv.gz
+man/man3/SoTabBoxManip.3iv.gz
+man/man3/SoTabPlaneDragger.3iv.gz
+man/man3/SoText2.3iv.gz
+man/man3/SoText3.3iv.gz
+man/man3/SoTextDetail.3iv.gz
+man/man3/SoTexture2.3iv.gz
+man/man3/SoTexture2Transform.3iv.gz
+man/man3/SoTextureCoordinate2.3iv.gz
+man/man3/SoTextureCoordinateBinding.3iv.gz
+man/man3/SoTextureCoordinateDefault.3iv.gz
+man/man3/SoTextureCoordinateEnvironment.3iv.gz
+man/man3/SoTextureCoordinateFunction.3iv.gz
+man/man3/SoTextureCoordinatePlane.3iv.gz
+man/man3/SoTimeCounter.3iv.gz
+man/man3/SoTimerQueueSensor.3iv.gz
+man/man3/SoTimerSensor.3iv.gz
+man/man3/SoTrackballDragger.3iv.gz
+man/man3/SoTrackballManip.3iv.gz
+man/man3/SoTranReceiver.3iv.gz
+man/man3/SoTranSender.3iv.gz
+man/man3/SoTransform.3iv.gz
+man/man3/SoTransformBoxDragger.3iv.gz
+man/man3/SoTransformBoxManip.3iv.gz
+man/man3/SoTransformManip.3iv.gz
+man/man3/SoTransformSeparator.3iv.gz
+man/man3/SoTransformVec3f.3iv.gz
+man/man3/SoTransformation.3iv.gz
+man/man3/SoTransformerDragger.3iv.gz
+man/man3/SoTransformerManip.3iv.gz
+man/man3/SoTranslate1Dragger.3iv.gz
+man/man3/SoTranslate2Dragger.3iv.gz
+man/man3/SoTranslation.3iv.gz
+man/man3/SoTriangleStripSet.3iv.gz
+man/man3/SoTriggerAny.3iv.gz
+man/man3/SoType.3iv.gz
+man/man3/SoTypeList.3iv.gz
+man/man3/SoUnits.3iv.gz
+man/man3/SoVertexProperty.3iv.gz
+man/man3/SoVertexShape.3iv.gz
+man/man3/SoWWWAnchor.3iv.gz
+man/man3/SoWWWInline.3iv.gz
+man/man3/SoWrapperKit.3iv.gz
+man/man3/SoWriteAction.3iv.gz
+man/man3/SoXt.3iv.gz
+man/man3/SoXtClipboard.3iv.gz
+man/man3/SoXtComponent.3iv.gz
+man/man3/SoXtConstrainedViewer.3iv.gz
+man/man3/SoXtDevice.3iv.gz
+man/man3/SoXtDirectionalLightEditor.3iv.gz
+man/man3/SoXtExaminerViewer.3iv.gz
+man/man3/SoXtFlyViewer.3iv.gz
+man/man3/SoXtFullViewer.3iv.gz
+man/man3/SoXtGLWidget.3iv.gz
+man/man3/SoXtInputFocus.3iv.gz
+man/man3/SoXtKeyboard.3iv.gz
+man/man3/SoXtLightSliderSet.3iv.gz
+man/man3/SoXtMaterialEditor.3iv.gz
+man/man3/SoXtMaterialList.3iv.gz
+man/man3/SoXtMaterialSliderSet.3iv.gz
+man/man3/SoXtMouse.3iv.gz
+man/man3/SoXtPlaneViewer.3iv.gz
+man/man3/SoXtPrintDialog.3iv.gz
+man/man3/SoXtRenderArea.3iv.gz
+man/man3/SoXtResource.3iv.gz
+man/man3/SoXtSliderSet.3iv.gz
+man/man3/SoXtSliderSetBase.3iv.gz
+man/man3/SoXtSpaceball.3iv.gz
+man/man3/SoXtTransformSliderSet.3iv.gz
+man/man3/SoXtViewer.3iv.gz
+man/man3/SoXtWalkViewer.3iv.gz
share/help/Inventor/SoXtBaseEditor.help
share/help/Inventor/SoXtBaseViewer.help
share/help/Inventor/SoXtColorEditor.help