aboutsummaryrefslogtreecommitdiff
path: root/graphics/ipe/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-11 18:17:22 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-11 18:17:22 +0000
commiteeb4f2a2d9df655d900c20c58f36a9c2446a7980 (patch)
tree35f96447ede42a46adbff8acf9d5070277719267 /graphics/ipe/Makefile
parente0984a2582bdf610097b92753a2bfdbcff4df975 (diff)
Notes
Diffstat (limited to 'graphics/ipe/Makefile')
-rw-r--r--graphics/ipe/Makefile52
1 files changed, 43 insertions, 9 deletions
diff --git a/graphics/ipe/Makefile b/graphics/ipe/Makefile
index 1fb60f896dd3..5643f98eaf21 100644
--- a/graphics/ipe/Makefile
+++ b/graphics/ipe/Makefile
@@ -6,26 +6,41 @@
#
PORTNAME= Ipe
-PORTVERSION= 5.0
+PORTVERSION= 6.0.p12
CATEGORIES= graphics
-MASTER_SITES= ftp://ftp.cs.uni-magdeburg.de/pub/ipe/ \
- ftp://ftp.cs.ruu.nl/pub/mirror/ipe/ \
- ftp://ftp.cs.ust.hk/pub/ipe/
+MASTER_SITES= http://www.cs.uu.nl/~otfried/Ipe/
+DISTNAME= ${PORTNAME:L}-${PORTVERSION:S/.p/pre/}
+EXTRACT_SUFX= -src.tar.gz
MAINTAINER= bremner@unb.ca
COMMENT= Extensible drawing editor
+RUN_DEPENDS= gs:${PORTSDIR}/${GSPORT} \
+ latex:${PORTSDIR}/print/teTeX
+
.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
GSPORT?= print/ghostscript-afpl
.else
GSPORT?= print/ghostscript-gnu
.endif
-RUN_DEPENDS= gs:${PORTSDIR}/${GSPORT} \
- latex:${PORTSDIR}/print/teTeX
-
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+USE_QT_VER= 3
+MAKE_ENV+= QTDIR=${QTDIR}
USE_XLIB= yes
-USE_MOTIF= yes
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS= %%PREFIX%%/libexec/ipe/${PORTVERSION:S/.p/pre/} %%PREFIX%%/lib
+NO_FILTER_SHLIBS= 1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+# the problem is a little more subtle, really. It requires gcc 3
+USE_GCC= 3.3
+.endif
+
+QTDIR?= ${X11BASE}
+QMAKE?= ${LOCALBASE}/bin/qmake
pre-fetch:
.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
@@ -35,4 +50,23 @@ pre-fetch:
@${ECHO} ""
.endif
-.include <bsd.port.mk>
+.if !defined(WITH_BROWSER)
+ @${ECHO} ""
+ @${ECHO} " Define WITH_BROWSER=myBrowser to use"
+ @${ECHO} " myBrowser to browse ipe help instead of mozilla"
+ @${ECHO} ""
+.endif
+
+WITH_BROWSER?=mozilla
+
+# This is my feeble attempt at making qmake play nice with FreeBSD.
+# If you change a variable, you _must_ reconfigure.
+# If it is not on this list, it will _not_ be propagated.
+do-configure:
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
+ ${QMAKE} -spec ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ \
+ "PREFIX=${PREFIX}" "WWWBROWSER=${WITH_BROWSER}" \
+ "CC=${CC}" "CXX=${CXX}" "LINK=${CXX}" "LINK_SHLIB=${CXX}" \
+ "LOCALBASE=${LOCALBASE}" main.pro
+
+.include <bsd.port.post.mk>