aboutsummaryrefslogtreecommitdiff
path: root/graphics/ipe
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2001-04-21 13:59:26 +0000
committerPeter Pentchev <roam@FreeBSD.org>2001-04-21 13:59:26 +0000
commit12e491196b134bed46fc7a06e09d14f8d99fbf63 (patch)
tree1528ca0ef4a883dbfafc910d76952a0f5530d269 /graphics/ipe
parent7b488295120bfec78abcdd29c219fd0995676c04 (diff)
downloadports-12e491196b134bed46fc7a06e09d14f8d99fbf63.tar.gz
ports-12e491196b134bed46fc7a06e09d14f8d99fbf63.zip
Notes
Diffstat (limited to 'graphics/ipe')
-rw-r--r--graphics/ipe/Makefile2
-rw-r--r--graphics/ipe/files/patch-Ipe23
-rw-r--r--graphics/ipe/files/patch-Ipe.app-defaults4
-rw-r--r--graphics/ipe/files/patch-Makefile21
-rw-r--r--graphics/ipe/pkg-descr8
5 files changed, 36 insertions, 22 deletions
diff --git a/graphics/ipe/Makefile b/graphics/ipe/Makefile
index e019a1769394..179127b610a3 100644
--- a/graphics/ipe/Makefile
+++ b/graphics/ipe/Makefile
@@ -18,6 +18,6 @@ RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript6 \
latex:${PORTSDIR}/print/teTeX
USE_XLIB= yes
-REQUIRES_MOTIF= yes
+USE_MOTIF= yes
.include <bsd.port.mk>
diff --git a/graphics/ipe/files/patch-Ipe b/graphics/ipe/files/patch-Ipe
index 8b673dadc223..74134c46eb00 100644
--- a/graphics/ipe/files/patch-Ipe
+++ b/graphics/ipe/files/patch-Ipe
@@ -1,6 +1,6 @@
diff -cr ../Ipe-5.0/Ipe/Makefile Ipe/Makefile
*** ../Ipe-5.0/Ipe/Makefile Thu Nov 27 16:09:18 1997
---- Ipe/Makefile Thu Oct 26 14:57:59 2000
+--- Ipe/Makefile Sun Nov 5 14:51:33 2000
***************
*** 26,42 ****
@@ -24,7 +24,7 @@ diff -cr ../Ipe-5.0/Ipe/Makefile Ipe/Makefile
# define GFLAGS if you use g++
#GFLAGS =
-! GFLAGS = -fno-for-scope -g
+! GFLAGS = -fno-for-scope
# Need to find X and Motif
! INCLUDE_DIRS = -I../Plageo -I/usr/X11R6/include
@@ -111,7 +111,7 @@ diff -cr ../Ipe-5.0/Ipe/advertise.h Ipe/advertise.h
IpeCallback callback DefaultsTo(NIL));
diff -cr ../Ipe-5.0/Ipe/colors.C Ipe/colors.C
*** ../Ipe-5.0/Ipe/colors.C Tue May 9 04:36:03 1995
---- Ipe/colors.C Wed Oct 25 15:19:03 2000
+--- Ipe/colors.C Thu Nov 2 15:31:19 2000
***************
*** 123,129 ****
// COLOR I/O
@@ -129,6 +129,21 @@ diff -cr ../Ipe-5.0/Ipe/colors.C Ipe/colors.C
// save color in file
{
if (!col)
+***************
+*** 409,414 ****
+--- 409,420 ----
+
+ // if less than 6 bits, give up and use b&w
+
++ if (!bestv[PseudoColor]){
++ cerr << "No PseudoColor visuals found\n";
++ monochrome=true;
++ return;
++ }
++
+ if (bestv[PseudoColor]->depth < 6) {
+ monochrome = TRUE;
+ return;
diff -cr ../Ipe-5.0/Ipe/configuration.C Ipe/configuration.C
*** ../Ipe-5.0/Ipe/configuration.C Tue May 9 04:36:04 1995
--- Ipe/configuration.C Wed Oct 25 15:24:38 2000
@@ -213,8 +228,6 @@ diff -cr ../Ipe-5.0/Ipe/interface.C Ipe/interface.C
// popup an (error) message window with one or two lines of text
// window stays, and is removed by its OK button
{
-Only in ../Ipe-5.0/Ipe: ipe
-Only in Ipe: ipe.core
diff -cr ../Ipe-5.0/Ipe/itypes.h Ipe/itypes.h
*** ../Ipe-5.0/Ipe/itypes.h Tue May 9 04:36:00 1995
--- Ipe/itypes.h Wed Oct 25 11:32:14 2000
diff --git a/graphics/ipe/files/patch-Ipe.app-defaults b/graphics/ipe/files/patch-Ipe.app-defaults
index 61157b7b801a..62c98db704f5 100644
--- a/graphics/ipe/files/patch-Ipe.app-defaults
+++ b/graphics/ipe/files/patch-Ipe.app-defaults
@@ -1,5 +1,5 @@
*** ../Ipe-5.0/Ipe.app-defaults Tue May 9 04:38:01 1995
---- Ipe.app-defaults Wed Nov 1 11:21:40 2000
+--- Ipe.app-defaults Sun Nov 5 15:31:31 2000
***************
*** 6,13 ****
!
@@ -57,7 +57,7 @@
! INSTALL: Command to start help system
!
*helpCommand: \
-! netscape file://localhost/usr/X11R6/lib/ipe/doc/Ipe.html &
+! netscape file://localhost/usr/local/lib/ipe/doc/Ipe.html &
!
!
! INSTALL: Directories where Ipe can find Ipe User Macros (IUMs)
diff --git a/graphics/ipe/files/patch-Makefile b/graphics/ipe/files/patch-Makefile
index b68e29ca2d86..a8869a8d4f5b 100644
--- a/graphics/ipe/files/patch-Makefile
+++ b/graphics/ipe/files/patch-Makefile
@@ -1,5 +1,5 @@
*** ../Ipe-5.0/Makefile Sat Dec 20 12:05:11 1997
---- Makefile Fri Oct 27 16:23:21 2000
+--- Makefile Sun Nov 5 14:55:20 2000
***************
*** 1,33 ****
###########################################################################
@@ -27,15 +27,15 @@
! cp html/* $(INSTALL_DIR)/doc/
! cp Ipe.app-defaults.linux /usr/lib/X11/app-defaults/Ipe
! cp ipe2eps /usr/local/bin/
-
-- kitit:
-- cd Plageo/ ; rm -r -f *.o
-- cd Ipe/ ; rm -r -f *.o
-- cd Ium/ ; rm -r -f *.o
-- rm -f Ipe-5.0.tar Ipe-5.0.tar.gz
-- cd .. ; tar cf Ipe-5.0/Ipe-5.0.tar Ipe-5.0/*
-- gzip Ipe-5.0.tar
---- 1,34 ----
+!
+! kitit:
+! cd Plageo/ ; rm -r -f *.o
+! cd Ipe/ ; rm -r -f *.o
+! cd Ium/ ; rm -r -f *.o
+! rm -f Ipe-5.0.tar Ipe-5.0.tar.gz
+! cd .. ; tar cf Ipe-5.0/Ipe-5.0.tar Ipe-5.0/*
+! gzip Ipe-5.0.tar
+--- 1,33 ----
###########################################################################
# Ipe Makefile for Linux
! # Modfied for FreeBSD ports, David Bremner
@@ -69,4 +69,3 @@
! $(BSD_INSTALL_DATA) tex/ipe_pages.tex ${IPETEXDIR}
! $(BSD_INSTALL_DATA) tex/mipe.cls ${IPETEXDIR}
! ${PREFIX}/bin/texconfig rehash
-
diff --git a/graphics/ipe/pkg-descr b/graphics/ipe/pkg-descr
index 428ce151e310..7e2689739b47 100644
--- a/graphics/ipe/pkg-descr
+++ b/graphics/ipe/pkg-descr
@@ -2,9 +2,11 @@ This is a port of Ipe, Otfried Cheong's Interactive Picture Editor.
Ipe has a very nice integration of LaTeX text and PostScript drawings.
There are a couple of gotchas that potential installers should be aware of
-1) Unfortunately Ipe only works in 8 bit colour. As far as I know this is
-a Motif limitation. Starting in higher colour depth will yield a core
-dump.
+1) Ipe needs a pseudocolor visual to work optimally. XFree86
+currently only provides this at 8 bit colour depth. If you run Ipe at
+a higher colour depth, it reverts to "monochrome mode", which is not
+nearly as nice. This falling back to monochrome mode is my
+modification, so direct any complaints to me first.
2) The previewing features sensitive to which versions of teTeX and ghostscript
are installed. They work with the versions listed in the Makefile, but