aboutsummaryrefslogtreecommitdiff
path: root/graphics/ipe
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-05-29 21:01:38 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-05-29 21:01:38 +0000
commitf184d715f51b28b37333f89b2200b4ab1c72db55 (patch)
tree1b3e1d23d67361513d01017bf5487e6a0e755c7b /graphics/ipe
parent539ec30302e69b8de068aeb8ef5a912e4cffd0ee (diff)
downloadports-f184d715f51b28b37333f89b2200b4ab1c72db55.tar.gz
ports-f184d715f51b28b37333f89b2200b4ab1c72db55.zip
Notes
Diffstat (limited to 'graphics/ipe')
-rw-r--r--graphics/ipe/Makefile7
-rw-r--r--graphics/ipe/distinfo4
-rw-r--r--graphics/ipe/files/patch-src-config-mak34
-rw-r--r--graphics/ipe/pkg-plist93
4 files changed, 93 insertions, 45 deletions
diff --git a/graphics/ipe/Makefile b/graphics/ipe/Makefile
index d6a85e058eac..5dcfe6bb4a16 100644
--- a/graphics/ipe/Makefile
+++ b/graphics/ipe/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= ipe
-DISTVERSION= 7.0.10
-PORTREVISION= 1
+DISTVERSION= 7.1.2
CATEGORIES= graphics
MASTER_SITES= SF
-MASTER_SITE_SUBDIR= ipe7/ipe
+MASTER_SITE_SUBDIR= ${PORTNAME}7/${PORTNAME}/7.1.0
DISTNAME= ${PORTNAME}-${DISTVERSION}-src
MAINTAINER= tkjacobsen@gmail.com
@@ -27,7 +26,7 @@ USE_GMAKE= yes
USE_GNOME= pkgconfig
USE_QT_VER= 4
QT_COMPONENTS= gui qt3support qmake_build moc_build uic_build rcc_build
-MAN1= ipe.1 ipe6upgrade.1 ipeextract.1 iperender.1 ipetoipe.1
+MAN1= ipe.1 ipe6upgrade.1 ipeextract.1 iperender.1 ipetoipe.1 ipescript.1
.if defined(NOPORTDOCS)
EXTRA_PATCHES+= ${FILESDIR}/extrapatch-ipe__Makefile
diff --git a/graphics/ipe/distinfo b/graphics/ipe/distinfo
index e8e879387dc7..cee20c70f94c 100644
--- a/graphics/ipe/distinfo
+++ b/graphics/ipe/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ipe-7.0.10-src.tar.gz) = f343493d9e4d2390a9fdd5403162d187dd6ec1b204e7c026baec76657f40cd9c
-SIZE (ipe-7.0.10-src.tar.gz) = 1158532
+SHA256 (ipe-7.1.2-src.tar.gz) = 3390de67ee22b2de74acfab2e9fb29bcfd6fe180688086febb758dc8a82eda11
+SIZE (ipe-7.1.2-src.tar.gz) = 1416404
diff --git a/graphics/ipe/files/patch-src-config-mak b/graphics/ipe/files/patch-src-config-mak
index 858e041b3b21..65808de0b45c 100644
--- a/graphics/ipe/files/patch-src-config-mak
+++ b/graphics/ipe/files/patch-src-config-mak
@@ -1,25 +1,31 @@
---- config.mak.orig 2009-11-22 01:56:12.000000000 +0100
-+++ config.mak 2009-11-22 14:03:58.000000000 +0100
-@@ -18,8 +18,8 @@
+--- config.mak.orig 2012-05-22 11:50:19.537220266 +0600
++++ config.mak 2012-05-22 11:57:03.846226857 +0600
+@@ -46,14 +46,8 @@
CAIRO_CFLAGS ?= $(shell pkg-config --cflags cairo)
CAIRO_LIBS ?= $(shell pkg-config --libs cairo)
- ifndef MACOS
--LUA_CFLAGS ?= $(shell pkg-config --cflags lua5.1)
--LUA_LIBS ?= $(shell pkg-config --libs lua5.1)
-+LUA_CFLAGS ?= -I$(LUA_INCDIR)
-+LUA_LIBS ?= -L$(LUA_LIBDIR) -llua
+ # The lua package might be called "lua" or "lua5.1"
+-luatest = $(shell pkg-config --modversion --silence-errors lua)
+-ifneq "$(luatest)" ""
+- LUA_CFLAGS ?= $(shell pkg-config --cflags lua)
+- LUA_LIBS ?= $(shell pkg-config --libs lua)
+-else
+- LUA_CFLAGS ?= $(shell pkg-config --cflags lua5.1)
+- LUA_LIBS ?= $(shell pkg-config --libs lua5.1)
+-endif
++LUA_CFLAGS ?= -I$(LUA_INCDIR)
++LUA_LIBS ?= -L$(LUA_LIBDIR) -llua
+ GTK_CFLAGS ?= $(shell pkg-config --cflags gtk+-2.0)
+ GTK_LIBS ?= $(shell pkg-config --libs gtk+-2.0)
QT_CFLAGS ?= $(shell pkg-config --cflags QtGui QtCore)
- QT_LIBS ?= $(shell pkg-config --libs QtGui QtCore)
- #
-@@ -75,6 +75,7 @@
- #IPEPREFIX := /usr/local
+@@ -123,6 +117,7 @@
#IPEPREFIX := /usr
#IPEPREFIX := /opt/ipe7
-+IPEPREFIX := $(PREFIX)
#
++IPEPREFIX := $(PREFIX)
ifeq "$(IPEPREFIX)" ""
$(error You need to specify IPEPREFIX!)
-@@ -115,11 +116,11 @@
+ endif
+@@ -157,11 +152,11 @@
#
# IPEDOCDIR contains the Ipe documentation (mostly html files)
#
diff --git a/graphics/ipe/pkg-plist b/graphics/ipe/pkg-plist
index f0939360a968..619569fe31ed 100644
--- a/graphics/ipe/pkg-plist
+++ b/graphics/ipe/pkg-plist
@@ -1,13 +1,17 @@
bin/ipe
-bin/ipe-update-master
bin/ipe6upgrade
bin/ipeextract
bin/iperender
+bin/ipescript
bin/ipetoipe
bin/ipeview
include/ipeattributes.h
include/ipebase.h
include/ipebitmap.h
+include/ipecanvas.h
+include/ipecanvas_gtk.h
+include/ipecanvas_qt.h
+include/ipecanvas_win.h
include/ipedoc.h
include/ipefactory.h
include/ipefontpool.h
@@ -26,10 +30,12 @@ include/ipepdfparser.h
include/ipepdfwriter.h
include/ipepswriter.h
include/ipereference.h
+include/ipeselector_qt.h
include/ipeshape.h
include/ipesnap.h
include/ipestyle.h
include/ipetext.h
+include/ipetool.h
include/ipeutils.h
include/ipexml.h
lib/ipe/%%VERSION%%/ipelets/align.lua
@@ -41,16 +47,17 @@ lib/ipe/%%VERSION%%/ipelets/move.lua
lib/ipe/%%VERSION%%/ipelets/search-replace.lua
lib/ipe/%%VERSION%%/ipelets/symbols.lua
lib/libipe.so
-lib/libipe.so.7.0.10
+lib/libipe.so.7.1.2
lib/libipecairo.so
-lib/libipecairo.so.7.0.10
+lib/libipecairo.so.7.1.2
+lib/libipecanvas.so
+lib/libipecanvas.so.7.1.2
lib/libipelua.so
-lib/libipelua.so.7.0.10
-lib/libipeqtcanvas.so
-lib/libipeqtcanvas.so.7.0.10
+lib/libipelua.so.7.1.2
lib/libipeui.so
-lib/libipeui.so.7.0.10
+lib/libipeui.so.7.1.2
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/annotated.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/bc_s.png
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/blank.png
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/class_ipe_auto_ptr-members.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/class_ipe_auto_ptr.html
@@ -87,6 +94,12 @@ lib/libipeui.so.7.0.10
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_buffer_source.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_cairo_painter-members.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_cairo_painter.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_canvas_base.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_canvas_base-members.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_canvas-members.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_canvas_observer.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_canvas_observer-members.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_canvas.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_cascade-members.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_cascade.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_closed_spline-members.html
@@ -143,9 +156,13 @@ lib/libipeui.so.7.0.10
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_object_factory-members.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_object_factory.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_page-members.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_page_selector.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_page_selector-members.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_page.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_painter-members.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_painter.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_pan_tool-members.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_pan_tool.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_path-members.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_path.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_pdf_array-members.html
@@ -188,6 +205,8 @@ lib/libipeui.so.7.0.10
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_repository.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_segment-members.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_segment.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_select_tool-members.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_select_tool.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_shape-members.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_shape.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_snap-members.html
@@ -207,6 +226,12 @@ lib/libipeui.so.7.0.10
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_tell_stream.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_text-members.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_text.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_thumbnail.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_thumbnail-members.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_tool.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_tool-members.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_transform_tool.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_transform_tool-members.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_vector-members.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_vector.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_visitor-members.html
@@ -215,16 +240,7 @@ lib/libipeui.so.7.0.10
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_xml_attributes.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_xml_parser-members.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipe_1_1_xml_parser.html
-%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipeqt_1_1_canvas-members.html
-%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipeqt_1_1_canvas.html
-%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipeqt_1_1_pan_tool-members.html
-%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipeqt_1_1_pan_tool.html
-%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipeqt_1_1_select_tool-members.html
-%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipeqt_1_1_select_tool.html
-%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipeqt_1_1_tool-members.html
-%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipeqt_1_1_tool.html
-%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipeqt_1_1_transform_tool-members.html
-%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/classipeqt_1_1_transform_tool.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/closed.png
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/cpp-ipelets.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/doxygen.css
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/doxygen.png
@@ -295,12 +311,12 @@ lib/libipeui.so.7.0.10
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/group__attr.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/group__base.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/group__cairo.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/group__canvas.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/group__doc.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/group__geo.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/group__high.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/group__ipelet.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/group__obj.html
-%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/group__qtcanvas.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/hierarchy.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/intersection.svg
@@ -381,11 +397,17 @@ lib/libipeui.so.7.0.10
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/namespacemembers_type.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/namespacemembers_vars.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/namespaces.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/nav_f.png
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/nav_h.png
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/next.png
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/open.png
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/previous.png
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/polygon.pdf
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/radgrad1.svg
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/radgrad2.svg
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/snaplines.svg
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/structipe_1_1_canvas_base_1_1_style.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/structipe_1_1_canvas_base_1_1_style-members.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/structipe_1_1_document_1_1_s_properties-members.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/structipe_1_1_document_1_1_s_properties.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/structipe_1_1_effect.html
@@ -403,6 +425,8 @@ lib/libipeui.so.7.0.10
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/structipe_1_1_painter_1_1_state.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/structipe_1_1_pdf_token-members.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/structipe_1_1_pdf_token.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/structipe_1_1_select_tool_1_1_s_obj.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/structipe_1_1_select_tool_1_1_s_obj-members.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/structipe_1_1_style_sheet_1_1_page_number_style-members.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/structipe_1_1_style_sheet_1_1_page_number_style.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/structipe_1_1_style_sheet_1_1_title_style-members.html
@@ -410,19 +434,25 @@ lib/libipeui.so.7.0.10
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/structipe_1_1_symbol.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/structipe_1_1_text_1_1_x_form-members.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/structipe_1_1_text_1_1_x_form.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/structipe_1_1_text_padding.html
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/structipe_1_1_text_padding-members.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/structipe_1_1_tiling-members.html
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/structipe_1_1_tiling.html
-%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/structipeqt_1_1_canvas_1_1_style-members.html
-%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/structipeqt_1_1_canvas_1_1_style.html
-%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/structipeqt_1_1_select_tool_1_1_s_obj-members.html
-%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/structipeqt_1_1_select_tool_1_1_s_obj.html
-%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/tab_b.gif
-%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/tab_l.gif
-%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/tab_r.gif
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/tab_a.png
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/tab_b.png
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/tab_h.png
+%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/tab_s.png
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/tabs.css
%%PORTDOCS%%%%DOCSDIR%%/%%VERSION%%/up.png
%%DATADIR%%/%%VERSION%%/fontmap.xml
+%%DATADIR%%/%%VERSION%%/icons/copy.png
+%%DATADIR%%/%%VERSION%%/icons/cut.png
+%%DATADIR%%/%%VERSION%%/icons/delete.png
+%%DATADIR%%/%%VERSION%%/icons/fit_objects.png
+%%DATADIR%%/%%VERSION%%/icons/fit_page.png
+%%DATADIR%%/%%VERSION%%/icons/fit_width.png
%%DATADIR%%/%%VERSION%%/icons/ipe.png
+%%DATADIR%%/%%VERSION%%/icons/keyboard.png
%%DATADIR%%/%%VERSION%%/icons/mode_arc1.png
%%DATADIR%%/%%VERSION%%/icons/mode_arc2.png
%%DATADIR%%/%%VERSION%%/icons/mode_arc3.png
@@ -440,29 +470,42 @@ lib/libipeui.so.7.0.10
%%DATADIR%%/%%VERSION%%/icons/mode_rectangles.png
%%DATADIR%%/%%VERSION%%/icons/mode_rotate.png
%%DATADIR%%/%%VERSION%%/icons/mode_select.png
+%%DATADIR%%/%%VERSION%%/icons/mode_shredder.png
%%DATADIR%%/%%VERSION%%/icons/mode_splinegons.png
%%DATADIR%%/%%VERSION%%/icons/mode_splines.png
%%DATADIR%%/%%VERSION%%/icons/mode_stretch.png
%%DATADIR%%/%%VERSION%%/icons/mode_translate.png
+%%DATADIR%%/%%VERSION%%/icons/paste.png
%%DATADIR%%/%%VERSION%%/icons/pen.png
+%%DATADIR%%/%%VERSION%%/icons/redo.png
+%%DATADIR%%/%%VERSION%%/icons/shift_key.png
%%DATADIR%%/%%VERSION%%/icons/snapangle.png
%%DATADIR%%/%%VERSION%%/icons/snapauto.png
%%DATADIR%%/%%VERSION%%/icons/snapbd.png
%%DATADIR%%/%%VERSION%%/icons/snapgrid.png
%%DATADIR%%/%%VERSION%%/icons/snapint.png
%%DATADIR%%/%%VERSION%%/icons/snapvtx.png
+%%DATADIR%%/%%VERSION%%/icons/undo.png
+%%DATADIR%%/%%VERSION%%/icons/zoom_in.png
+%%DATADIR%%/%%VERSION%%/icons/zoom_out.png
%%DATADIR%%/%%VERSION%%/lua/actions.lua
%%DATADIR%%/%%VERSION%%/lua/editpath.lua
%%DATADIR%%/%%VERSION%%/lua/main.lua
%%DATADIR%%/%%VERSION%%/lua/model.lua
+%%DATADIR%%/%%VERSION%%/lua/mouse.lua
%%DATADIR%%/%%VERSION%%/lua/prefs.lua
%%DATADIR%%/%%VERSION%%/lua/properties.lua
%%DATADIR%%/%%VERSION%%/lua/shortcuts.lua
%%DATADIR%%/%%VERSION%%/lua/tools.lua
+%%DATADIR%%/%%VERSION%%/scripts/add-style.lua
+%%DATADIR%%/%%VERSION%%/scripts/update-master.lua
+%%DATADIR%%/%%VERSION%%/scripts/update-styles.lua
%%DATADIR%%/%%VERSION%%/styles/basic.isy
+%%DATADIR%%/%%VERSION%%/styles/beamer.isy
%%DATADIR%%/%%VERSION%%/styles/colors.isy
%%DATADIR%%/%%VERSION%%/styles/presentation.isy
@dirrm %%DATADIR%%/%%VERSION%%/styles
+@dirrm %%DATADIR%%/%%VERSION%%/scripts
@dirrm %%DATADIR%%/%%VERSION%%/lua
@dirrm %%DATADIR%%/%%VERSION%%/icons
@dirrm %%DATADIR%%/%%VERSION%%