aboutsummaryrefslogtreecommitdiff
path: root/graphics/isreal
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-07 06:08:33 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-07 06:08:33 +0000
commitbf93d27159c3d28457ef8ee1e422a0cbc49e72df (patch)
treebc63a3e1f2c37653366016c9e1a581b043d6ba3f /graphics/isreal
parent1f84276af5d0273da131b53458916adeb7f3ba76 (diff)
downloadports-bf93d27159c3d28457ef8ee1e422a0cbc49e72df.tar.gz
ports-bf93d27159c3d28457ef8ee1e422a0cbc49e72df.zip
Notes
Diffstat (limited to 'graphics/isreal')
-rw-r--r--graphics/isreal/Makefile22
-rw-r--r--graphics/isreal/distinfo1
-rw-r--r--graphics/isreal/files/patch-Makefile22
-rw-r--r--graphics/isreal/files/patch-getopt11
-rw-r--r--graphics/isreal/pkg-comment1
-rw-r--r--graphics/isreal/pkg-descr16
-rw-r--r--graphics/isreal/pkg-plist1
7 files changed, 74 insertions, 0 deletions
diff --git a/graphics/isreal/Makefile b/graphics/isreal/Makefile
new file mode 100644
index 000000000000..b56f782325fe
--- /dev/null
+++ b/graphics/isreal/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: isreal
+# Date created: Mar 31, 2001
+# Whom: Mark Pulford <mark@kyne.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= isreal
+PORTVERSION= 2.0
+CATEGORIES= graphics
+MASTER_SITES= ftp://ftp.freeradius.org/pub/isreal/
+EXTRACT_SUFX= .tar
+
+MAINTAINER= mark@kyne.com.au
+
+USE_XLIB= yes
+USE_IMLIB= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/isreal ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/isreal/distinfo b/graphics/isreal/distinfo
new file mode 100644
index 000000000000..f8cae736fd78
--- /dev/null
+++ b/graphics/isreal/distinfo
@@ -0,0 +1 @@
+MD5 (isreal-2.0.tar) = 6ced43fc94f64909c13ec3373681e483
diff --git a/graphics/isreal/files/patch-Makefile b/graphics/isreal/files/patch-Makefile
new file mode 100644
index 000000000000..0f678134e02a
--- /dev/null
+++ b/graphics/isreal/files/patch-Makefile
@@ -0,0 +1,22 @@
+--- Makefile.orig Thu Jan 6 08:09:10 2000
++++ Makefile Sat Mar 31 19:46:20 2001
+@@ -3,13 +3,14 @@
+ #
+ LIBS = -L/usr/X11R6/lib -L/usr/local/lib -lX11 -lXext \
+- -ljpeg -lpng -ltiff -lz -lgif -lm -lImlib
+-CFLAGS = -g -Wall -Wshadow -Wpointer-arith -Wcast-qual -Wcast-align \
+- -Wwrite-strings -Wconversion -Waggregate-return -Wstrict-prototypes \
+- -Wmissing-prototypes -Wmissing-declarations -Wnested-externs
++ -ljpeg -lpng -ltiff -lz -lungif -lm -lImlib
++
++CFLAGS += -I/usr/X11R6/include
+
+ VERSION=2.0
+
++all: isreal
++
+ isreal: isreal.o
+- $(CC) $^ $(LIBS) -o $@
++ $(CC) isreal.o $(LIBS) -o $@
+
+ clean:
diff --git a/graphics/isreal/files/patch-getopt b/graphics/isreal/files/patch-getopt
new file mode 100644
index 000000000000..51eb56d5bfd7
--- /dev/null
+++ b/graphics/isreal/files/patch-getopt
@@ -0,0 +1,11 @@
+--- isreal.c.orig Sat Mar 31 19:06:30 2001
++++ isreal.c Sat Mar 31 19:06:37 2001
+@@ -20,7 +20,7 @@
+ #include <X11/Xutil.h>
+ #include <Imlib.h>
+ #include <math.h>
+-#include <getopt.h>
++#include <unistd.h>
+ #include <errno.h>
+
+ #ifndef FALSE
diff --git a/graphics/isreal/pkg-comment b/graphics/isreal/pkg-comment
new file mode 100644
index 000000000000..923c2c17cdca
--- /dev/null
+++ b/graphics/isreal/pkg-comment
@@ -0,0 +1 @@
+An image classification utility
diff --git a/graphics/isreal/pkg-descr b/graphics/isreal/pkg-descr
new file mode 100644
index 000000000000..ac1b62f8c012
--- /dev/null
+++ b/graphics/isreal/pkg-descr
@@ -0,0 +1,16 @@
+IsReal analyzes image files to guess the type of image contained:
+real, realistic or unreal.
+
+WWW: http://www.striker.ottawa.on.ca/~aland/isreal/
+
+IsReal is distributed under the following license:
+
+Copyright (c) 1999 Alan DeKok <aland@ox.org>
+
+All rights reserved.
+
+Redistribution and use in source and binary forms are permitted
+provided that the above copyright notice and this paragraph are
+duplicated in all such forms and that any documentation, advertising
+materials, and other materials related to such distribution and use,
+acknowledge that the software was developed by Alan DeKok.
diff --git a/graphics/isreal/pkg-plist b/graphics/isreal/pkg-plist
new file mode 100644
index 000000000000..c2c3c814bcf4
--- /dev/null
+++ b/graphics/isreal/pkg-plist
@@ -0,0 +1 @@
+bin/isreal