aboutsummaryrefslogtreecommitdiff
path: root/graphics/ivtools/Makefile
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2009-07-16 13:26:51 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2009-07-16 13:26:51 +0000
commitb78c2662fd194007646e98d7ace5a4c28fd307ce (patch)
tree8907e5f83c965f1deaea3081e31f928ed61b0d82 /graphics/ivtools/Makefile
parent8cfd75625951e25b20b2df7207288b309b299a8f (diff)
Notes
Diffstat (limited to 'graphics/ivtools/Makefile')
-rw-r--r--graphics/ivtools/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/ivtools/Makefile b/graphics/ivtools/Makefile
index bb8f715762d9..da8f6479d417 100644
--- a/graphics/ivtools/Makefile
+++ b/graphics/ivtools/Makefile
@@ -18,11 +18,12 @@ COMMENT= Drawing editors derived from idraw
BUILD_DEPENDS= imake:${PORTSDIR}/devel/imake
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff
+USE_GMAKE= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf:262
CONFIGURE_ARGS= --with-tiff=${PREFIX}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
-USE_LDCONFIG= yes
MAKE_ARGS= ARCH=FREEBSD
USE_XORG= x11 xaw ice xext
@@ -34,4 +35,9 @@ MAN1= idraw.1 iclass.1 drawtool.1 comterp.1 comdraw.1 flipbook.1 graphdraw.1
.if ${ARCH} == "amd64"
BROKEN= incomplete pkg-plist
.endif
+
+.if ${OSVERSION} <= 604100
+USE_GCC= 4.2+
+.endif
+
.include <bsd.port.post.mk>