aboutsummaryrefslogtreecommitdiff
path: root/graphics/jasper
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-15 16:46:55 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-15 16:46:55 +0000
commit1e9daf32c553888fe783c5b776e791d122fe6f98 (patch)
treeee83e00c46a135b87f463c725327d5f6e64c1d29 /graphics/jasper
parent6e64e601329d42246f92c9f25064315946589550 (diff)
downloadports-1e9daf32c553888fe783c5b776e791d122fe6f98.tar.gz
ports-1e9daf32c553888fe783c5b776e791d122fe6f98.zip
Notes
Diffstat (limited to 'graphics/jasper')
-rw-r--r--graphics/jasper/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/graphics/jasper/Makefile b/graphics/jasper/Makefile
index 5b08fa263935..a5d8db1f4a42 100644
--- a/graphics/jasper/Makefile
+++ b/graphics/jasper/Makefile
@@ -34,12 +34,13 @@ MASTER_SITE_IMAGEMAGICK= \
ftp://ftp.imagemagick.org/pub/%SUBDIR%/ \
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,graphics/&,}
-OPTIONS= OPENGL "OpenGL support" off \
- UUID "UUID support (required by GDAL)" off
+OPTIONS_DEFINE= OPENGL UUID
+OPTIONS_DEFAULT=
+UUID_DESC= UUID support (required by GDAL)
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_OPENGL)
+.if ${PORT_OPTIONS:MOPENGL}
USE_GL= glut
CONFIGURE_ARGS+=--enable-opengl
PLIST_SUB+= OPENGL=""
@@ -48,7 +49,7 @@ CONFIGURE_ARGS+=--disable-opengl
PLIST_SUB+= OPENGL="@comment "
.endif
-.if defined(WITH_UUID)
+.if ${PORT_OPTIONS:MUUID}
EXTRA_PATCHES+= ${FILESDIR}/uuid.patch
.endif
@@ -65,4 +66,4 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>