aboutsummaryrefslogtreecommitdiff
path: root/graphics/jbig2dec
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-04-09 12:29:43 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-04-09 12:29:43 +0000
commit7fcc6761eb6598343acb9672d7afe14bf4968d0b (patch)
tree38435e6c1c20437a4bddf9fe451a88b821bc42e7 /graphics/jbig2dec
parent848eb75b28e6e77ddfbfd14ded746335c4fa439a (diff)
Notes
Diffstat (limited to 'graphics/jbig2dec')
-rw-r--r--graphics/jbig2dec/Makefile2
-rw-r--r--graphics/jbig2dec/distinfo4
-rw-r--r--graphics/jbig2dec/files/patch-jbig2_image_png.c28
-rw-r--r--graphics/jbig2dec/files/patch-sha1.c8
4 files changed, 7 insertions, 35 deletions
diff --git a/graphics/jbig2dec/Makefile b/graphics/jbig2dec/Makefile
index 9d462347fa28..12d78c45d67d 100644
--- a/graphics/jbig2dec/Makefile
+++ b/graphics/jbig2dec/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= jbig2dec
-PORTVERSION= 0.12
+PORTVERSION= 0.13
CATEGORIES= graphics devel
MASTER_SITES= http://downloads.ghostscript.com/public/${PORTNAME}/ \
LOCAL/sunpoet:tests
diff --git a/graphics/jbig2dec/distinfo b/graphics/jbig2dec/distinfo
index 78dc644c454e..18d407151beb 100644
--- a/graphics/jbig2dec/distinfo
+++ b/graphics/jbig2dec/distinfo
@@ -1,4 +1,4 @@
-SHA256 (jbig2dec-0.12.tar.gz) = bcc5f2cc75ee46e9a2c3c68d4a1b740280c772062579a5d0ceda24bee2e5ebf0
-SIZE (jbig2dec-0.12.tar.gz) = 330935
+SHA256 (jbig2dec-0.13.tar.gz) = 5aaca0070992cc2e971e3bb2338ee749495613dcecab4c868fc547b4148f5311
+SIZE (jbig2dec-0.13.tar.gz) = 442571
SHA256 (jb2streams.tar.gz) = 1b070a15468d186010047b5525b2eb99cdcda655576600d2d8a0d008b80a5ba2
SIZE (jb2streams.tar.gz) = 1000034
diff --git a/graphics/jbig2dec/files/patch-jbig2_image_png.c b/graphics/jbig2dec/files/patch-jbig2_image_png.c
deleted file mode 100644
index bab346ca99b8..000000000000
--- a/graphics/jbig2dec/files/patch-jbig2_image_png.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- jbig2_image_png.c.orig 2014-10-31 13:30:04 UTC
-+++ jbig2_image_png.c
-@@ -26,7 +26,6 @@
- #include <stdio.h>
- #include <stdlib.h>
- #include <png.h>
--#include <pngstruct.h>
- #define CVT_PTR(ptr) (ptr)
-
- #include "jbig2.h"
-@@ -40,7 +39,7 @@ jbig2_png_write_data(png_structp png_ptr
- {
- png_size_t check;
-
-- check = fwrite(data, 1, length, (png_FILE_p)png_ptr->io_ptr);
-+ check = fwrite(data, 1, length, (png_FILE_p)png_get_io_ptr(png_ptr));
- if (check != length) {
- png_error(png_ptr, "Write Error");
- }
-@@ -50,7 +49,7 @@ static void
- jbig2_png_flush(png_structp png_ptr)
- {
- png_FILE_p io_ptr;
-- io_ptr = (png_FILE_p)CVT_PTR((png_ptr->io_ptr));
-+ io_ptr = (png_FILE_p)png_get_io_ptr(png_ptr);
- if (io_ptr != NULL)
- fflush(io_ptr);
- }
diff --git a/graphics/jbig2dec/files/patch-sha1.c b/graphics/jbig2dec/files/patch-sha1.c
index 7e831800d3f7..8bf5fbc99ce6 100644
--- a/graphics/jbig2dec/files/patch-sha1.c
+++ b/graphics/jbig2dec/files/patch-sha1.c
@@ -7,18 +7,18 @@
+
+#include <sha.h>
+#ifndef SHA1_DIGEST_SIZE
-+# define SHA1_DIGEST_SIZE 20
++#define SHA1_DIGEST_SIZE 20
+#endif
+
+#if 0
#include "sha1.h"
void SHA1_Transform(uint32_t state[5], const uint8_t buffer[64]);
-@@ -260,7 +267,6 @@ void SHA1_Final(SHA1_CTX* context, uint8
+@@ -258,7 +265,6 @@ SHA1_Final(SHA1_CTX *context, uint8_t di
/*************************************************************/
-#if 0
- int main(int argc, char** argv)
+ int
+ main(int argc, char **argv)
{
- int i, j;