aboutsummaryrefslogtreecommitdiff
path: root/graphics/jbig2dec
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-05-04 16:46:03 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-05-04 16:46:03 +0000
commit98f62693ce7f8a9b0a5d9113413257c8c21cf1e7 (patch)
tree6a1504be26548dc96b039ebfe0734849a1936688 /graphics/jbig2dec
parent518e721449ec9fe99c07d63bb4177146b43977b6 (diff)
downloadports-98f62693ce7f8a9b0a5d9113413257c8c21cf1e7.tar.gz
ports-98f62693ce7f8a9b0a5d9113413257c8c21cf1e7.zip
Notes
Diffstat (limited to 'graphics/jbig2dec')
-rw-r--r--graphics/jbig2dec/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/graphics/jbig2dec/Makefile b/graphics/jbig2dec/Makefile
index cc18b2ddd5d4..96c925fe0be0 100644
--- a/graphics/jbig2dec/Makefile
+++ b/graphics/jbig2dec/Makefile
@@ -5,14 +5,17 @@ PORTVERSION= 0.11
PORTREVISION= 1
CATEGORIES= graphics devel
MASTER_SITES= SF
-DISTFILES+= ${DISTNAME}${EXTRACT_SUFX}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Decoder implementation of the JBIG2 image compression format
-USE_XZ= yes:src
+LICENSE= GPLv3
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+USES= tar:xz
OPTIONS_DEFINE= PNG TESTS
OPTIONS_DEFAULT= PNG
@@ -21,8 +24,6 @@ TESTS_DESC= Download and use test-images for post-build testing
EXTRACT_AFTER_ARGS+= --exclude sha1.h --exclude 'getopt*'
-LICENSE= GPLv3
-
PNG_LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
PNG_CONFIGURE_ON= --with-libpng=${LOCALBASE}
PNG_CFLAGS= -I${LOCALBASE}/include/libpng15
@@ -32,13 +33,12 @@ PNG_CFLAGS= -I${LOCALBASE}/include/libpng15
.if ${PORT_OPTIONS:MTESTS}
MASTER_SITES+= http://jbig2dec.sourceforge.net/ubc/:tests
DISTFILES+= jb2streams.zip:tests
-EXTRACT_ONLY= ${DISTFILES:M*xz}
USE_PYTHON_BUILD=yes
KNOWN_BAD_JB2S= 042_11 042_13 042_14 042_24 042_25 amb_1 amb_2
post-extract:
- ${MKDIR} ${WRKDIR}/ubc
- ${TAR} -C ${WRKDIR}/ubc/ -xpf ${DISTDIR}/jb2streams.zip \
+ @${MKDIR} ${WRKDIR}/ubc
+ @${TAR} -C ${WRKDIR}/ubc/ -xpf ${DISTDIR}/jb2streams.zip \
${KNOWN_BAD_JB2S:S/$/.jb2/:S/^/--exclude /}
.else
EXTRA_PATCHES= ${FILESDIR}/simpler-test-patch
@@ -48,7 +48,7 @@ post-patch:
.if ${PORT_OPTIONS:MPNG}
@${REINPLACE_CMD} 's/png_check_sig/png_sig_cmp/g' ${WRKSRC}/configure
.endif
- ${REINPLACE_CMD} -E 's|SHA1_Final\( *([^,]+), *([^\)]+)\)|SHA1_Final(\2, \1)|' \
+ @${REINPLACE_CMD} -E 's|SHA1_Final\( *([^,]+), *([^\)]+)\)|SHA1_Final(\2, \1)|' \
${WRKSRC}/jbig2dec.c ${WRKSRC}/sha1.c
test check regression-test: