aboutsummaryrefslogtreecommitdiff
path: root/graphics/jbig2dec
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /graphics/jbig2dec
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
- update png to 1.5.10
Notes
Notes: svn path=/head/; revision=297915
Diffstat (limited to 'graphics/jbig2dec')
-rw-r--r--graphics/jbig2dec/Makefile4
-rw-r--r--graphics/jbig2dec/files/patch-jbig2_image_png.c10
2 files changed, 13 insertions, 1 deletions
diff --git a/graphics/jbig2dec/Makefile b/graphics/jbig2dec/Makefile
index e21364edbebc..6a7ca7b62dea 100644
--- a/graphics/jbig2dec/Makefile
+++ b/graphics/jbig2dec/Makefile
@@ -7,6 +7,7 @@
PORTNAME= jbig2dec
PORTVERSION= 0.11
+PORTREVISION= 1
CATEGORIES= graphics devel
MASTER_SITES= SF \
http://ghostscript.com/~giles/jbig2/jbig2dec/
@@ -36,8 +37,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPNG}
-LIB_DEPENDS+= png:${PORTSDIR}/graphics/png
+LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
CONFIGURE_ARGS+=--with-libpng=${LOCALBASE}
+CFLAGS+= -I${LOCALBASE}/include/libpng15
.endif
.if ${PORT_OPTIONS:MTESTS}
diff --git a/graphics/jbig2dec/files/patch-jbig2_image_png.c b/graphics/jbig2dec/files/patch-jbig2_image_png.c
new file mode 100644
index 000000000000..1aa509b0f27a
--- /dev/null
+++ b/graphics/jbig2dec/files/patch-jbig2_image_png.c
@@ -0,0 +1,10 @@
+--- jbig2_image_png.c.orig 2009-07-16 06:44:49.000000000 +0200
++++ jbig2_image_png.c 2012-04-24 21:54:55.000000000 +0200
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <png.h>
++#include <pngpriv.h>
+
+ #include "jbig2.h"
+ #include "jbig2_priv.h"