aboutsummaryrefslogtreecommitdiff
path: root/graphics/jbigkit/Makefile
diff options
context:
space:
mode:
authorFelippe de Meirelles Motta <lippe@FreeBSD.org>2008-05-16 14:14:05 +0000
committerFelippe de Meirelles Motta <lippe@FreeBSD.org>2008-05-16 14:14:05 +0000
commit2f44db99d9e682c856246e1764b922edf3f9027b (patch)
tree30146ac626780494407cf4663fb745e94c780c85 /graphics/jbigkit/Makefile
parentc55f81ac6136c66973df8f73afccc92fd93bf947 (diff)
- Uses "CC" to build in any case, regardless of what CC is set to.
- Bump PORTREVISION. PR: ports/122939 Submitted by: Frank Fenor <frank@fenor.de> Approved by: gabor (mentor), maintainer timeout (> 2 weeks)
Notes
Notes: svn path=/head/; revision=213145
Diffstat (limited to 'graphics/jbigkit/Makefile')
-rw-r--r--graphics/jbigkit/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/graphics/jbigkit/Makefile b/graphics/jbigkit/Makefile
index 62585ac54bf5..af7f0de6ac99 100644
--- a/graphics/jbigkit/Makefile
+++ b/graphics/jbigkit/Makefile
@@ -14,15 +14,17 @@ MAINTAINER= mi@aldan.algebra.com
COMMENT= Lossless compression for bi-level images such as scanned pages, faxes
WRKSRC= ${WRKDIR}/${PORTNAME}
-
+MAKE_ENV+= CC="${CC}"
USE_LDCONFIG= yes
MAN1= jbgtopbm.1 pbmtojbg.1
+DOCSDIR?= ${PREFIX}/share/doc/jbig
+
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/jbig
- ${INSTALL_DATA} ${WRKSRC}/libjbig/jbig.doc ${PREFIX}/share/doc/jbig
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/libjbig/jbig.doc ${DOCSDIR}
.endif
post-build test: