aboutsummaryrefslogtreecommitdiff
path: root/graphics/jgraph
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-02-19 09:49:30 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-02-19 09:49:30 +0000
commite8b13f25626fce88f0f7eab0f2adb48996c985c1 (patch)
treeafb1da94844ebb11eb4e3095032af770dbca2594 /graphics/jgraph
parent47a14a653a5a8fcb05308ef8b6e57a6a456d73f5 (diff)
downloadports-e8b13f25626fce88f0f7eab0f2adb48996c985c1.tar.gz
ports-e8b13f25626fce88f0f7eab0f2adb48996c985c1.zip
Notes
Diffstat (limited to 'graphics/jgraph')
-rw-r--r--graphics/jgraph/Makefile12
-rw-r--r--graphics/jgraph/files/patch-aa15
-rw-r--r--graphics/jgraph/pkg-plist52
3 files changed, 40 insertions, 39 deletions
diff --git a/graphics/jgraph/Makefile b/graphics/jgraph/Makefile
index 097d1c2e0ff5..334fac366ce0 100644
--- a/graphics/jgraph/Makefile
+++ b/graphics/jgraph/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: jgraph
-# Date created: 6 August 1999
-# Whom: wolman@cs.washington.edu
-#
+# Created by: wolman@cs.washington.edu
# $FreeBSD$
-#
PORTNAME= jgraph
PORTVERSION= 8.3
@@ -17,10 +13,14 @@ COMMENT= A program that generates postscript graphs
NO_LATEST_LINK= yes
EXTRACT_CMD= uncompress
EXTRACT_BEFORE_ARGS= -c
-EXTRACT_AFTER_ARGS= | sh
+EXTRACT_AFTER_ARGS= | ${SH}
NO_WRKSUBDIR= yes
MAN1= jgraph.1
MAKEFILE= makefile
+MAKE_ENV+= DATADIR=${DATADIR}
+
+CFLAGS+= -Wno-return-type
+
.include <bsd.port.mk>
diff --git a/graphics/jgraph/files/patch-aa b/graphics/jgraph/files/patch-aa
index 2246f0aac8af..d958f69de137 100644
--- a/graphics/jgraph/files/patch-aa
+++ b/graphics/jgraph/files/patch-aa
@@ -1,5 +1,5 @@
---- makefile.orig Fri Aug 6 15:11:40 1999
-+++ makefile Fri Aug 6 15:17:05 1999
+--- makefile.orig 2013-02-19 10:47:01.000000000 +0100
++++ makefile 2013-02-19 10:47:23.000000000 +0100
@@ -18,6 +18,34 @@
show.o \
token.o
@@ -35,7 +35,7 @@
EXAMPLES = \
acc.jps \
acc.eps \
-@@ -58,14 +86,20 @@
+@@ -58,15 +86,21 @@
.tex.dvi:
latex $*.tex
.c.o:
@@ -49,12 +49,13 @@
sin: sin.o
cc -o sin sin.o -lm
-+
+
+install: jgraph
+ install -c -m 555 -o bin -g bin jgraph ${PREFIX}/bin
+ install -c -m 444 -o bin -g bin jgraph.1 ${PREFIX}/man/man1
-+ -mkdir -p -m 755 ${PREFIX}/share/jgraph
-+ install -c -m 444 -o bin -g bin $(EXAMPLE_SRC) ${PREFIX}/share/jgraph
-
++ -mkdir -p -m 755 ${DATADIR}
++ install -c -m 444 -o bin -g bin $(EXAMPLE_SRC) ${DATADIR}
++
ad.jps: cube.eps disk.eps
bailey.jps: bailey.pts
+ ex2.jps: data.txt
diff --git a/graphics/jgraph/pkg-plist b/graphics/jgraph/pkg-plist
index 0c5f34dd3387..b878de0a36b7 100644
--- a/graphics/jgraph/pkg-plist
+++ b/graphics/jgraph/pkg-plist
@@ -1,27 +1,27 @@
bin/jgraph
-share/jgraph/acc.jgr
-share/jgraph/ad.jgr
-share/jgraph/alb.jgr
-share/jgraph/bailey.jgr
-share/jgraph/cube.jgr
-share/jgraph/data.txt
-share/jgraph/disk.jgr
-share/jgraph/ebars.jgr
-share/jgraph/ex1.jgr
-share/jgraph/ex2.jgr
-share/jgraph/g8.jgr
-share/jgraph/g8col.jgr
-share/jgraph/g9n10.jgr
-share/jgraph/gpaper.jgr
-share/jgraph/hypercube.jgr
-share/jgraph/mab2.jgr
-share/jgraph/mab2.times
-share/jgraph/nr.jgr
-share/jgraph/sin.pts
-share/jgraph/sin1.jgr
-share/jgraph/sin2.jgr
-share/jgraph/sin2.pts
-share/jgraph/sin3.jgr
-share/jgraph/sin3.pts
-share/jgraph/wortman.jgr
-@dirrm share/jgraph
+%%DATADIR%%/acc.jgr
+%%DATADIR%%/ad.jgr
+%%DATADIR%%/alb.jgr
+%%DATADIR%%/bailey.jgr
+%%DATADIR%%/cube.jgr
+%%DATADIR%%/data.txt
+%%DATADIR%%/disk.jgr
+%%DATADIR%%/ebars.jgr
+%%DATADIR%%/ex1.jgr
+%%DATADIR%%/ex2.jgr
+%%DATADIR%%/g8.jgr
+%%DATADIR%%/g8col.jgr
+%%DATADIR%%/g9n10.jgr
+%%DATADIR%%/gpaper.jgr
+%%DATADIR%%/hypercube.jgr
+%%DATADIR%%/mab2.jgr
+%%DATADIR%%/mab2.times
+%%DATADIR%%/nr.jgr
+%%DATADIR%%/sin.pts
+%%DATADIR%%/sin1.jgr
+%%DATADIR%%/sin2.jgr
+%%DATADIR%%/sin2.pts
+%%DATADIR%%/sin3.jgr
+%%DATADIR%%/sin3.pts
+%%DATADIR%%/wortman.jgr
+@dirrm %%DATADIR%%