aboutsummaryrefslogtreecommitdiff
path: root/graphics/jhead
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-02-12 17:16:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-02-12 17:16:17 +0000
commit350a49af33ed6fdb7e5e631d65e3445697b75607 (patch)
tree0ef5152f7541cdee83fd58fd33daf43c03a466cc /graphics/jhead
parent27ce45dd2836008c0c4cdf6c54fe0f941aa44fe3 (diff)
downloadports-350a49af33ed6fdb7e5e631d65e3445697b75607.tar.gz
ports-350a49af33ed6fdb7e5e631d65e3445697b75607.zip
Notes
Diffstat (limited to 'graphics/jhead')
-rw-r--r--graphics/jhead/Makefile3
-rw-r--r--graphics/jhead/distinfo6
-rw-r--r--graphics/jhead/files/patch-makernote.c39
3 files changed, 4 insertions, 44 deletions
diff --git a/graphics/jhead/Makefile b/graphics/jhead/Makefile
index dda37382d5e8..d2bbcffa6a34 100644
--- a/graphics/jhead/Makefile
+++ b/graphics/jhead/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= jhead
-PORTVERSION= 2.88
-PORTREVISION= 2
+PORTVERSION= 2.90
CATEGORIES= graphics
MASTER_SITES= http://www.sentex.net/~mwandel/jhead/ \
http://www.is-root.com/myports/
diff --git a/graphics/jhead/distinfo b/graphics/jhead/distinfo
index c77306fd9ac6..8f993ff274e6 100644
--- a/graphics/jhead/distinfo
+++ b/graphics/jhead/distinfo
@@ -1,3 +1,3 @@
-MD5 (jhead-2.88.tar.gz) = a2d4a3ede43a72ac7b97fd6b659c328c
-SHA256 (jhead-2.88.tar.gz) = 821f4717abd8462d113cb3f254e82562318e053036bc7e85ce68128d23c83b2e
-SIZE (jhead-2.88.tar.gz) = 63483
+MD5 (jhead-2.90.tar.gz) = 661effa9420bb92cb99ced697c5a177f
+SHA256 (jhead-2.90.tar.gz) = d18f862349f6d65560de12510f5cc9068b65dda7394b13fdeb6155a4933e0de8
+SIZE (jhead-2.90.tar.gz) = 64390
diff --git a/graphics/jhead/files/patch-makernote.c b/graphics/jhead/files/patch-makernote.c
deleted file mode 100644
index 79f778278428..000000000000
--- a/graphics/jhead/files/patch-makernote.c
+++ /dev/null
@@ -1,39 +0,0 @@
---- jhead-2.60.orig/makernote.c 2006-05-18 00:48:56.000000000 +0400
-+++ makernote.c 2006-12-18 09:57:32.000000000 +0300
-@@ -147,6 +147,27 @@
- }
- }
- }
-+//
-+//--------------------------------------------------------------------------
-+// Process exif format directory, as used by Nikon maker note
-+//--------------------------------------------------------------------------
-+void ProcessNikonMakerNoteDir(unsigned char *MakerNote)
-+{
-+ unsigned short iso;
-+
-+ if (DumpExifMap){
-+ printf("(Nikon makernote)\n");
-+ }
-+
-+ iso = Get16u(MakerNote + 20 + 12 + 10); // 20 bytes MakerNote ID ("Nikon" + padding), then TIFF header
-+
-+ if (ShowTags){
-+ printf("ISO derived from Nikon MakerNote: %d\n",iso);
-+ }
-+
-+ if (!ImageInfo.ISOequivalent)
-+ ImageInfo.ISOequivalent = iso;
-+}
-
- //--------------------------------------------------------------------------
- // Show generic maker note - just hex bytes.
-@@ -174,6 +195,8 @@
- {
- if (strstr(ImageInfo.CameraMake, "Canon")){
- ProcessCanonMakerNoteDir(ValuePtr, OffsetBase, ExifLength);
-+ }else if (strncmp((char *)ValuePtr, "Nikon", 5) == 0){
-+ ProcessNikonMakerNoteDir(ValuePtr);
- }else{
- if (ShowTags){
- ShowMakerNoteGeneric(ValuePtr, ByteCount);