aboutsummaryrefslogtreecommitdiff
path: root/graphics/jhead
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-21 23:12:31 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-11-21 23:12:31 +0000
commite2f62b48258248370a25e86dd67b81bcb3db1640 (patch)
tree7c5076ad0b2ffc3d6b63696ca78fb538df40425a /graphics/jhead
parent31aebd4eb2480cd6c339a990fbe99b972687100b (diff)
downloadports-e2f62b48258248370a25e86dd67b81bcb3db1640.tar.gz
ports-e2f62b48258248370a25e86dd67b81bcb3db1640.zip
Notes
Diffstat (limited to 'graphics/jhead')
-rw-r--r--graphics/jhead/Makefile24
1 files changed, 10 insertions, 14 deletions
diff --git a/graphics/jhead/Makefile b/graphics/jhead/Makefile
index 87df216c369e..df481f6014fa 100644
--- a/graphics/jhead/Makefile
+++ b/graphics/jhead/Makefile
@@ -4,33 +4,29 @@
PORTNAME= jhead
PORTVERSION= 2.97
CATEGORIES= graphics
-MASTER_SITES= http://www.sentex.net/~mwandel/jhead/
+MASTER_SITES= http://www.sentex.net/~mwandel/${PORTNAME}/ \
+ LOCAL/sunpoet
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= EXIF JPEG header manipulation tool
-RUN_DEPENDS= jpegtran:${PORTSDIR}/graphics/jpeg
+RUN_DEPENDS= ${LOCALBASE}/bin/jpegtran:${PORTSDIR}/graphics/jpeg
OPTIONS_DEFINE= DOCS
MAKEFILE= makefile
-MAN1= jhead.1
-PLIST_FILES= bin/jhead
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz
PORTDOCS= usage.html
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
post-patch:
- @${REINPLACE_CMD} -e '/^CFLAGS=/d' ${WRKSRC}/makefile
+ @${REINPLACE_CMD} -e '/^CFLAGS=/d' ${WRKSRC}/${MAKEFILE}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/jhead ${PREFIX}/bin/
- ${INSTALL_MAN} ${WRKSRC}/jhead.1 ${PREFIX}/man/man1/
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/usage.html ${DOCSDIR}/
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${PREFIX}/man/man1/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
.include <bsd.port.mk>