aboutsummaryrefslogtreecommitdiff
path: root/graphics/jpeg2ps-letter
diff options
context:
space:
mode:
authorLars Koeller <lkoeller@FreeBSD.org>2000-12-30 14:14:57 +0000
committerLars Koeller <lkoeller@FreeBSD.org>2000-12-30 14:14:57 +0000
commitdaa5c350c9c177dee9dd00fcb386380cf117cff8 (patch)
tree8b95c438672dbb8c5131254a6a4d9fb30965c5ba /graphics/jpeg2ps-letter
parent87ac79e889c94df1426e1b74cf5291b2b1eeb237 (diff)
downloadports-daa5c350c9c177dee9dd00fcb386380cf117cff8.tar.gz
ports-daa5c350c9c177dee9dd00fcb386380cf117cff8.zip
Notes
Diffstat (limited to 'graphics/jpeg2ps-letter')
-rw-r--r--graphics/jpeg2ps-letter/Makefile34
-rw-r--r--graphics/jpeg2ps-letter/distinfo1
-rw-r--r--graphics/jpeg2ps-letter/files/patch-aa23
-rw-r--r--graphics/jpeg2ps-letter/pkg-comment1
-rw-r--r--graphics/jpeg2ps-letter/pkg-descr10
-rw-r--r--graphics/jpeg2ps-letter/pkg-plist3
6 files changed, 72 insertions, 0 deletions
diff --git a/graphics/jpeg2ps-letter/Makefile b/graphics/jpeg2ps-letter/Makefile
new file mode 100644
index 000000000000..cdc39bdb54ed
--- /dev/null
+++ b/graphics/jpeg2ps-letter/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: jpeg2ps (letter)
+# Date created: 30 December 2000
+# Whom: Lars Koeller <Lars.Koeller@Uni-Bielefeld.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jpeg2ps
+PORTVERSION= 1.8
+CATEGORIES= graphics converters
+MASTER_SITES= http://www.pdflib.com/jpeg2ps/
+PKGNAMESUFFIX= -${PAPERSIZE}
+
+MAINTAINER= Lars.Koeller@Uni-Bielefeld.de
+
+PAPERSIZE?= letter
+
+INSTALL_TARGET=
+
+.if ${PAPERSIZE} == a4
+post-patch:
+ ${CP} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.input
+ ${SED} "s%CCFLAGS= -O -c%CCFLAGS= -O -c -DA4%" ${WRKSRC}/Makefile.input > ${WRKSRC}/Makefile
+ ${RM} -f ${WRKSRC}/Makefile.input
+.endif
+
+post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/jpeg2ps ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/jpeg2ps
+ ${INSTALL_DATA} ${WRKSRC}/jpeg2ps.txt ${PREFIX}/share/doc/jpeg2ps
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/jpeg2ps-letter/distinfo b/graphics/jpeg2ps-letter/distinfo
new file mode 100644
index 000000000000..f764dd76670e
--- /dev/null
+++ b/graphics/jpeg2ps-letter/distinfo
@@ -0,0 +1 @@
+MD5 (jpeg2ps-1.8.tar.gz) = 780c1cf2c3c7bdf464d23eb407f14702
diff --git a/graphics/jpeg2ps-letter/files/patch-aa b/graphics/jpeg2ps-letter/files/patch-aa
new file mode 100644
index 000000000000..b06fe98a51c6
--- /dev/null
+++ b/graphics/jpeg2ps-letter/files/patch-aa
@@ -0,0 +1,23 @@
+*** Makefile.org Sat Dec 30 14:30:00 2000
+--- Makefile Sat Dec 30 14:38:10 2000
+***************
+*** 15,23 ****
+ # The following was reported to work for emx/gcc 0.9c fix04 under OS/2:
+ # make -f Makefile "CCFLAGS=-c -DA4 -DDOS -O2" "LDFLAGS=-Zexe -s"
+
+! CC=gcc
+! CCFLAGS= -c -DA4
+! LD=gcc
+ LDFLAGS=
+ OBJ=o
+ EXE=
+--- 15,23 ----
+ # The following was reported to work for emx/gcc 0.9c fix04 under OS/2:
+ # make -f Makefile "CCFLAGS=-c -DA4 -DDOS -O2" "LDFLAGS=-Zexe -s"
+
+! CC=cc
+! CCFLAGS= -O -c
+! LD=cc
+ LDFLAGS=
+ OBJ=o
+ EXE=
diff --git a/graphics/jpeg2ps-letter/pkg-comment b/graphics/jpeg2ps-letter/pkg-comment
new file mode 100644
index 000000000000..8672bc00a345
--- /dev/null
+++ b/graphics/jpeg2ps-letter/pkg-comment
@@ -0,0 +1 @@
+Converter for JPEG compressed images to PostScript Level 2
diff --git a/graphics/jpeg2ps-letter/pkg-descr b/graphics/jpeg2ps-letter/pkg-descr
new file mode 100644
index 000000000000..941ee793dc10
--- /dev/null
+++ b/graphics/jpeg2ps-letter/pkg-descr
@@ -0,0 +1,10 @@
+Purpose of jpeg2ps
+==================
+jpeg2ps converts JPEG files to PostScript Level 2 or 3 EPS. In fact, jpeg2ps
+is not really a converter but a "wrapper": it reads the image parameters
+(width, height, number of color components) in a JPEG file, writes the
+according EPS header and then copies the compressed JPEG data to the output
+file. Decompression is done by the PostScript interpreter (only PostScript
+Level 2 and 3 interpreters support JPEG compression and decompression).
+If you have a slow communication channel and a fast printer, sending
+compressed image data is a big win.
diff --git a/graphics/jpeg2ps-letter/pkg-plist b/graphics/jpeg2ps-letter/pkg-plist
new file mode 100644
index 000000000000..d07edb74d5f0
--- /dev/null
+++ b/graphics/jpeg2ps-letter/pkg-plist
@@ -0,0 +1,3 @@
+bin/jpeg2ps
+share/doc/jpeg2ps/jpeg2ps.txt
+@dirrm share/doc/jpeg2ps