aboutsummaryrefslogtreecommitdiff
path: root/graphics/jpegpixi
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-20 04:47:47 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-20 04:47:47 +0000
commit1108f6f5e1c6b13086055b19f0c4a8ca6656cf19 (patch)
tree5a53a3085fae66be2429f82ba6e6d5bf5032e532 /graphics/jpegpixi
parentc31cbb35d3dd58e7ca556845453c957f80688411 (diff)
downloadports-1108f6f5e1c6b13086055b19f0c4a8ca6656cf19.tar.gz
ports-1108f6f5e1c6b13086055b19f0c4a8ca6656cf19.zip
Notes
Diffstat (limited to 'graphics/jpegpixi')
-rw-r--r--graphics/jpegpixi/Makefile22
-rw-r--r--graphics/jpegpixi/distinfo1
-rw-r--r--graphics/jpegpixi/pkg-comment1
-rw-r--r--graphics/jpegpixi/pkg-descr17
-rw-r--r--graphics/jpegpixi/pkg-plist1
5 files changed, 42 insertions, 0 deletions
diff --git a/graphics/jpegpixi/Makefile b/graphics/jpegpixi/Makefile
new file mode 100644
index 000000000000..9ff38106c53b
--- /dev/null
+++ b/graphics/jpegpixi/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: jpegpixi
+# Date created: 28 May 2002
+# Whom: verm@drunkmonk.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= jpegpixi
+PORTVERSION= 0.3
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= jpegpixi
+
+MAINTAINER= verm@drunkmonk.net
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-jpeglib-include=${LOCALBASE}/include \
+ --with-jpeglib-lib=${LOCALBASE}/lib
+
+.include <bsd.port.mk>
diff --git a/graphics/jpegpixi/distinfo b/graphics/jpegpixi/distinfo
new file mode 100644
index 000000000000..739cc7c77f58
--- /dev/null
+++ b/graphics/jpegpixi/distinfo
@@ -0,0 +1 @@
+MD5 (jpegpixi-0.3.tar.gz) = b6b95c916d81f865ec49e3292048bd6b
diff --git a/graphics/jpegpixi/pkg-comment b/graphics/jpegpixi/pkg-comment
new file mode 100644
index 000000000000..303911aa5500
--- /dev/null
+++ b/graphics/jpegpixi/pkg-comment
@@ -0,0 +1 @@
+Useful to correct images from digtal camera with CCD defects
diff --git a/graphics/jpegpixi/pkg-descr b/graphics/jpegpixi/pkg-descr
new file mode 100644
index 000000000000..d5d2a1d03409
--- /dev/null
+++ b/graphics/jpegpixi/pkg-descr
@@ -0,0 +1,17 @@
+"Jpegpixi" is short for "JPEG pixel interpolator". The intent of the
+program is to interpolate pixels in JFIF images (commonly refered to as
+"JPEG images"). This is useful to correct images from a digital camera
+with CCD defects. For example, if one pixel is always bright green, this
+pixel can be interpolated away with jpegpixi.
+
+Jpegpixi is unique in that it tries to preserve the quality of the JFIF
+image as much as possible. Usual graphics programs decode JFIF images
+when they are loaded, and re-encode them when they are saved, which
+results in an overall loss of quality. Jpegpixi, on the other hand, does
+not decode and re-encode the image, but manipulates the encoded image
+data (known as the "DCT coefficients"). Therefore, the blocks (typically
+8x8, 8x16, or 16x16 pixel areas) which contain the pixels to be
+interpolated are minimally disturbed, and other blocks remain
+pixel-by-pixel identical to the original image.
+
+WWW: http://jpegpixi.sourceforge.net/
diff --git a/graphics/jpegpixi/pkg-plist b/graphics/jpegpixi/pkg-plist
new file mode 100644
index 000000000000..f9b1c6a7ae37
--- /dev/null
+++ b/graphics/jpegpixi/pkg-plist
@@ -0,0 +1 @@
+bin/jpegpixi