aboutsummaryrefslogtreecommitdiff
path: root/graphics/jpgtn/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-01-11 23:47:14 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-01-11 23:47:14 +0000
commit3f38b08f94142fd3a5c7371ff1e7d47d7aaa2ccf (patch)
tree9532340b9fd3a1f31725bb3e16361ab541154116 /graphics/jpgtn/Makefile
parent1bc9c43ec86a94bc65fe195c74622470af5cc334 (diff)
downloadports-3f38b08f94142fd3a5c7371ff1e7d47d7aaa2ccf.tar.gz
ports-3f38b08f94142fd3a5c7371ff1e7d47d7aaa2ccf.zip
Notes
Diffstat (limited to 'graphics/jpgtn/Makefile')
-rw-r--r--graphics/jpgtn/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/graphics/jpgtn/Makefile b/graphics/jpgtn/Makefile
index 1a4f55af38d2..2c282c7be546 100644
--- a/graphics/jpgtn/Makefile
+++ b/graphics/jpgtn/Makefile
@@ -7,6 +7,7 @@
PORTNAME= jpgtn
PORTVERSION= 1.04
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= apps/graphics/misc
@@ -17,5 +18,30 @@ COMMENT= Creates thumbnails of JPEG images
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
MAN1= jpgtn.1
+USE_REINPLACE= yes
+
+pre-everything::
+ @${ECHO_MSG} "===>"
+ @${ECHO_MSG} "===> You can control program functionality by defining the following variables:"
+ @${ECHO_MSG} "===>"
+.if !defined(WITH_MAXSIZE)
+ @${ECHO_MSG} "===> Define WITH_MAXSIZE to set the maximum allowable thumbnail size"
+.endif
+.if !defined(WITH_MINSIZE)
+ @${ECHO_MSG} "===> Define WITH_MINSIZE to set the minimum allowable thumbnail size"
+.endif
+ @${ECHO_MSG} "===>"
+
+post-patch:
+.if defined(WITH_MAXSIZE)
+ @${ECHO_MSG} "Setting MAXSIZE to ${WITH_MAXSIZE}"
+ @${REINPLACE_CMD} "s/define MAXSIZE[[:blank:]]*256/define MAXSIZE ${WITH_MAXSIZE}/" ${WRKSRC}/jpgtn.h
+ @${REINPLACE_CMD} "s/allowable range (24-256)/allowable range (24-${WITH_MAXSIZE})/" ${WRKSRC}/jpgtn.1
+.endif
+.if defined(WITH_MINSIZE)
+ @${ECHO_MSG} "Setting MINSIZE to ${WITH_MINSIZE}"
+ @${REINPLACE_CMD} "s/define MINSIZE[[:blank:]]*24/define MINSIZE ${WITH_MINSIZE}/" ${WRKSRC}/jpgtn.h
+ @${REINPLACE_CMD} "s/allowable range (24-)/allowable range (${WITH_MINSIZE}-/" ${WRKSRC}/jpgtn.1
+.endif
.include <bsd.port.mk>