aboutsummaryrefslogtreecommitdiff
path: root/graphics/k3d/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-06-11 07:10:39 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-06-11 07:10:39 +0000
commit8a4881c4d880f88758f5b517354f1912a161d4f1 (patch)
treee9a9bbb8758d8bb615f7c7bbc50f45caca84dd82 /graphics/k3d/Makefile
parenta93cd68a7bfde737312a51859f938652dfd951c2 (diff)
downloadports-8a4881c4d880f88758f5b517354f1912a161d4f1.tar.gz
ports-8a4881c4d880f88758f5b517354f1912a161d4f1.zip
Notes
Diffstat (limited to 'graphics/k3d/Makefile')
-rw-r--r--graphics/k3d/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/graphics/k3d/Makefile b/graphics/k3d/Makefile
new file mode 100644
index 000000000000..c10646f75c52
--- /dev/null
+++ b/graphics/k3d/Makefile
@@ -0,0 +1,54 @@
+# ex:ts=8
+# Ports collection makefile for: k3d
+# Date created: Jun 9, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= k3d
+PORTVERSION= 0.4.1.0
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A free 3D modeling, animation, and rendering system
+
+BUILD_DEPENDS= ${X11BASE}/lib/libplibul.a:${PORTSDIR}/x11-toolkits/plib
+# ${X11BASE}/lib/libode.a:${PORTSDIR}/devel/ode
+LIB_DEPENDS= sigc.1:${PORTSDIR}/devel/libsigc++ \
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ Magick++.6:${PORTSDIR}/graphics/ImageMagick \
+ netpbm.1:${PORTSDIR}/graphics/netpbm \
+ Half.2:${PORTSDIR}/graphics/OpenEXR \
+ gts.2:${PORTSDIR}/graphics/gts
+
+USE_GL= yes
+USE_GNOME= gnometarget gtk12 libxslt
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= \
+ CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+CONFIGURE_ARGS= --without-docbook --without-graphviz \
+ --with-openexr --with-plib --with-gts
+# --with-ode
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+MAN1= k3d.1
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.for dir in ${PREFIX}/include/k3d ${PREFIX}/share/k3d ${PREFIX}/lib/k3d
+ @${FIND} ${dir} ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${dir} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+.endfor
+
+.include <bsd.port.post.mk>