aboutsummaryrefslogtreecommitdiff
path: root/graphics/k3d
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-06-11 07:10:39 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-06-11 07:10:39 +0000
commit8a4881c4d880f88758f5b517354f1912a161d4f1 (patch)
treee9a9bbb8758d8bb615f7c7bbc50f45caca84dd82 /graphics/k3d
parenta93cd68a7bfde737312a51859f938652dfd951c2 (diff)
downloadports-8a4881c4d880f88758f5b517354f1912a161d4f1.tar.gz
ports-8a4881c4d880f88758f5b517354f1912a161d4f1.zip
Notes
Diffstat (limited to 'graphics/k3d')
-rw-r--r--graphics/k3d/Makefile54
-rw-r--r--graphics/k3d/distinfo2
-rw-r--r--graphics/k3d/files/patch-ltmain.sh15
-rw-r--r--graphics/k3d/pkg-descr12
-rw-r--r--graphics/k3d/pkg-plist25
5 files changed, 108 insertions, 0 deletions
diff --git a/graphics/k3d/Makefile b/graphics/k3d/Makefile
new file mode 100644
index 000000000000..c10646f75c52
--- /dev/null
+++ b/graphics/k3d/Makefile
@@ -0,0 +1,54 @@
+# ex:ts=8
+# Ports collection makefile for: k3d
+# Date created: Jun 9, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= k3d
+PORTVERSION= 0.4.1.0
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A free 3D modeling, animation, and rendering system
+
+BUILD_DEPENDS= ${X11BASE}/lib/libplibul.a:${PORTSDIR}/x11-toolkits/plib
+# ${X11BASE}/lib/libode.a:${PORTSDIR}/devel/ode
+LIB_DEPENDS= sigc.1:${PORTSDIR}/devel/libsigc++ \
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ Magick++.6:${PORTSDIR}/graphics/ImageMagick \
+ netpbm.1:${PORTSDIR}/graphics/netpbm \
+ Half.2:${PORTSDIR}/graphics/OpenEXR \
+ gts.2:${PORTSDIR}/graphics/gts
+
+USE_GL= yes
+USE_GNOME= gnometarget gtk12 libxslt
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= \
+ CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+CONFIGURE_ARGS= --without-docbook --without-graphviz \
+ --with-openexr --with-plib --with-gts
+# --with-ode
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+MAN1= k3d.1
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.for dir in ${PREFIX}/include/k3d ${PREFIX}/share/k3d ${PREFIX}/lib/k3d
+ @${FIND} ${dir} ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${dir} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/graphics/k3d/distinfo b/graphics/k3d/distinfo
new file mode 100644
index 000000000000..3e1a71df2e8e
--- /dev/null
+++ b/graphics/k3d/distinfo
@@ -0,0 +1,2 @@
+MD5 (k3d-0.4.1.0.tgz) = 2c42382ade409af4ced7f42f4b471bb1
+SIZE (k3d-0.4.1.0.tgz) = 5399787
diff --git a/graphics/k3d/files/patch-ltmain.sh b/graphics/k3d/files/patch-ltmain.sh
new file mode 100644
index 000000000000..dac9e30fb3f1
--- /dev/null
+++ b/graphics/k3d/files/patch-ltmain.sh
@@ -0,0 +1,15 @@
+--- ltmain.sh.orig Thu Jun 10 09:49:38 2004
++++ ltmain.sh Thu Jun 10 09:49:53 2004
+@@ -4383,10 +4383,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/graphics/k3d/pkg-descr b/graphics/k3d/pkg-descr
new file mode 100644
index 000000000000..c31a43032439
--- /dev/null
+++ b/graphics/k3d/pkg-descr
@@ -0,0 +1,12 @@
+K-3D is the free-as-in-freedom 3D modeling, animation, and rendering system
+for GNU/Linux, Posix, and Win32 operating systems. K-3D features a robust,
+object-oriented plugin architecture, designed to scale to the needs of
+professional artists, and is designed from-the-ground-up to generate
+motion-picture-quality animation using RenderMan-compliant render engines.
+We strongly recommend the Aqsis render engine for use with K-3D.
+
+K-3D allows you to create and edit documents in multiple realtime OpenGL
+solid, shaded, texture-mapped views. You can even model, animate, and interact
+with animations while they play back for maximum productivity!
+
+WWW: http://k3d.sourceforge.net/
diff --git a/graphics/k3d/pkg-plist b/graphics/k3d/pkg-plist
new file mode 100644
index 000000000000..c1c6771547c9
--- /dev/null
+++ b/graphics/k3d/pkg-plist
@@ -0,0 +1,25 @@
+bin/gpp
+bin/k3d
+bin/k3d-bin
+bin/k3d-config
+bin/k3d-makempeg
+bin/k3d-renderframe
+bin/k3d-renderjob
+bin/k3d-uuidgen
+bin/sl2xml
+lib/libHapy.so
+lib/libHapy.so.0
+lib/libk3dembed.so
+lib/libk3dembed.so.0
+lib/libk3dsdk.so
+lib/libk3dsdk.so.0
+lib/libk3dui.so
+lib/libk3dui.so.0
+lib/libsdpgl.so
+lib/libsdpgl.so.0
+lib/libsdpgtk.so
+lib/libsdpgtk.so.0
+lib/libsdpsl.so
+lib/libsdpsl.so.0
+lib/libsdpxml.so
+lib/libsdpxml.so.0