aboutsummaryrefslogtreecommitdiff
path: root/graphics/kdegraphics4-mobipocket/Makefile
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-10-17 00:03:42 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-10-17 00:03:42 +0000
commita2d3b5a4bc5047210b788a128596ec34749ffa11 (patch)
treec3c20b47c3435ddcaf02b8570db6aab5b70011af /graphics/kdegraphics4-mobipocket/Makefile
parentda6ade2349d0bdc372133d4d97bc6988aee94238 (diff)
The KDE/FreeBSD team is pleased to announce KDE Software Compilation
4.7.2. The official release notes can be found at: http://kde.org/announcements/announce-4.7.2.php This release ships with many improvements. Read more about them here: http://FreeBSD.kde.org/news.php#itemKDESC472availableinports We'd like to say thanks to all testers and contributors, especially to lwhsu@ for his effort on hosting our test packages. PR: 156293 [1] 159219 [2] 160164 [3] Submitted by: Oleg Sidorkin <osidorkin@gmail.com> [1] Alvaro Castillo <gobledb@gmail.com> [2] dkeav04@gmail.com [3] Tested by: exp-run via pav
Notes
Notes: svn path=/head/; revision=283641
Diffstat (limited to 'graphics/kdegraphics4-mobipocket/Makefile')
-rw-r--r--graphics/kdegraphics4-mobipocket/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/graphics/kdegraphics4-mobipocket/Makefile b/graphics/kdegraphics4-mobipocket/Makefile
new file mode 100644
index 000000000000..78149215f349
--- /dev/null
+++ b/graphics/kdegraphics4-mobipocket/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: kdegraphics-mobipocket
+# Date created: 5 September 2011
+# Whom: Alberto Villa <avilla@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mobipocket
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= graphics kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+PKGNAMEPREFIX= kdegraphics-
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Mobipocket plugins for Strigi indexing, Okular and thumbnails
+
+LIB_DEPENDS= searchclient.0:${PORTSDIR}/deskutils/strigi \
+ okularcore.1:${PORTSDIR}/graphics/okular
+
+CONFLICTS= kdegraphics-4.[0-6].*
+
+USE_KDE4= kdehier kdelibs kdeprefix automoc4
+KDE4_BUILDENV= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui qmake_build moc_build uic_build rcc_build
+USE_BZIP2= yes
+MAKE_JOBS_SAFE= yes
+
+.include <bsd.port.mk>