aboutsummaryrefslogtreecommitdiff
path: root/graphics/kdegraphics4/Makefile
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2001-08-19 00:04:22 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2001-08-19 00:04:22 +0000
commit158547a0682ac5f7af805736bdc4de642d124dd6 (patch)
tree77fc2ae034458269deeb099147d0f606bdb133b1 /graphics/kdegraphics4/Makefile
parente2b6e5584d5b4be1df9a150afa03256c5d422f15 (diff)
downloadports-158547a0682ac5f7af805736bdc4de642d124dd6.tar.gz
ports-158547a0682ac5f7af805736bdc4de642d124dd6.zip
Notes
Diffstat (limited to 'graphics/kdegraphics4/Makefile')
-rw-r--r--graphics/kdegraphics4/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/graphics/kdegraphics4/Makefile b/graphics/kdegraphics4/Makefile
index 7e45e7e60be7..deb7acfdb602 100644
--- a/graphics/kdegraphics4/Makefile
+++ b/graphics/kdegraphics4/Makefile
@@ -16,11 +16,24 @@ MAINTAINER= will@FreeBSD.org
BUILD_DEPENDS= dvips:${PORTSDIR}/print/teTeX
RUN_DEPENDS= dvips:${PORTSDIR}/print/teTeX
+# temporarily disable kamera, it requires gphoto2
+PLIST_SUB+= KAMERA:="@comment "
+
+.if defined(WITH_SANE)
+LIB_DEPENDS= sane.1:${PORTSDIR}/graphics/sane-backends
+PLIST_SUB+= SANE:=""
+.else
+PLIST_SUB+= SANE:="@comment "
+pre-everything::
+ @${ECHO_MSG} "===> If you want to compile this port with scanner support, use \"make WITH_SANE=yes\""
+.endif
+
USE_KDELIBS_VER=2
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
+CONFIGURE_ARGS+=--without-kamera
pre-configure:
${PERL} -pi -e "s@libkscan_la_LIBADD =@libkscan_la_LIBADD= -lintl@g" ${WRKSRC}/libkscan/Makefile.in