aboutsummaryrefslogtreecommitdiff
path: root/graphics/kdiagram
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-06-17 13:44:51 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-06-17 13:44:51 +0000
commita842d469243bc265e68c14c19cdf2648a2aaac95 (patch)
treed722a6757db1136f92f82f7b7d4e4d968a16b536 /graphics/kdiagram
parent4f68d0d44822e3c276d674d30164f29889b27351 (diff)
downloadports-a842d469243bc265e68c14c19cdf2648a2aaac95.tar.gz
ports-a842d469243bc265e68c14c19cdf2648a2aaac95.zip
Notes
Diffstat (limited to 'graphics/kdiagram')
-rw-r--r--graphics/kdiagram/Makefile24
-rw-r--r--graphics/kdiagram/distinfo3
-rw-r--r--graphics/kdiagram/pkg-descr3
-rw-r--r--graphics/kdiagram/pkg-plist245
4 files changed, 275 insertions, 0 deletions
diff --git a/graphics/kdiagram/Makefile b/graphics/kdiagram/Makefile
new file mode 100644
index 000000000000..30e2946e6d18
--- /dev/null
+++ b/graphics/kdiagram/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= kdiagram
+PORTVERSION= 2.6.0
+CATEGORIES= graphics kde
+MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}/src
+PKGNAMESUFFIX= -kf5
+DIST_SUBDIR= KDE/${PORTNAME}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Library to create business diagrams
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE.GPL.txt
+
+USES= cmake:outsource kde:5 tar:xz
+USE_KDE= ecm
+USE_QT5= core gui linguisttools printsupport sql svg widgets \
+ buildtools_build qmake_build
+
+PLIST_SUB= SHLIB_VER="${PORTVERSION}" \
+ SHLIB_SHVER="${PORTVERSION:R:R}"
+
+.include <bsd.port.mk>
diff --git a/graphics/kdiagram/distinfo b/graphics/kdiagram/distinfo
new file mode 100644
index 000000000000..6aa99808c7b6
--- /dev/null
+++ b/graphics/kdiagram/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1478527331
+SHA256 (KDE/kdiagram/kdiagram-2.6.0.tar.xz) = 02788dad7e15c64b74a2d1073c5910469ab4cf46ba905030c1713dce45981882
+SIZE (KDE/kdiagram/kdiagram-2.6.0.tar.xz) = 683792
diff --git a/graphics/kdiagram/pkg-descr b/graphics/kdiagram/pkg-descr
new file mode 100644
index 000000000000..32a132a24cda
--- /dev/null
+++ b/graphics/kdiagram/pkg-descr
@@ -0,0 +1,3 @@
+Powerful libraries (KChart, KGantt) for creating business diagrams.
+
+WWW: http://projects.kde.org/kdiagram
diff --git a/graphics/kdiagram/pkg-plist b/graphics/kdiagram/pkg-plist
new file mode 100644
index 000000000000..2abdf31995aa
--- /dev/null
+++ b/graphics/kdiagram/pkg-plist
@@ -0,0 +1,245 @@
+include/KChart/KChart
+include/KChart/KChartAbstractArea
+include/KChart/KChartAbstractArea.h
+include/KChart/KChartAbstractAreaBase
+include/KChart/KChartAbstractAreaBase.h
+include/KChart/KChartAbstractAreaWidget
+include/KChart/KChartAbstractAreaWidget.h
+include/KChart/KChartAbstractAxis
+include/KChart/KChartAbstractAxis.h
+include/KChart/KChartAbstractCartesianDiagram
+include/KChart/KChartAbstractCartesianDiagram.h
+include/KChart/KChartAbstractCoordinatePlane
+include/KChart/KChartAbstractCoordinatePlane.h
+include/KChart/KChartAbstractDiagram
+include/KChart/KChartAbstractDiagram.h
+include/KChart/KChartAbstractPieDiagram
+include/KChart/KChartAbstractPieDiagram.h
+include/KChart/KChartAbstractPolarDiagram
+include/KChart/KChartAbstractPolarDiagram.h
+include/KChart/KChartAbstractProxyModel
+include/KChart/KChartAbstractProxyModel.h
+include/KChart/KChartAbstractTernaryDiagram
+include/KChart/KChartAbstractTernaryDiagram.h
+include/KChart/KChartAbstractThreeDAttributes
+include/KChart/KChartAbstractThreeDAttributes.h
+include/KChart/KChartAttributesModel
+include/KChart/KChartAttributesModel.h
+include/KChart/KChartBackgroundAttributes
+include/KChart/KChartBackgroundAttributes.h
+include/KChart/KChartBarAttributes
+include/KChart/KChartBarAttributes.h
+include/KChart/KChartBarDiagram
+include/KChart/KChartBarDiagram.h
+include/KChart/KChartCartesianAxis
+include/KChart/KChartCartesianAxis.h
+include/KChart/KChartCartesianCoordinatePlane
+include/KChart/KChartCartesianCoordinatePlane.h
+include/KChart/KChartChart
+include/KChart/KChartChart.h
+include/KChart/KChartDataValueAttributes
+include/KChart/KChartDataValueAttributes.h
+include/KChart/KChartDatasetProxyModel
+include/KChart/KChartDatasetProxyModel.h
+include/KChart/KChartDatasetSelector
+include/KChart/KChartDatasetSelector.h
+include/KChart/KChartDiagramObserver
+include/KChart/KChartDiagramObserver.h
+include/KChart/KChartEnums
+include/KChart/KChartEnums.h
+include/KChart/KChartFrameAttributes
+include/KChart/KChartFrameAttributes.h
+include/KChart/KChartGlobal
+include/KChart/KChartGlobal.h
+include/KChart/KChartGridAttributes
+include/KChart/KChartGridAttributes.h
+include/KChart/KChartHeaderFooter
+include/KChart/KChartHeaderFooter.h
+include/KChart/KChartLayoutItems
+include/KChart/KChartLayoutItems.h
+include/KChart/KChartLegend
+include/KChart/KChartLegend.h
+include/KChart/KChartLeveyJenningsAxis
+include/KChart/KChartLeveyJenningsAxis.h
+include/KChart/KChartLeveyJenningsCoordinatePlane
+include/KChart/KChartLeveyJenningsCoordinatePlane.h
+include/KChart/KChartLeveyJenningsDiagram
+include/KChart/KChartLeveyJenningsDiagram.h
+include/KChart/KChartLeveyJenningsGridAttributes
+include/KChart/KChartLeveyJenningsGridAttributes.h
+include/KChart/KChartLineAttributes
+include/KChart/KChartLineAttributes.h
+include/KChart/KChartLineDiagram
+include/KChart/KChartLineDiagram.h
+include/KChart/KChartMarkerAttributes
+include/KChart/KChartMarkerAttributes.h
+include/KChart/KChartMeasure
+include/KChart/KChartMeasure.h
+include/KChart/KChartPaintContext
+include/KChart/KChartPaintContext.h
+include/KChart/KChartPalette
+include/KChart/KChartPalette.h
+include/KChart/KChartPieAttributes
+include/KChart/KChartPieAttributes.h
+include/KChart/KChartPieDiagram
+include/KChart/KChartPieDiagram.h
+include/KChart/KChartPlotter
+include/KChart/KChartPlotter.h
+include/KChart/KChartPolarCoordinatePlane
+include/KChart/KChartPolarCoordinatePlane.h
+include/KChart/KChartPolarDiagram
+include/KChart/KChartPolarDiagram.h
+include/KChart/KChartPosition
+include/KChart/KChartPosition.h
+include/KChart/KChartRadarCoordinatePlane
+include/KChart/KChartRadarCoordinatePlane.h
+include/KChart/KChartRadarDiagram
+include/KChart/KChartRadarDiagram.h
+include/KChart/KChartRelativePosition
+include/KChart/KChartRelativePosition.h
+include/KChart/KChartRingDiagram
+include/KChart/KChartRingDiagram.h
+include/KChart/KChartRulerAttributes
+include/KChart/KChartRulerAttributes.h
+include/KChart/KChartStockBarAttributes
+include/KChart/KChartStockBarAttributes.h
+include/KChart/KChartStockDiagram
+include/KChart/KChartStockDiagram.h
+include/KChart/KChartTernaryAxis
+include/KChart/KChartTernaryAxis.h
+include/KChart/KChartTernaryCoordinatePlane
+include/KChart/KChartTernaryCoordinatePlane.h
+include/KChart/KChartTernaryLineDiagram
+include/KChart/KChartTernaryLineDiagram.h
+include/KChart/KChartTernaryPointDiagram
+include/KChart/KChartTernaryPointDiagram.h
+include/KChart/KChartTextArea
+include/KChart/KChartTextArea.h
+include/KChart/KChartTextAttributes
+include/KChart/KChartTextAttributes.h
+include/KChart/KChartThreeDBarAttributes
+include/KChart/KChartThreeDBarAttributes.h
+include/KChart/KChartThreeDLineAttributes
+include/KChart/KChartThreeDLineAttributes.h
+include/KChart/KChartThreeDPieAttributes
+include/KChart/KChartThreeDPieAttributes.h
+include/KChart/KChartValueTrackerAttributes
+include/KChart/KChartValueTrackerAttributes.h
+include/KChart/KChartWidget
+include/KChart/KChartWidget.h
+include/KChart/kchart_export.h
+include/KGantt/KGanttAbstractGrid
+include/KGantt/KGanttAbstractRowController
+include/KGantt/KGanttConstraint
+include/KGantt/KGanttConstraintGraphicsItem
+include/KGantt/KGanttConstraintModel
+include/KGantt/KGanttConstraintProxy
+include/KGantt/KGanttDateTimeGrid
+include/KGantt/KGanttForwardingProxyModel
+include/KGantt/KGanttGlobal
+include/KGantt/KGanttGraphicsItem
+include/KGantt/KGanttGraphicsScene
+include/KGantt/KGanttGraphicsView
+include/KGantt/KGanttItemDelegate
+include/KGantt/KGanttLegend
+include/KGantt/KGanttListViewRowController
+include/KGantt/KGanttProxyModel
+include/KGantt/KGanttStyleOptionGanttItem
+include/KGantt/KGanttSummaryHandlingProxyModel
+include/KGantt/KGanttTreeViewRowController
+include/KGantt/KGanttView
+include/KGantt/kgantt_export.h
+include/KGantt/kganttabstractgrid.h
+include/KGantt/kganttabstractrowcontroller.h
+include/KGantt/kganttconstraint.h
+include/KGantt/kganttconstraintgraphicsitem.h
+include/KGantt/kganttconstraintmodel.h
+include/KGantt/kganttconstraintproxy.h
+include/KGantt/kganttdatetimegrid.h
+include/KGantt/kganttforwardingproxymodel.h
+include/KGantt/kganttglobal.h
+include/KGantt/kganttgraphicsitem.h
+include/KGantt/kganttgraphicsscene.h
+include/KGantt/kganttgraphicsview.h
+include/KGantt/kganttitemdelegate.h
+include/KGantt/kganttlegend.h
+include/KGantt/kganttlistviewrowcontroller.h
+include/KGantt/kganttproxymodel.h
+include/KGantt/kganttstyleoptionganttitem.h
+include/KGantt/kganttsummaryhandlingproxymodel.h
+include/KGantt/kgantttreeviewrowcontroller.h
+include/KGantt/kganttview.h
+include/kchart_version.h
+include/kgantt_version.h
+lib/cmake/KChart/KChartConfig.cmake
+lib/cmake/KChart/KChartConfigVersion.cmake
+lib/cmake/KChart/KChartTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/KChart/KChartTargets.cmake
+lib/cmake/KGantt/KGanttConfig.cmake
+lib/cmake/KGantt/KGanttConfigVersion.cmake
+lib/cmake/KGantt/KGanttTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/KGantt/KGanttTargets.cmake
+lib/libKChart.so
+lib/libKChart.so.%%SHLIB_SHVER%%
+lib/libKChart.so.%%SHLIB_VER%%
+lib/libKGantt.so
+lib/libKGantt.so.%%SHLIB_SHVER%%
+lib/libKGantt.so.%%SHLIB_VER%%
+%%QT_MKSPECDIR%%/modules/qt_KChart.pri
+%%QT_MKSPECDIR%%/modules/qt_KGantt.pri
+share/locale/ar/LC_MESSAGES/kchart_qt.qm
+share/locale/ar/LC_MESSAGES/kgantt_qt.qm
+share/locale/ast/LC_MESSAGES/kchart_qt.qm
+share/locale/ast/LC_MESSAGES/kgantt_qt.qm
+share/locale/bg/LC_MESSAGES/kgantt_qt.qm
+share/locale/bs/LC_MESSAGES/kchart_qt.qm
+share/locale/bs/LC_MESSAGES/kgantt_qt.qm
+share/locale/ca/LC_MESSAGES/kchart_qt.qm
+share/locale/ca/LC_MESSAGES/kgantt_qt.qm
+share/locale/ca@valencia/LC_MESSAGES/kchart_qt.qm
+share/locale/ca@valencia/LC_MESSAGES/kgantt_qt.qm
+share/locale/cs/LC_MESSAGES/kchart_qt.qm
+share/locale/cs/LC_MESSAGES/kgantt_qt.qm
+share/locale/de/LC_MESSAGES/kchart_qt.qm
+share/locale/de/LC_MESSAGES/kgantt_qt.qm
+share/locale/el/LC_MESSAGES/kchart_qt.qm
+share/locale/el/LC_MESSAGES/kgantt_qt.qm
+share/locale/en_GB/LC_MESSAGES/kchart_qt.qm
+share/locale/en_GB/LC_MESSAGES/kgantt_qt.qm
+share/locale/es/LC_MESSAGES/kchart_qt.qm
+share/locale/es/LC_MESSAGES/kgantt_qt.qm
+share/locale/fi/LC_MESSAGES/kchart_qt.qm
+share/locale/fi/LC_MESSAGES/kgantt_qt.qm
+share/locale/gl/LC_MESSAGES/kchart_qt.qm
+share/locale/gl/LC_MESSAGES/kgantt_qt.qm
+share/locale/ja/LC_MESSAGES/kchart_qt.qm
+share/locale/ja/LC_MESSAGES/kgantt_qt.qm
+share/locale/ko/LC_MESSAGES/kchart_qt.qm
+share/locale/ko/LC_MESSAGES/kgantt_qt.qm
+share/locale/lt/LC_MESSAGES/kchart_qt.qm
+share/locale/lt/LC_MESSAGES/kgantt_qt.qm
+share/locale/nl/LC_MESSAGES/kchart_qt.qm
+share/locale/nl/LC_MESSAGES/kgantt_qt.qm
+share/locale/nn/LC_MESSAGES/kchart_qt.qm
+share/locale/nn/LC_MESSAGES/kgantt_qt.qm
+share/locale/pl/LC_MESSAGES/kchart_qt.qm
+share/locale/pl/LC_MESSAGES/kgantt_qt.qm
+share/locale/pt/LC_MESSAGES/kchart_qt.qm
+share/locale/pt/LC_MESSAGES/kgantt_qt.qm
+share/locale/pt_BR/LC_MESSAGES/kchart_qt.qm
+share/locale/pt_BR/LC_MESSAGES/kgantt_qt.qm
+share/locale/ro/LC_MESSAGES/kchart_qt.qm
+share/locale/ru/LC_MESSAGES/kchart_qt.qm
+share/locale/ru/LC_MESSAGES/kgantt_qt.qm
+share/locale/sk/LC_MESSAGES/kchart_qt.qm
+share/locale/sk/LC_MESSAGES/kgantt_qt.qm
+share/locale/sv/LC_MESSAGES/kchart_qt.qm
+share/locale/sv/LC_MESSAGES/kgantt_qt.qm
+share/locale/tr/LC_MESSAGES/kchart_qt.qm
+share/locale/tr/LC_MESSAGES/kgantt_qt.qm
+share/locale/uk/LC_MESSAGES/kchart_qt.qm
+share/locale/uk/LC_MESSAGES/kgantt_qt.qm
+share/locale/zh_CN/LC_MESSAGES/kchart_qt.qm
+share/locale/zh_CN/LC_MESSAGES/kgantt_qt.qm
+share/locale/zh_TW/LC_MESSAGES/kchart_qt.qm
+share/locale/zh_TW/LC_MESSAGES/kgantt_qt.qm