aboutsummaryrefslogtreecommitdiff
path: root/graphics/kipi-plugins-kde4
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-03-28 09:05:39 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-03-28 09:05:39 +0000
commit069eb5d63d5e4b6bf5f627b99250eefcee25b759 (patch)
treef856b089e9a3ec600c7c2951efca3b6237d9f466 /graphics/kipi-plugins-kde4
parentb3a7fcbada27616a9478958476078073a9e20e71 (diff)
downloadports-069eb5d63d5e4b6bf5f627b99250eefcee25b759.tar.gz
ports-069eb5d63d5e4b6bf5f627b99250eefcee25b759.zip
Notes
Diffstat (limited to 'graphics/kipi-plugins-kde4')
-rw-r--r--graphics/kipi-plugins-kde4/files/extrapatch-CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/graphics/kipi-plugins-kde4/files/extrapatch-CMakeLists.txt b/graphics/kipi-plugins-kde4/files/extrapatch-CMakeLists.txt
index 552aa033329b..aa02b2154659 100644
--- a/graphics/kipi-plugins-kde4/files/extrapatch-CMakeLists.txt
+++ b/graphics/kipi-plugins-kde4/files/extrapatch-CMakeLists.txt
@@ -1,10 +1,15 @@
+The first hunk looks for libkipiplugins via CMake, as we split every kipi
+plugin as well as the common code into separate ports. Not using CMake results
+in "kipiplugins" in a target_link_libraries() call becoming a literal
+-lkipiplugins being passed to the linker instead of /path/to/libkipiplugin.so.
--- ./CMakeLists.txt.orig 2015-02-25 22:15:14.659030000 +0100
+++ ./CMakeLists.txt 2015-02-25 22:17:07.071209000 +0100
-@@ -356,7 +356,6 @@
+@@ -391,7 +391,7 @@ if(KIPI_FOUND)
# Plugins which will be always compiled
- add_subdirectory(common)
++ find_library(LIBKIPIPLUGINS_LIBRARIES kipiplugins)
add_subdirectory(timeadjust)
add_subdirectory(jpeglossless)
add_subdirectory(rawconverter)