aboutsummaryrefslogtreecommitdiff
path: root/graphics/kipi-plugins-kde4
diff options
context:
space:
mode:
authorKris Moore <kmoore@FreeBSD.org>2009-10-01 20:15:42 +0000
committerKris Moore <kmoore@FreeBSD.org>2009-10-01 20:15:42 +0000
commit2b8658b0cb15f566b6eed6d129828884c7d8110b (patch)
tree0025d6e09be240e18408e8844ff41d1fe77b8139 /graphics/kipi-plugins-kde4
parent356bd1b264d8a09ef0db4eba39be051fd0b29afb (diff)
downloadports-2b8658b0cb15f566b6eed6d129828884c7d8110b.tar.gz
ports-2b8658b0cb15f566b6eed6d129828884c7d8110b.zip
Notes
Diffstat (limited to 'graphics/kipi-plugins-kde4')
-rw-r--r--graphics/kipi-plugins-kde4/Makefile5
-rw-r--r--graphics/kipi-plugins-kde4/distinfo6
-rw-r--r--graphics/kipi-plugins-kde4/files/patch-CMakeLists.txt88
-rw-r--r--graphics/kipi-plugins-kde4/pkg-plist22
4 files changed, 38 insertions, 83 deletions
diff --git a/graphics/kipi-plugins-kde4/Makefile b/graphics/kipi-plugins-kde4/Makefile
index c39504df53fe..6bb8a272ae7b 100644
--- a/graphics/kipi-plugins-kde4/Makefile
+++ b/graphics/kipi-plugins-kde4/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= kipi-plugins
-PORTVERSION= 0.5.0
+PORTVERSION= 0.7.0
PORTEPOCH= 1
CATEGORIES= graphics kde
MASTER_SITES= SF/kipi/${PORTNAME}/${PORTVERSION}
-PKGNAMESUFFIX= -kde4
MAINTAINER= kris@pcbsd.org
COMMENT= KDE4 kipi graphics plugins
@@ -19,6 +18,8 @@ LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
kipi.6:${PORTSDIR}/graphics/kdegraphics4
RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
+LATEST_LINK= ${PORTNAME}-kde4
+
USE_BZIP2= yes
USE_CMAKE= yes
USE_GETTEXT= yes
diff --git a/graphics/kipi-plugins-kde4/distinfo b/graphics/kipi-plugins-kde4/distinfo
index 84d388c1b994..c74d5324f283 100644
--- a/graphics/kipi-plugins-kde4/distinfo
+++ b/graphics/kipi-plugins-kde4/distinfo
@@ -1,3 +1,3 @@
-MD5 (kipi-plugins-0.5.0.tar.bz2) = f82c95b85f2b434fd03b99451ec5081e
-SHA256 (kipi-plugins-0.5.0.tar.bz2) = 6d349d7b156617603dadfe88d6a62b42bea083d9e15ef200f40d7f4d7d64c6e9
-SIZE (kipi-plugins-0.5.0.tar.bz2) = 3711696
+MD5 (kipi-plugins-0.7.0.tar.bz2) = 564e766f7afac6169ff0cc591667183c
+SHA256 (kipi-plugins-0.7.0.tar.bz2) = 81b68b5f8250508af4e93e7f59720484d62d97d7e38957a305633e74e3bff568
+SIZE (kipi-plugins-0.7.0.tar.bz2) = 3781114
diff --git a/graphics/kipi-plugins-kde4/files/patch-CMakeLists.txt b/graphics/kipi-plugins-kde4/files/patch-CMakeLists.txt
index 75ed0f2000ee..be60c16fa71f 100644
--- a/graphics/kipi-plugins-kde4/files/patch-CMakeLists.txt
+++ b/graphics/kipi-plugins-kde4/files/patch-CMakeLists.txt
@@ -1,79 +1,11 @@
---- ./CMakeLists.txt.orig 2009-03-17 04:59:48.000000000 -0400
-+++ ./CMakeLists.txt 2009-06-08 04:36:50.000000000 -0400
-@@ -32,15 +32,53 @@
- INCLUDE(FindPackageHandleStandardArgs)
- INCLUDE(KDE4Defaults)
- INCLUDE(MacroLibrary)
-+INCLUDE(FindPkgConfig)
-
- # Depencies detection required by all plugins
--FIND_PACKAGE(Kexiv2 REQUIRED)
--FIND_PACKAGE(Kdcraw REQUIRED)
--FIND_PACKAGE(Kipi REQUIRED)
- FIND_PACKAGE(JPEG REQUIRED)
- FIND_PACKAGE(PNG REQUIRED)
- FIND_PACKAGE(TIFF REQUIRED)
-
-+# Check for KExiv2
-+PKG_CHECK_MODULES(LIBKEXIV2 libkexiv2-kde4>=0.5.0)
-+FIND_PATH(KEXIV2_INCLUDE_DIR NAMES libkexiv2/version.h
-+ PATHS ${LIBKEXIV2_INCLUDE_DIRS} ${KDE4_INCLUDE_DIR} NO_DEFAULT_PATH)
-+FIND_LIBRARY(KEXIV2_LIBRARY NAMES kexiv2
-+ PATHS ${LIBKEXIV2_LIBRARY_DIRS} ${KDE4_LIB_DIR} NO_DEFAULT_PATH)
-+
-+FIND_PACKAGE_HANDLE_STANDARD_ARGS(KEXIV2 DEFAULT_MSG KEXIV2_LIBRARY KEXIV2_INCLUDE_DIR)
-+
-+IF(KEXIV2_FOUND)
-+ SET(KEXIV2_LIBRARIES ${KEXIV2_LIBRARY})
-+ENDIF(KEXIV2_FOUND)
-+
-+# Check for Kdcraw
-+PKG_CHECK_MODULES(LIBKDCRAW libkdcraw-kde4>=0.4.0)
-+FIND_PATH(KDCRAW_INCLUDE_DIR NAMES libkdcraw/version.h
-+ PATHS ${LIBKDCRAW_INCLUDE_DIRS} ${KDE4_INCLUDE_DIR} NO_DEFAULT_PATH)
-+FIND_LIBRARY(KDCRAW_LIBRARY NAMES kdcraw
-+ PATHS ${LIBKDCRAW_LIBRARY_DIRS} ${KDE4_LIB_DIR} NO_DEFAULT_PATH)
-+
-+FIND_PACKAGE_HANDLE_STANDARD_ARGS(KDCRAW DEFAULT_MSG KDCRAW_LIBRARY KDCRAW_INCLUDE_DIR)
-+
-+IF(KDCRAW_FOUND)
-+ SET(KDCRAW_LIBRARIES ${KDCRAW_LIBRARY})
-+ SET(KDCRAW_FOR_DNGCONVERTER TRUE)
-+ENDIF(KDCRAW_FOUND)
-+
-+# Check for Kipi
-+PKG_CHECK_MODULES(LIBKIPI libkipi-kde4>=0.2.0)
-+FIND_PATH(KIPI_INCLUDE_DIR NAMES libkipi/version.h
-+ PATHS ${LIBKIPI_INCLUDE_DIRS} ${KDE4_INCLUDE_DIR} NO_DEFAULT_PATH)
-+FIND_LIBRARY(KIPI_LIBRARY NAMES kipi
-+ PATHS ${LIBKIPI_LIBRARY_DIRS} ${KDE4_LIB_DIR} NO_DEFAULT_PATH)
-+
-+FIND_PACKAGE_HANDLE_STANDARD_ARGS(KIPI DEFAULT_MSG KIPI_LIBRARY KIPI_INCLUDE_DIR)
-+
-+IF(KIPI_FOUND)
-+ SET(KIPI_LIBRARIES ${KIPI_LIBRARY})
-+ENDIF(KIPI_FOUND)
-+
- # Optional depencies detection required by some plugins
-
- SET(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules)
-@@ -63,19 +101,6 @@
- MACRO_OPTIONAL_FIND_PACKAGE(X11) # For AdvancedSlideshow and ImageViewer.
- ENDIF(NOT WIN32 AND NOT APPLE)
-
--IF(NOT WIN32)
-- # Check KDcraw version installed to compile fine DngConverter plugin.
-- FIND_PACKAGE(PkgConfig)
+--- ./CMakeLists.txt.orig 2009-09-24 19:01:31.000000000 -0400
++++ ./CMakeLists.txt 2009-09-24 19:01:48.000000000 -0400
+@@ -69,7 +69,7 @@
+ IF(NOT WIN32)
+ # Check KDcraw version installed to compile fine DngConverter plugin.
+ FIND_PACKAGE(PkgConfig)
- PKG_CHECK_MODULES(Kdcraw libkdcraw>=0.4.0)
-- IF(Kdcraw_FOUND)
-- SET(KDCRAW_FOR_DNGCONVERTER TRUE)
-- ELSE(Kdcraw_FOUND)
-- SET(KDCRAW_FOR_DNGCONVERTER FALSE)
-- ENDIF(Kdcraw_FOUND)
--ELSE(NOT WIN32)
-- SET(KDCRAW_FOR_DNGCONVERTER TRUE)
--ENDIF(NOT WIN32)
--
- INCLUDE(MacroOptionalDependPackage)
-
- # LINUX Only.
++ PKG_CHECK_MODULES(Kdcraw libkdcraw-kde4>=0.4.0)
+ IF(Kdcraw_FOUND)
+ SET(KDCRAW_FOR_DNGCONVERTER TRUE)
+ ELSE(Kdcraw_FOUND)
diff --git a/graphics/kipi-plugins-kde4/pkg-plist b/graphics/kipi-plugins-kde4/pkg-plist
index e4487765fea0..3e20a3a71f12 100644
--- a/graphics/kipi-plugins-kde4/pkg-plist
+++ b/graphics/kipi-plugins-kde4/pkg-plist
@@ -41,14 +41,19 @@ share/apps/kipiplugin_flashexport/index.template
share/apps/kipiplugin_flashexport/simpleviewer_html/space.png
share/apps/kipiplugin_flickrexport/icons/hicolor/16x16/actions/flickr.png
share/apps/kipiplugin_flickrexport/icons/hicolor/16x16/actions/hq.png
+share/apps/kipiplugin_flickrexport/icons/hicolor/16x16/actions/zooomr.png
share/apps/kipiplugin_flickrexport/icons/hicolor/22x22/actions/flickr.png
share/apps/kipiplugin_flickrexport/icons/hicolor/22x22/actions/hq.png
+share/apps/kipiplugin_flickrexport/icons/hicolor/22x22/actions/zooomr.png
share/apps/kipiplugin_flickrexport/icons/hicolor/32x32/actions/flickr.png
share/apps/kipiplugin_flickrexport/icons/hicolor/32x32/actions/hq.png
+share/apps/kipiplugin_flickrexport/icons/hicolor/32x32/actions/zooomr.png
share/apps/kipiplugin_flickrexport/icons/hicolor/48x48/actions/flickr.png
share/apps/kipiplugin_flickrexport/icons/hicolor/48x48/actions/hq.png
+share/apps/kipiplugin_flickrexport/icons/hicolor/48x48/actions/zooomr.png
share/apps/kipiplugin_flickrexport/icons/hicolor/scalable/actions/flickr.svgz
share/apps/kipiplugin_flickrexport/icons/hicolor/scalable/actions/hq.svgz
+share/apps/kipiplugin_flickrexport/icons/hicolor/scalable/actions/zooomr.svgz
share/apps/kipiplugin_galleryexport/icons/hicolor/16x16/actions/gallery.png
share/apps/kipiplugin_galleryexport/icons/hicolor/22x22/actions/gallery.png
share/apps/kipiplugin_galleryexport/icons/hicolor/32x32/actions/gallery.png
@@ -70,6 +75,8 @@ share/apps/kipiplugin_htmlexport/themes/cleanframes/red.css
share/apps/kipiplugin_htmlexport/themes/cleanframes/star.png
share/apps/kipiplugin_htmlexport/themes/cleanframes/template.xsl
share/apps/kipiplugin_htmlexport/themes/cleanframes/yellow.css
+share/apps/kipiplugin_htmlexport/themes/dateframes/dateframes.desktop
+share/apps/kipiplugin_htmlexport/themes/dateframes/template.xsl
share/apps/kipiplugin_htmlexport/themes/frames/frames.desktop
share/apps/kipiplugin_htmlexport/themes/frames/style.css
share/apps/kipiplugin_htmlexport/themes/frames/template.xsl
@@ -344,13 +351,25 @@ share/locale/en_GB/LC_MESSAGES/kipiplugin_wallpaper.mo
share/locale/en_GB/LC_MESSAGES/kipiplugins.mo
share/locale/es/LC_MESSAGES/kipiplugin_acquireimages.mo
share/locale/es/LC_MESSAGES/kipiplugin_advancedslideshow.mo
+share/locale/es/LC_MESSAGES/kipiplugin_batchprocessimages.mo
+share/locale/es/LC_MESSAGES/kipiplugin_calendar.mo
+share/locale/es/LC_MESSAGES/kipiplugin_dngconverter.mo
+share/locale/es/LC_MESSAGES/kipiplugin_facebook.mo
share/locale/es/LC_MESSAGES/kipiplugin_flashexport.mo
+share/locale/es/LC_MESSAGES/kipiplugin_flickrexport.mo
+share/locale/es/LC_MESSAGES/kipiplugin_galleryexport.mo
share/locale/es/LC_MESSAGES/kipiplugin_gpssync.mo
share/locale/es/LC_MESSAGES/kipiplugin_htmlexport.mo
+share/locale/es/LC_MESSAGES/kipiplugin_imageviewer.mo
+share/locale/es/LC_MESSAGES/kipiplugin_ipodexport.mo
share/locale/es/LC_MESSAGES/kipiplugin_jpeglossless.mo
share/locale/es/LC_MESSAGES/kipiplugin_metadataedit.mo
+share/locale/es/LC_MESSAGES/kipiplugin_picasawebexport.mo
+share/locale/es/LC_MESSAGES/kipiplugin_printimages.mo
share/locale/es/LC_MESSAGES/kipiplugin_rawconverter.mo
+share/locale/es/LC_MESSAGES/kipiplugin_removeredeyes.mo
share/locale/es/LC_MESSAGES/kipiplugin_sendimages.mo
+share/locale/es/LC_MESSAGES/kipiplugin_smug.mo
share/locale/es/LC_MESSAGES/kipiplugin_timeadjust.mo
share/locale/es/LC_MESSAGES/kipiplugin_wallpaper.mo
share/locale/es/LC_MESSAGES/kipiplugins.mo
@@ -378,9 +397,11 @@ share/locale/et/LC_MESSAGES/kipiplugin_smug.mo
share/locale/et/LC_MESSAGES/kipiplugin_timeadjust.mo
share/locale/et/LC_MESSAGES/kipiplugin_wallpaper.mo
share/locale/et/LC_MESSAGES/kipiplugins.mo
+share/locale/fi/LC_MESSAGES/kipiplugin_facebook.mo
share/locale/fi/LC_MESSAGES/kipiplugin_gpssync.mo
share/locale/fi/LC_MESSAGES/kipiplugin_jpeglossless.mo
share/locale/fi/LC_MESSAGES/kipiplugin_metadataedit.mo
+share/locale/fi/LC_MESSAGES/kipiplugin_printimages.mo
share/locale/fi/LC_MESSAGES/kipiplugin_rawconverter.mo
share/locale/fi/LC_MESSAGES/kipiplugin_sendimages.mo
share/locale/fi/LC_MESSAGES/kipiplugin_wallpaper.mo
@@ -1026,6 +1047,7 @@ share/locale/zh_TW/LC_MESSAGES/kipiplugins.mo
@dirrm share/apps/kipiplugin_htmlexport/themes/s0
@dirrm share/apps/kipiplugin_htmlexport/themes/matrix
@dirrm share/apps/kipiplugin_htmlexport/themes/frames
+@dirrm share/apps/kipiplugin_htmlexport/themes/dateframes
@dirrm share/apps/kipiplugin_htmlexport/themes/cleanframes
@dirrm share/apps/kipiplugin_htmlexport/themes/classic
@dirrm share/apps/kipiplugin_htmlexport/themes