aboutsummaryrefslogtreecommitdiff
path: root/graphics/kisomandel
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-09-01 16:07:59 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-09-01 16:07:59 +0000
commit534fffca27bb18f7529d548c46ee3326505a89c7 (patch)
treea09ac440edd299d85a3517dea62caa2b115543fc /graphics/kisomandel
parent5bc499ce47fa1a8da853b36cc61cddf06075d203 (diff)
downloadports-534fffca27bb18f7529d548c46ee3326505a89c7.tar.gz
ports-534fffca27bb18f7529d548c46ee3326505a89c7.zip
Notes
Diffstat (limited to 'graphics/kisomandel')
-rw-r--r--graphics/kisomandel/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/graphics/kisomandel/Makefile b/graphics/kisomandel/Makefile
index bf894a13fc7b..c63a0dd58c36 100644
--- a/graphics/kisomandel/Makefile
+++ b/graphics/kisomandel/Makefile
@@ -16,15 +16,16 @@ MAINTAINER= kde@freebsd.org
LIB_DEPENDS= png:${PORTSDIR}/graphics/png
USE_BZIP2= yes
+USE_REINPLACE= yes
USE_QT_VER= 2
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GMAKE= yes
post-patch:
- @${PERL} -pi -e "s,-lqt,-lqt2,g" ${WRKSRC}/configure
- @find ${WRKSRC} -name Makefile.in | xargs \
- ${PERL} -pi -e "s,-lqt,-lqt2,g"
- @${PERL} -pi -e "s,malloc.h,stdlib.h,g" ${WRKSRC}/kisomandel/fractal.cpp
+ @${REINPLACE_CMD} -e "s,-lqt,-lqt2,g" ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
+ ${REINPLACE_CMD} -e "s,-lqt,-lqt2,g"
+ @${REINPLACE_CMD} -e "s,malloc.h,stdlib.h,g" ${WRKSRC}/kisomandel/fractal.cpp
.include <bsd.port.mk>