aboutsummaryrefslogtreecommitdiff
path: root/graphics/kooka
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-08-11 01:27:37 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-08-11 01:27:37 +0000
commit461f3c5adb635525af6de102321df3e6288bfb1c (patch)
tree2025e3327a038c580b6f13bdc201e220e2077bb4 /graphics/kooka
parent5036b1c6d43d4a6652f933702bfcc8b3553fddfd (diff)
Notes
Diffstat (limited to 'graphics/kooka')
-rw-r--r--graphics/kooka/Makefile41
-rw-r--r--graphics/kooka/distinfo2
-rw-r--r--graphics/kooka/pkg-descr11
-rw-r--r--graphics/kooka/pkg-plist55
4 files changed, 109 insertions, 0 deletions
diff --git a/graphics/kooka/Makefile b/graphics/kooka/Makefile
new file mode 100644
index 000000000000..46c5f5fdff35
--- /dev/null
+++ b/graphics/kooka/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: kooka
+# Date created: July 09 2004
+# Whom: Michael Nottebrock <lofi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kooka
+PORTVERSION= ${KDE_VERSION}
+CATEGORIES= graphics kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
+PKGNAMEPREFIX= kdegraphics-
+DISTNAME= kdegraphics-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Raster image scan program for KDE
+
+LIB_DEPENDS= sane.1:${PORTSDIR}/graphics/sane-backends
+RUN_DEPENDS= ${LOCALBASE}/bin/gocr:${PORTSDIR}/graphics/gocr
+
+CONFLICTS= kdegraphics-3.1.* kdegraphics-3.2.[0-3]
+
+USE_KDELIBS_VER=3
+PREFIX= ${KDE_PREFIX}
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/kdegraphics-${PORTVERSION}
+INSTALLS_SHLIB= yes
+
+pre-configure:
+ ${ECHO_CMD} libkscan ${PORTNAME} doc > ${WRKSRC}/inst-apps
+ ${REINPLACE_CMD} \
+ 's|^SUBDIRS =.*${PORTNAME}.*$$|SUBDIRS =\. ${PORTNAME}|g' \
+ ${WRKSRC}/doc/Makefile.in
+
+.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+.include <bsd.port.mk>
diff --git a/graphics/kooka/distinfo b/graphics/kooka/distinfo
new file mode 100644
index 000000000000..a53ab49a4820
--- /dev/null
+++ b/graphics/kooka/distinfo
@@ -0,0 +1,2 @@
+MD5 (KDE/kdegraphics-3.2.3.tar.bz2) = af7092f2afc5a8565eb5017ecee6b67e
+SIZE (KDE/kdegraphics-3.2.3.tar.bz2) = 5676995
diff --git a/graphics/kooka/pkg-descr b/graphics/kooka/pkg-descr
new file mode 100644
index 000000000000..f3f3d8c8cb39
--- /dev/null
+++ b/graphics/kooka/pkg-descr
@@ -0,0 +1,11 @@
+Kooka is an intuitive, easy to use open source GNU/Linux scan program
+which is released under the GNU General Public License with exceptions.
+
+Kooka is the scan application of choice for the KDE project and
+thus it is official part of the KDE Graphics Package.
+
+Kooka helps you to handle the most important scan parameters, find
+the correct image file format to save and manage your scanned images.
+It offers support for different OCR modules. Libkscan, a autonomous
+part of Kooka, provides a scan service for easy and consistent use
+to all KDE applications.
diff --git a/graphics/kooka/pkg-plist b/graphics/kooka/pkg-plist
new file mode 100644
index 000000000000..907d6cf5dd4d
--- /dev/null
+++ b/graphics/kooka/pkg-plist
@@ -0,0 +1,55 @@
+bin/kooka
+include/devselector.h
+include/dispgamma.h
+include/gammadialog.h
+include/img_canvas.h
+include/imgscaledialog.h
+include/kgammatable.h
+include/kscandevice.h
+include/kscanoption.h
+include/kscanoptset.h
+include/kscanslider.h
+include/massscandialog.h
+include/previewer.h
+include/scanparams.h
+include/scansourcedialog.h
+include/sizeindicator.h
+lib/libkscan.la
+lib/libkscan.so
+lib/libkscan.so.1
+share/applications/kde/kooka.desktop
+share/apps/kooka/kookaui.rc
+share/apps/kooka/pics/gocr.png
+share/apps/kooka/pics/lockzoom.png
+share/apps/kooka/pics/mirror-both.png
+share/apps/kooka/pics/mirror-horiz.png
+share/apps/kooka/pics/mirror-vert.png
+share/apps/kooka/pics/newfromselect.png
+share/apps/kooka/pics/ocr-select.png
+share/apps/kooka/pics/ocr.png
+share/apps/kooka/pics/ocrad.png
+share/apps/kooka/pics/scaleorig.png
+share/apps/kooka/pics/scaletoheight.png
+share/apps/kooka/pics/scaletowidth.png
+share/apps/kooka/pics/thumbviewtile.png
+share/config/kookarc
+share/doc/HTML/en/kooka/common
+share/doc/HTML/en/kooka/index.cache.bz2
+share/doc/HTML/en/kooka/index.docbook
+share/doc/HTML/en/kooka/kooka_gocr.png
+share/doc/HTML/en/kooka/kooka_gocr_result.png
+share/doc/HTML/en/kooka/kooka_mainctrl.png
+share/doc/HTML/en/kooka/ocr-select.png
+share/doc/HTML/en/kooka/shortcut0.png
+share/doc/HTML/en/kooka/shortcut1.png
+share/doc/HTML/en/kooka/toolbar.png
+share/doc/HTML/en/kooka/toolbar1.png
+share/doc/HTML/en/kooka/toolbar2.png
+share/icons/crystalsvg/16x16/actions/palette_color.png
+share/icons/crystalsvg/16x16/actions/palette_gray.png
+share/icons/crystalsvg/16x16/actions/palette_halftone.png
+share/icons/crystalsvg/16x16/actions/palette_lineart.png
+share/services/scanservice.desktop
+@dirrm share/doc/HTML/en/kooka
+@dirrm share/apps/kooka/pics
+@dirrm share/apps/kooka