aboutsummaryrefslogtreecommitdiff
path: root/graphics/kphotoalbum-kde4
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-04-19 09:45:59 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-04-19 09:45:59 +0000
commitad7699c582859a99e2995870e9a5191e726c72f4 (patch)
treee0b0f4d78e3ce5bf36eea3a5659616cc3bd4be85 /graphics/kphotoalbum-kde4
parentfeb3a2a2e660a73ea78278caa18ce81726a8a191 (diff)
downloadports-ad7699c582859a99e2995870e9a5191e726c72f4.tar.gz
ports-ad7699c582859a99e2995870e9a5191e726c72f4.zip
Notes
Diffstat (limited to 'graphics/kphotoalbum-kde4')
-rw-r--r--graphics/kphotoalbum-kde4/Makefile14
-rw-r--r--graphics/kphotoalbum-kde4/files/patch-Exif__Info.cpp47
2 files changed, 53 insertions, 8 deletions
diff --git a/graphics/kphotoalbum-kde4/Makefile b/graphics/kphotoalbum-kde4/Makefile
index 1ecb83805cb6..5d2937a91a50 100644
--- a/graphics/kphotoalbum-kde4/Makefile
+++ b/graphics/kphotoalbum-kde4/Makefile
@@ -6,7 +6,7 @@
PORTNAME= kphotoalbum
PORTVERSION= ${APP_VER}.${EXTRA_VER}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${EXTRA_VER}/src/extragear
@@ -16,7 +16,9 @@ DIST_SUBDIR= KDE/extragear
MAINTAINER= kde@FreeBSD.org
COMMENT= Image viewer and organizer for KDE
-LIB_DEPENDS= kipi.8:${PORTSDIR}/graphics/kdegraphics4
+LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
+ exiv2.10:${PORTSDIR}/graphics/exiv2 \
+ kipi.8:${PORTSDIR}/graphics/kdegraphics4
USE_BZIP2= yes
USE_KDE4= kdelibs kdeprefix kdehier automoc4
@@ -36,12 +38,8 @@ OPTIONS= MARBLE "Geolocation support (requires astro/marble)" off
.if defined(WITH_MARBLE)
LIB_DEPENDS+= marblewidget.11:${PORTSDIR}/astro/marble
-.endif
-
-pre-configure:
-.if !defined(WITH_MARBLE)
- ${REINPLACE_CMD} -e '/macro_optional_find_package(Marble)/d' \
- ${WRKSRC}/CMakeLists.txt
+.else
+CMAKE_ARGS+= -DWITH_Marble:BOOL=Off
.endif
.include <bsd.port.mk>
diff --git a/graphics/kphotoalbum-kde4/files/patch-Exif__Info.cpp b/graphics/kphotoalbum-kde4/files/patch-Exif__Info.cpp
new file mode 100644
index 000000000000..9cdb6baecdb3
--- /dev/null
+++ b/graphics/kphotoalbum-kde4/files/patch-Exif__Info.cpp
@@ -0,0 +1,47 @@
+--- ./Exif/Info.cpp.orig 2010-02-11 22:44:01.000000000 +0100
++++ ./Exif/Info.cpp 2011-04-19 10:47:27.975620628 +0200
+@@ -106,6 +106,28 @@
+ return res;
+
+ QList<const Exiv2::TagInfo*> tags;
++ std::ostringstream s;
++
++#if (EXIV2_TEST_VERSION(0,21,0))
++ const Exiv2::GroupInfo* gi = Exiv2::ExifTags::groupList();
++ while (gi->tagList_ != 0) {
++ Exiv2::TagListFct tl = gi->tagList_;
++ const Exiv2::TagInfo* ti = tl();
++
++ while (ti->tag_ != 0xFFFF) {
++ tags << ti;
++ ++ti;
++ }
++ ++gi;
++ }
++
++ for (QList<const Exiv2::TagInfo*>::iterator it = tags.begin(); it != tags.end(); ++it) {
++ while ( (*it)->tag_ != 0xffff ) {
++ res.insert(QString::fromLatin1(Exiv2::ExifKey(**it).key().c_str()));
++ ++(*it);
++ }
++ }
++#else
+ tags <<
+ Exiv2::ExifTags::ifdTagList() <<
+ Exiv2::ExifTags::exifTagList() <<
+@@ -121,7 +143,6 @@
+ // Now the ugly part -- exiv2 doesn't have any way to get a list of
+ // MakerNote tags in a reasonable form, so we have to parse it from strings
+
+- std::ostringstream s;
+ for ( Exiv2::IfdId kind = Exiv2::canonIfdId; kind < Exiv2::lastIfdId;
+ kind = static_cast<Exiv2::IfdId>( kind + 1 ) ) {
+ #if EXIV2_TEST_VERSION(0,17,0)
+@@ -130,6 +151,7 @@
+ Exiv2::ExifTags::makerTaglist( s, kind );
+ #endif
+ }
++#endif
+
+ // IPTC tags use yet another format...
+ Exiv2::IptcDataSets::dataSetList( s );