aboutsummaryrefslogtreecommitdiff
path: root/graphics/lcdtest/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-03-09 22:33:19 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-03-09 22:33:19 +0000
commitb5138f61bb1f540d6a76ab9f7829b5613d44978a (patch)
tree4e9dd9fbd32a1b024a1c759fa3ee2e470620c1d6 /graphics/lcdtest/Makefile
parent894d59821d55cc7007c5d7c79dec622733899340 (diff)
downloadports-b5138f61bb1f540d6a76ab9f7829b5613d44978a.tar.gz
ports-b5138f61bb1f540d6a76ab9f7829b5613d44978a.zip
Notes
Diffstat (limited to 'graphics/lcdtest/Makefile')
-rw-r--r--graphics/lcdtest/Makefile27
1 files changed, 16 insertions, 11 deletions
diff --git a/graphics/lcdtest/Makefile b/graphics/lcdtest/Makefile
index 76a895836733..1b07ab4aa40d 100644
--- a/graphics/lcdtest/Makefile
+++ b/graphics/lcdtest/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= lcdtest
-PORTVERSION= 1.08
-PORTREVISION= 2
+PORTVERSION= 1.18
CATEGORIES= graphics
MASTER_SITES= http://www.brouhaha.com/~eric/software/lcdtest/download/ \
http://www.predatorlabs.net/dl/
@@ -15,23 +14,29 @@ MASTER_SITES= http://www.brouhaha.com/~eric/software/lcdtest/download/ \
MAINTAINER= rfarmer@predatorlabs.net
COMMENT= LCD monitor test pattern generator
-BUILD_DEPENDS= pngtopnm:${PORTSDIR}/graphics/netpbm
+RUN_DEPENDS= ${LOCALBASE}/lib/X11/fonts/Liberation/LiberationMono-Bold.ttf:${PORTSDIR}/x11-fonts/liberation-fonts-ttf
-USE_SDL= sdl image
+USE_SDL= sdl image ttf
-CFLAGS= -I${LOCALBASE}/include
-LINKFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-
-USE_SCONS= yes
-SCONS_ENV= CFLAGS="${CFLAGS}" LINKFLAGS="${LINKFLAGS}" CC="${CC}"
-SCONS_ARGS= bindir=${PREFIX}/bin mandir=${PREFIX}/man/man1
+CFLAGS+= -I${LOCALBASE}/include -DRELEASE=1.18
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lSDL -lSDL_image -lSDL_ttf
PLIST_FILES= bin/lcdtest
PORTDOCS= README
MAN1= lcdtest.1
-post-install:
+post-patch:
+ ${REINPLACE_CMD} -e 's|/usr/share/fonts/liberation/|${LOCALBASE}/lib/X11/fonts/Liberation/|' \
+ ${WRKSRC}/src/lcdtest.c
+
+do-build:
+ (cd ${WRKSRC}/src && ${CC} ${CFLAGS} -o lcdtest.o -c lcdtest.c)
+ (cd ${WRKSRC}/src && ${CC} ${LDFLAGS} -o lcdtest lcdtest.o)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/lcdtest ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/lcdtest.1 ${PREFIX}/man/man1
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}/
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/