aboutsummaryrefslogtreecommitdiff
path: root/graphics/lcdtest
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-12-29 09:39:48 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-12-29 09:39:48 +0000
commitdd33abfe38d1a14e0db6d1e325fc826854410c22 (patch)
treea3db1e63f48fd34c838ff49973b944b50626889d /graphics/lcdtest
parent60261a550f2d6d1a1897c160e0f61b9456112e12 (diff)
downloadports-dd33abfe38d1a14e0db6d1e325fc826854410c22.tar.gz
ports-dd33abfe38d1a14e0db6d1e325fc826854410c22.zip
- Add LICENSE_FILE
- Simplify building - Switch to options helpers
Notes
Notes: svn path=/head/; revision=429884
Diffstat (limited to 'graphics/lcdtest')
-rw-r--r--graphics/lcdtest/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/graphics/lcdtest/Makefile b/graphics/lcdtest/Makefile
index 42b2d110b3fb..8d6ce9ddddb3 100644
--- a/graphics/lcdtest/Makefile
+++ b/graphics/lcdtest/Makefile
@@ -15,20 +15,19 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= LCD monitor test pattern generator
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= liberation-fonts-ttf>0:x11-fonts/liberation-fonts-ttf
USE_SDL= sdl image ttf
-CFLAGS+= -I${LOCALBASE}/include -DRELEASE=1.18
-LDFLAGS+= -L${LOCALBASE}/lib -lpthread -lSDL -lSDL_image -lSDL_ttf
-
PLIST_FILES= bin/${PORTNAME} \
man/man1/${PORTNAME}.1.gz \
share/applications/${PORTNAME}.desktop \
share/pixmaps/${PORTNAME}.png
PORTDOCS= README
+
OPTIONS_DEFINE= DOCS
post-patch:
@@ -37,8 +36,11 @@ post-patch:
${WRKSRC}/src/lcdtest.c
do-build:
- (cd ${WRKSRC}/src && ${CC} ${CFLAGS} -o lcdtest.o -c lcdtest.c)
- (cd ${WRKSRC}/src && ${CC} ${LDFLAGS} -o lcdtest lcdtest.o)
+ cd ${WRKSRC}/src && \
+ ${CC} ${CFLAGS} ${LDFLAGS} `sdl-config --cflags --libs` \
+ -DRELEASE=${PORTVERSION} \
+ -lSDL_image -lSDL_ttf \
+ -o lcdtest lcdtest.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
@@ -48,6 +50,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/desktop/${PORTNAME}.desktop \
${STAGEDIR}${DESKTOPDIR}
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}