aboutsummaryrefslogtreecommitdiff
path: root/graphics/lcdtest
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-01-11 21:31:39 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-01-11 21:31:39 +0000
commit74d01f63d0dcf3c3625d761c4d22cb0e2462ba69 (patch)
treef7a7039467ed434468e5c6a4bc1d56807cd1f497 /graphics/lcdtest
parent4f01d882c1983e9fc4cc82701b418e2145e8445c (diff)
downloadports-74d01f63d0dcf3c3625d761c4d22cb0e2462ba69.tar.gz
ports-74d01f63d0dcf3c3625d761c4d22cb0e2462ba69.zip
Notes
Diffstat (limited to 'graphics/lcdtest')
-rw-r--r--graphics/lcdtest/Makefile30
-rw-r--r--graphics/lcdtest/distinfo6
-rw-r--r--graphics/lcdtest/files/patch-SConstruct11
-rw-r--r--graphics/lcdtest/files/patch-src-SConscript11
4 files changed, 39 insertions, 19 deletions
diff --git a/graphics/lcdtest/Makefile b/graphics/lcdtest/Makefile
index 3fe2fc812d8a..93031b4dfce9 100644
--- a/graphics/lcdtest/Makefile
+++ b/graphics/lcdtest/Makefile
@@ -6,34 +6,32 @@
#
PORTNAME= lcdtest
-PORTVERSION= 1.04
-PORTREVISION= 2
+PORTVERSION= 1.08
CATEGORIES= graphics
MASTER_SITES= http://www.brouhaha.com/~eric/software/lcdtest/download/ \
- CENKES
+ http://www.predatorlabs.net/dl/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= rfarmer@predatorlabs.net
COMMENT= LCD monitor test pattern generator
BUILD_DEPENDS= pngtopnm:${PORTSDIR}/graphics/netpbm
-USE_GMAKE= yes
USE_SDL= sdl image
+
CFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-MAKE_ENV= LDFLAGS="${LDFLAGS}"
-MAKE_ARGS= -o SDL/SDL.h -o SDL/SDL_image.h
+LINKFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
+USE_SCONS= yes
+SCONS_ENV= CFLAGS="${CFLAGS}" LINKFLAGS="${LINKFLAGS}" CC="${CC}"
+SCONS_ARGS= bindir=${PREFIX}/bin mandir=${PREFIX}/man/man1
+
PLIST_FILES= bin/lcdtest
PORTDOCS= README
-post-patch:
- @${REINPLACE_CMD} -e '/^CFLAGS =/s|=|+=|' ${WRKSRC}/Makefile
-
-do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/lcdtest ${PREFIX}/bin/
-.ifndef NOPORTDOCS
- @${INSTALL} -d ${DOCSDIR}/
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}/
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
.endif
.include <bsd.port.mk>
diff --git a/graphics/lcdtest/distinfo b/graphics/lcdtest/distinfo
index 7a00c1c62970..e2a81241240e 100644
--- a/graphics/lcdtest/distinfo
+++ b/graphics/lcdtest/distinfo
@@ -1,3 +1,3 @@
-MD5 (lcdtest-1.04.tar.gz) = 7a5a34206438b628b8e5aea3da2ed84a
-SHA256 (lcdtest-1.04.tar.gz) = 265327fb4a6e8b816966f858bfa882bae30bf44ab186b7bb1dc7da6b41b680f8
-SIZE (lcdtest-1.04.tar.gz) = 27018
+MD5 (lcdtest-1.08.tar.gz) = 0e73a7e25645e79ddbc84560f40e2738
+SHA256 (lcdtest-1.08.tar.gz) = f4cc00b90505ccc2f379d0f481a761ca11f7622abbb078430b595cf3aa287d29
+SIZE (lcdtest-1.08.tar.gz) = 30762
diff --git a/graphics/lcdtest/files/patch-SConstruct b/graphics/lcdtest/files/patch-SConstruct
index 78de12269d03..7916aa9a8d7d 100644
--- a/graphics/lcdtest/files/patch-SConstruct
+++ b/graphics/lcdtest/files/patch-SConstruct
@@ -9,3 +9,14 @@
opts.Update (env)
opts.Save (conf_file, env)
+--- SConstruct.orig 2007-06-05 16:38:23.000000000 -0700
++++ SConstruct 2009-10-26 14:22:35.000000000 -0700
+@@ -50,7 +50,7 @@
+ # Cache options
+ #-----------------------------------------------------------------------------
+
+-env = Environment (options = opts)
++env = Environment (**ARGUMENTS)
+ opts.Update (env)
+ opts.Save (conf_file, env)
+
diff --git a/graphics/lcdtest/files/patch-src-SConscript b/graphics/lcdtest/files/patch-src-SConscript
index 5be25705a62d..ec79ebd65911 100644
--- a/graphics/lcdtest/files/patch-src-SConscript
+++ b/graphics/lcdtest/files/patch-src-SConscript
@@ -9,3 +9,14 @@
env.PNG2PNM (target = 'help_font.ppm',
source = help_font_png)
+--- src/SConscript.orig 2009-10-26 15:30:35.000000000 -0700
++++ src/SConscript 2009-10-26 15:30:53.000000000 -0700
+@@ -40,7 +40,7 @@
+ src_suffix = '.ppm')
+
+ env.Append (BUILDERS = { 'PPM2C': PPM2C },
+- PPM2CCOM = "ppmtoxpm -name `basename $SOURCE .ppm`_xpm $SOURCE | sed 's/static //;s/black/#000000/;s/magenta/#FF00FF/;s/#E40808/#009900/' >$TARGET")
++ PPM2CCOM = "ppmtoxpm -name `basename $SOURCE .ppm`_xpm $SOURCE -hexonly | sed 's/static //;s/black/#000000/;s/magenta/#FF00FF/;s/#E40808/#009900/' >$TARGET")
+
+ env.PNG2PNM (target = 'help_font.ppm',
+ source = help_font_png)