aboutsummaryrefslogtreecommitdiff
path: root/graphics/lcms/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-23 19:08:26 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-23 19:08:26 +0000
commit56f284e72825a295fe94d1d211aa19e4aaefae27 (patch)
tree8655c4d20d9c94a0f739c10ec19afe30ef0a6622 /graphics/lcms/Makefile
parent0be207c7414d62e6d182bce5a1fea19371466c85 (diff)
downloadports-56f284e72825a295fe94d1d211aa19e4aaefae27.tar.gz
ports-56f284e72825a295fe94d1d211aa19e4aaefae27.zip
Notes
Diffstat (limited to 'graphics/lcms/Makefile')
-rw-r--r--graphics/lcms/Makefile37
1 files changed, 23 insertions, 14 deletions
diff --git a/graphics/lcms/Makefile b/graphics/lcms/Makefile
index c737966f63ca..bdc6a6d76a06 100644
--- a/graphics/lcms/Makefile
+++ b/graphics/lcms/Makefile
@@ -6,33 +6,42 @@
#
PORTNAME= lcms
-PORTVERSION= 1.09
-PORTREVISION= 1
+PORTVERSION= 1.12
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.littlecms.com/
-MASTER_SITE_SUBDIR=${PORTNAME}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Light Color Management System -- a color management library
+LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff
+
+USE_GNOME= gnometarget lthack
+USE_REINPLACE= yes
+USE_LIBTOOL_VER= 13
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --without-jpeg --without-tiff
INSTALLS_SHLIB= yes
-MAKEFILE= ${FILESDIR}/Makefile.bsd
-MAKE_ARGS+= -j2
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
-.ifndef NOPORTDOCS
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|^SUBDIRS =.*$$|SUBDIRS = src include|g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|-O3||g' ${WRKSRC}/src/Makefile.in
+
post-install:
- ${MKDIR} ${PREFIX}/share/doc/lcms
- ${CP} -rp ${WRKSRC}/../doc/* ${WRKSRC}/../tifficc/tifficc.c \
- ${WRKSRC}/../jpegicc/jpegicc.c ${WRKSRC}/../jpegicc/iccjpeg.c \
- ${WRKSRC}/../samples/wtpt.c ${WRKSRC}/../samples/icctrans.c \
- ${PREFIX}/share/doc/lcms/
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in doc/LCMSAPI.TXT doc/TUTORIAL.TXT tifficc/tifficc.c \
+ jpegicc/jpegicc.c jpegicc/iccjpeg.c samples/wtpt.c samples/icctrans.c
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
.endif
post-build test:
- cd ${WRKSRC}/../testbed && \
- ${SETENV} CFLAGS="${CFLAGS} -I../include" ${MAKE} -E CFLAGS test
+ cd ${WRKSRC}/testbed && ${SETENV} ${MAKE_ENV} ${MAKE} check
.include <bsd.port.mk>