aboutsummaryrefslogtreecommitdiff
path: root/graphics/lcms
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2000-11-03 17:03:33 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2000-11-03 17:03:33 +0000
commit1aae05025c55470327863435ab7085821e213487 (patch)
tree627621c26dd4eafef93e9cb7f1533389f1b08915 /graphics/lcms
parentfe925925a032ab59cde39bf9ac9914edc9a8b91c (diff)
downloadports-1aae05025c55470327863435ab7085821e213487.tar.gz
ports-1aae05025c55470327863435ab7085821e213487.zip
Notes
Diffstat (limited to 'graphics/lcms')
-rw-r--r--graphics/lcms/Makefile34
-rw-r--r--graphics/lcms/distinfo1
-rw-r--r--graphics/lcms/files/patch-aa40
-rw-r--r--graphics/lcms/files/patch-ab15
-rw-r--r--graphics/lcms/pkg-comment1
-rw-r--r--graphics/lcms/pkg-descr12
-rw-r--r--graphics/lcms/pkg-plist19
7 files changed, 122 insertions, 0 deletions
diff --git a/graphics/lcms/Makefile b/graphics/lcms/Makefile
new file mode 100644
index 000000000000..f347486a9f44
--- /dev/null
+++ b/graphics/lcms/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: lcms
+# Date created: October 30, 2000
+# Whom: Mikhail Teterin <mi@aldan.algebra.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lcms
+PORTVERSION= 1.06
+CATEGORIES= graphics
+MASTER_SITES= http://www.abaforum.es/martim/
+
+MAINTAINER= mi@aldan.algebra.com
+
+INSTALLS_SHLIB= yes
+
+GNU_CONFIGURE= yes
+
+post-build: test
+
+test:
+ cd ${WRKSRC}/profiles && ${WRKSRC}/testbed/testcms
+
+.ifndef NOPORTDOCS
+post-install:
+ ${MKDIR} ${PREFIX}/share/doc/lcms
+ ${CP} -rp ${WRKSRC}/doc/* ${PREFIX}/share/doc/lcms/
+
+PLIST_SUB= DOC=""
+.else
+PLIST_SUB= DOC="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/lcms/distinfo b/graphics/lcms/distinfo
new file mode 100644
index 000000000000..c9823311203c
--- /dev/null
+++ b/graphics/lcms/distinfo
@@ -0,0 +1 @@
+MD5 (lcms-1.06.tar.gz) = 7e0a3642b42628b1fc40c1702a5e71e0
diff --git a/graphics/lcms/files/patch-aa b/graphics/lcms/files/patch-aa
new file mode 100644
index 000000000000..ea6e464dd212
--- /dev/null
+++ b/graphics/lcms/files/patch-aa
@@ -0,0 +1,40 @@
+--- configure Thu May 18 20:08:40 2000
++++ configure Mon Oct 30 09:40:41 2000
+@@ -2259,35 +2259,13 @@
+
+ case "$host" in
+- i?86-pc-*)
++ i?86-*-*)
+ CFLAGS="$CFLAGS -fomit-frame-pointer"
+ ;;
+ esac
+
+-echo $ac_n "checking for __int64 type""... $ac_c" 1>&6
+-echo "configure:2268: checking for __int64 type" >&5
+-if test "$cross_compiling" = yes; then
+- echo "$ac_t""assuming no" 1>&6
+-else
+- cat > conftest.$ac_ext <<EOF
+-#line 2273 "configure"
+-#include "confdefs.h"
+-int main (void) { __int64 i = 0; return (i == 0);}
+-EOF
+-if { (eval echo configure:2277: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
+-then
++echo "using int64 on BSD" 1>&6
+ cat >> confdefs.h <<\EOF
+ #define USE_INT64 1
+ EOF
+-
+- echo "$ac_t""ok" 1>&6
+-else
+- echo "configure: failed program was:" >&5
+- cat conftest.$ac_ext >&5
+- rm -fr conftest*
+- echo "$ac_t""no" 1>&6
+-fi
+-rm -fr conftest*
+-fi
+-
+
+ echo $ac_n "checking for optimization""... $ac_c" 1>&6
diff --git a/graphics/lcms/files/patch-ab b/graphics/lcms/files/patch-ab
new file mode 100644
index 000000000000..4db3b692b82e
--- /dev/null
+++ b/graphics/lcms/files/patch-ab
@@ -0,0 +1,15 @@
+--- source/cmsmtrx.c Thu May 18 18:08:13 2000
++++ source/cmsmtrx.c Mon Oct 30 09:53:39 2000
+@@ -33,2 +33,3 @@
+ #include "lcms.h"
++#include <sys/types.h>
+
+@@ -250,3 +251,3 @@
+ #ifdef USE_INT64
+- __int64 l = (__int64) a * b + 0x8000i64;
++ u_int64_t l = (u_int64_t) a * b + (u_int64_t)0x8000;
+ return (Fixed32) (l >> 16);
+@@ -711,2 +712,2 @@
+ VEC3scaleAndCut(&r -> v[2], &v -> v[2], d);
+-}
++}
diff --git a/graphics/lcms/pkg-comment b/graphics/lcms/pkg-comment
new file mode 100644
index 000000000000..ed822224e73a
--- /dev/null
+++ b/graphics/lcms/pkg-comment
@@ -0,0 +1 @@
+Light Color Management System -- a color management library
diff --git a/graphics/lcms/pkg-descr b/graphics/lcms/pkg-descr
new file mode 100644
index 000000000000..e35a88b65b53
--- /dev/null
+++ b/graphics/lcms/pkg-descr
@@ -0,0 +1,12 @@
+LCMS is the Little Color Management System, a Color Matching Method
+(CMM) library which implements fast transforms between ICC profiles.
+It is released under LGPL with source code and meant to be portable.
+
+Color management refers to techniques that ensure consistent color
+as images are transferred from scanners or cameras to monitors and
+printers.
+
+WWW: http://www.abaforum.es/martim/lcms.htm
+
+Mikhail Teterin
+mi@aldan.algebra.com
diff --git a/graphics/lcms/pkg-plist b/graphics/lcms/pkg-plist
new file mode 100644
index 000000000000..56e4d2d62c0f
--- /dev/null
+++ b/graphics/lcms/pkg-plist
@@ -0,0 +1,19 @@
+include/lcms/lcms.h
+include/lcms/icc34.h
+@dirrm include/lcms
+lib/liblcms.a
+lib/liblcms.so.1
+lib/liblcms.so
+lib/liblcms.la
+bin/testcms
+%%DOC%%share/doc/lcms/README.simple
+%%DOC%%share/doc/lcms/filter.c
+%%DOC%%share/doc/lcms/jpgemb.c
+%%DOC%%share/doc/lcms/lcmsapi.txt
+%%DOC%%share/doc/lcms/neutral.c
+%%DOC%%share/doc/lcms/pngchrm.c
+%%DOC%%share/doc/lcms/simple.c
+%%DOC%%share/doc/lcms/tiffemb.c
+%%DOC%%share/doc/lcms/tutorial.txt
+%%DOC%%share/doc/lcms/wtpt.c
+%%DOC%%@dirrm share/doc/lcms/